Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qt-script, qt-core, qt-sdl, qt-dbus, qt-gui slot conflict
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5350
Location: France, Old Europe

PostPosted: Sun Aug 05, 2012 1:07 am    Post subject: Reply with quote

I'd suggest keeping the two issues separate.

I managed to get jpeg-turbo sorted out so post on that thread and I'll try to reply. (Post a link here since I may not still have a watch on that thread)

In relation to the qt mess, what's your problem with the fix summarised above? Your post seems more related to jpeg.
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.
Gentoo because I'm a masochist
AthlonXP-M on A7N8X. Portage ~x86
Back to top
View user's profile Send private message
dirtbag
Guru
Guru


Joined: 18 Feb 2003
Posts: 508
Location: NC

PostPosted: Sun Aug 05, 2012 3:36 pm    Post subject: Reply with quote

actually I found the answer at
http://wiki.gentoo.org/wiki/Qt/FAQ#Why_do_I_get_blockers_when_trying_to_emerge_Qt.3F

thanks..

-db
Back to top
View user's profile Send private message
ZHQ
n00b
n00b


Joined: 31 Dec 2009
Posts: 59
Location: Here

PostPosted: Sat Aug 18, 2012 6:30 am    Post subject: Reply with quote

EDIT: [SOLVED] See the bottom of this post.

Hi all,

I'm running into a bit of an issue trying to update my system (which is about a year old). This particular error is popping up for me when I run "sudo emerge -av --newuse --deep --update world". I'm getting a slot conflict on qt-4.8.2 and qt-4.7.4. It doesn't really make any sense, because the dependent packages require qt > 4.6.3, so shouldn't 4.8.2 automatically rule out the other version? What's really confusing is that I followed the guide in the above and I already have qt 4.8.2 installed! I must be misunderstanding something here...

Here's my portage output:
Code:
sudo emerge -av --newuse --deep --update world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-webkit:4

  (x11-libs/qt-webkit-4.8.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/qt-webkit-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/kexi-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/krita-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/karbon-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/koffice-l10n-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/kpresenter-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.7.0:4[kde] required by (app-office/kword-2.3.3-r1::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/kspread-2.3.3::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (app-office/koffice-libs-2.3.3::gentoo, installed)

x11-libs/qt-qt3support:4

  (x11-libs/qt-qt3support-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-qt3support-4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-gui-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/krita-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/kexi-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/koffice-data-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/kspread-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.7.0:4[accessibility,kde] required by (app-office/kword-2.3.3-r1::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/koffice-libs-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/karbon-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/koffice-l10n-2.3.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (app-office/kpresenter-2.3.3::gentoo, installed)
    ~x11-libs/qt-qt3support-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

x11-libs/qt-sql:4

  (x11-libs/qt-sql-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)

  (x11-libs/qt-sql-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-sql-4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support=] required by (x11-libs/qt-declarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

x11-libs/qt-core:4

  (x11-libs/qt-core-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-core-4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-script-4.8.2::gentoo, installed)
    (and 10 more with the same problem)

  (x11-libs/qt-core-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.7.4[aqua=,debug=] required by (x11-libs/qt-dbus-4.7.4::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problem)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.7.4[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (x11-libs/qt-gui-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-gui-4.8.2[accessibility=,aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-4.8.2::gentoo, installed)
    (and 5 more with the same problem)

x11-libs/qt-script:4

  (x11-libs/qt-script-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-script-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/qt-script-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-script-4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-declarative-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

x11-libs/qt-dbus:4

  (x11-libs/qt-dbus-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-dbus-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/qt-dbus-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-dbus-4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.2::gentoo, installed)

x11-libs/qt-xmlpatterns:4

  (x11-libs/qt-xmlpatterns-4.8.2::gentoo, installed) pulled in by
    ~x11-libs/qt-xmlpatterns-4.8.2[aqua=,debug=,qpa=] required by (x11-libs/qt-webkit-4.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (x11-libs/qt-xmlpatterns-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-xmlpatterns-4.7.4[aqua=,debug=] required by (x11-libs/qt-webkit-4.7.4::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously.  If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.


!!! The following updates are masked by LICENSE changes:
- www-plugins/adobe-flash-11.2.202.236::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy "=dev-db/mysql-5.1*[embedded=,minimal=,static=]".
!!! One of the following packages is required to complete your request:
- dev-db/mysql-5.1.62-r1::gentoo (Change USE: -embedded)
- virtual/mysql-5.1::gentoo (Change USE: +embedded)
(dependency required by "virtual/mysql-5.1" [ebuild])
(dependency required by "dev-perl/DBD-mysql-4.01.7" [installed])
(dependency required by "dev-db/mysql-5.1.62-r1[perl]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Near the bottom here are some unrelated problems that I have yet to get around to. I don't think they have anything to do with the qt conflict.

Thanks, everyone!

EDIT: I took another look at the messages and I noticed that the older version (4.7.4) of the qt packages was being pulled in by koffice. I hadn't updated koffice either, so it was probably my really old version specifically requesting 4.7.4. I unemerged the koffice packages (koffice-libs, koffice-data, koffice-meta) and the problem was solved! I'm still in the middle of updating about 400 packages and fixing all these little config things, so I haven't re-emerged koffice, but I'm sure that the latest version will have no problem with qt-webkit-4.8.3. You could probably just manually update koffice before doing an update world, but un-emerging and re-emerging later is the more surefire way.

Also, another thing. I had nepomuk blocking nepomuk-core after I resolved this problem. It was because the two packages were from different versions. (nepomuk was 4.8.3 and nepomuk-core was 4.9.0). Unmasking the 4.9.0 version of nepomuk did the trick. I didn't want to open a new thread or something for this little tidbit, so I figured I'd sneak it in here...

Hope that helps!
Back to top
View user's profile Send private message
atoussaint
n00b
n00b


Joined: 31 Jul 2012
Posts: 7

PostPosted: Sat Jan 19, 2013 4:23 am    Post subject: qt-4.8.2 is blocking qt-4.8.4 Reply with quote

Hello everyone,

I'm at a cousin's place and I installed a month ago, a Gentoo kde desktop system for multimedia (which is hooked to his 42 inch TV). the system's an old pentium 4 running x86 stable with kernel 3.5.7.

It was installed a month ago between Christmas and new years eve. This evening, I set out to update his system and I noticed there are 24 blocks of qt packages. It seem like qt want to upgrade from version 4.8.2:9999 to 4.8.4 and is blocked by the previous packages.

At my place, I run an x32 system since last saturday running unstables packages (kernel 4.7.2 among other and gnome 3.6.2) and I never ever got this much of packages blocked while updating every 3 month. How do I resolve my cousin's situation??

I will read the thread from start to finish tomorrow evening but in the meantime, this is how it look like:

[blocks b ] <x11-libs/qt-dbus-4.8.4:4 ("<x11-libs/qt-dbus-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-script-4.8.4:4 ("<x11-libs/qt-script-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-gui-4.8.4:4 ("<x11-libs/qt-gui-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-sql-4.8.4:4 ("<x11-libs/qt-sql-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-qt3support-4.8.4:4 ("<x11-libs/qt-qt3support-4.8.4:4" is blocking x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-svg-4.8.4:4 ("<x11-libs/qt-svg-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-test-4.8.4:4 ("<x11-libs/qt-test-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-opengl-4.8.4:4 ("<x11-libs/qt-opengl-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-xmlpatterns-4.8.4:4 ("<x11-libs/qt-xmlpatterns-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[blocks b ] <x11-libs/qt-webkit-4.8.4:4 ("<x11-libs/qt-webkit-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] <x11-libs/qt-declarative-4.8.4:4 ("<x11-libs/qt-declarative-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] >x11-libs/qt-script-4.8.2-r9999:4 (">x11-libs/qt-script-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-gui-4.8.2-r9999:4 (">x11-libs/qt-gui-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-sql-4.8.2-r9999:4 (">x11-libs/qt-sql-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] <x11-libs/qt-multimedia-4.8.4:4 ("<x11-libs/qt-multimedia-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-webkit-4.8.4, x11-libs/qt-declarative-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4, x11-libs/qt-xmlpatterns-4.8.4)
[blocks b ] >x11-libs/qt-xmlpatterns-4.8.2-r9999:4 (">x11-libs/qt-xmlpatterns-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-core-4.8.2-r9999:4 (">x11-libs/qt-core-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-svg-4.8.2-r9999:4 (">x11-libs/qt-svg-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-dbus-4.8.2-r9999:4 (">x11-libs/qt-dbus-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2)
[blocks b ] >x11-libs/qt-declarative-4.8.2-r9999:4 (">x11-libs/qt-declarative-4.8.2-r9999:4" is blocking x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-qt3support-4.8.2-r9999:4 (">x11-libs/qt-qt3support-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-webkit-4.8.2-r9999:4 (">x11-libs/qt-webkit-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-test-4.8.2-r9999:4 (">x11-libs/qt-test-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks b ] >x11-libs/qt-opengl-4.8.2-r9999:4 (">x11-libs/qt-opengl-4.8.2-r9999:4" is blocking x11-libs/qt-declarative-4.8.2, x11-libs/qt-qt3support-4.8.2, x11-libs/qt-webkit-4.8.2, x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-xmlpatterns-4.8.2, x11-libs/qt-multimedia-4.8.2, x11-libs/qt-sql-4.8.2, x11-libs/qt-script-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-dbus-4.8.2)
Conflict: 24 blocks
Back to top
View user's profile Send private message
region-g
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2005
Posts: 122
Location: Ελλάς

PostPosted: Sun Apr 19, 2015 6:01 pm    Post subject: Reply with quote

I was avoiding this update by fear that I may get stuck out of the DE, which I accomplished w/o even trying to get an idea of the blockage situation.

Please have a look

emerge -uDNav world

https://bpaste.net/show/e51e6f131c50

emerge --info

https://bpaste.net/show/006f23df2c60
_________________
wanna react ?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4563
Location: Suzhou, China

PostPosted: Sun Apr 19, 2015 11:21 pm    Post subject: Reply with quote

Try adding dev-qt/* to package.keywords. It's the mix of stable and testing versions that seems to be tripping you up.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
elprawn
n00b
n00b


Joined: 22 May 2017
Posts: 5

PostPosted: Mon May 22, 2017 8:37 pm    Post subject: qt 4.8.6 / 4.8.7 conflicts Reply with quote

I thought I should post this here, as it's a sticky and I thought the etiquette here may be to not start loads of threads of this kind of issue.

After emerge --sync, here is the output of the following command, which will attempt to install/update all installed packages that begin with dev-qt/

Code:
emerge --oneshot -av $(equery -q list 'dev-qt/*' | cut -d ' ' -f 5 | sed -n 's/-[0-9]\{1,\}.*$//p' | paste -s --delimiters=" ") --verbose-conflicts


Here is the output --

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtchooser-0_p20151008::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo  USE="icu -debug -systemd {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtdbus-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtxml-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtnetwork-5.6.2:5/5.6::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtsql-5.6.2:5/5.6::gentoo  USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtconcurrent-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qttest-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtpaths-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qdbus-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtgui-5.6.2:5/5.6::gentoo  USE="dbus egl gif jpeg png udev xcb -accessibility -debug -eglfs -evdev -gles2 -gtkstyle -ibus -libinput {-test} -tslib -tuio" 0 KiB
[ebuild   R    ] dev-qt/qtwidgets-5.6.2:5/5.6::gentoo  USE="png xcb -debug -gles2 -gtkstyle {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtx11extras-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtwayland-5.6.2:5/5.6::gentoo  USE="egl qml xcomposite -debug {-test} -wayland-compositor" 0 KiB
[ebuild   R    ] dev-qt/qtimageformats-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtscript-5.6.2:5/5.6::gentoo  USE="jit scripttools -debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtsvg-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo  USE="jit widgets xml -debug -gles2 -localstorage {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtopengl-5.6.2:5/5.6::gentoo  USE="-debug -gles2 {-test}" 0 KiB
[ebuild   R    ] dev-qt/qthelp-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/linguist-tools-5.6.2:5/5.6::gentoo  USE="qml -debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtwebkit-5.6.2:5/5.6::gentoo  USE="jit opengl qml -debug -geolocation -gstreamer -gstreamer010 -multimedia -orientation -printsupport {-test} -webchannel -webp" 0 KiB
[ebuild   R    ] dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo  USE="widgets -debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtgraphicaleffects-5.6.2:5/5.6::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtwebchannel-5.6.2:5/5.6::gentoo  USE="qml -debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtpositioning-5.6.2:5/5.6::gentoo  USE="qml -debug -geoclue {-test}" 0 KiB
[ebuild  NS    ] dev-qt/qttranslations-5.6.2:5/5.6::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtlockedfile-2.4.1_p20150629::gentoo  USE="qt4 qt5 -doc" 0 KiB
[ebuild   R    ] dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo  USE="cups -debug -gles2 {-test}" 0 KiB
[ebuild   R    ] dev-qt/designer-5.6.2:5/5.6::gentoo  USE="declarative webkit -debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qt-creator-3.6.1::gentoo  USE="webkit -android -autotools -baremetal -bazaar -clang -clearcase -cmake -cvs -doc -git -ios -mercurial -perforce -python -qbs -qnx -subversion -systemd {-test} -valgrind -winrt" LINGUAS="-cs -de -fr -ja -pl -ru -sl -uk -zh_CN -zh_TW" 0 KiB
[ebuild   R    ] dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo  USE="X qt4 qt5 -doc" 0 KiB
[ebuild     U  ] dev-qt/qtcore-4.8.7-r2:4::gentoo [4.8.6-r2:4::gentoo] USE="exceptions glib iconv icu qt3support ssl (-aqua) -debug (-libressl) -pch" ABI_X86="(64) -32 (-x32)" 235,426 KiB
[ebuild     U  ] dev-qt/qttranslations-4.8.7:4::gentoo [4.8.6-r1:4::gentoo] ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qtscript-4.8.7:4::gentoo [4.8.6-r2:4::gentoo] USE="exceptions jit (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qtgui-4.8.7:4::gentoo [4.8.6-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qtsql-4.8.7-r1:4::gentoo [4.8.6-r1:4::gentoo] USE="exceptions mysql qt3support sqlite (-aqua) -debug -freetds -oci8 -odbc -pch -postgres" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qt3support-4.8.7:4::gentoo [4.8.6-r1:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] dev-qt/qtmultimedia-5.6.2:5/5.6::gentoo  USE="alsa pulseaudio qml widgets -debug -gles2 -gstreamer -gstreamer010 -openal {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtwebengine-5.6.2:5/5.6::gentoo  USE="system-ffmpeg system-icu widgets -bindist -debug -geolocation -pax_kernel {-test}" 0 KiB

Total: 41 packages (6 upgrades, 1 in new slot, 34 reinstalls), Size of downloads: 235,426 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,ssl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,glib=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qttest-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtopengl-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsvg-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6 required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^

  (dev-qt/qtcore-4.8.7-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,glib=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.7 required by (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.6[accessibility=,aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsvg-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[accessibility=,aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,egl=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtopengl-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^

  (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.7[accessibility=,aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.7-r2:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.7[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^

dev-qt/qttranslations:4

  (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttranslations-4.8.7 required by (dev-qt/qtcore-4.8.7-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^

  (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qttranslations-4.8.6 required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^                      ^^^^^

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^

  (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, installed)
    ^                ^^^^^
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                ^^^^^
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.6-r1:4/4::gentoo, installed)
    ^                ^^^^^

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qt3support (Argument)
    ~dev-qt/qt3support-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.6[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.6-r1:4/4::gentoo, installed)
    ^                  ^^^^^
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                  ^^^^^
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, installed)
    ^                  ^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



Here is the output of emerge --info

Code:

Portage 2.3.5 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i3-3217U_CPU_@_1.80GHz-with-gentoo-2.3
KiB Mem:     5918972 total,   1992532 free
KiB Swap:   12582908 total,  12582908 free
Timestamp of repository gentoo: Mon, 22 May 2017 20:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.24.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

haskell
    location: /var/lib/layman/haskell
    masters: gentoo
    priority: 50

hossie
    location: /var/lib/layman/hossie
    masters: gentoo
    priority: 50

rindeal
    location: /var/lib/layman/rindeal
    masters: gentoo
    priority: 50

spike
    location: /var/lib/layman/spike
    masters: gentoo
    priority: 50

zugaina
    location: /var/lib/layman/zugaina
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=ivybridge"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=ivybridge"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.bytemark.co.uk/gentoo/ http://mirror.bytemark.co.uk/gentoo/ ftp://mirror.bytemark.co.uk/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ http://www.mirrorservice.org/sites/distfiles.gentoo.org/ rsync://rsync.mirrorservice.org/distfiles.gentoo.org/ ftp://ftp.mirrorservice.org/sites/distfiles.gentoo.org/"
LANG="en_GB.ISO-8859-1"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bidi bluetooth branding bzip2 cairo cdda cdio cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran freetype gbm gd gdbm gif glamor gnutls gpm gtk httpd iconv icu ipv6 jpeg kde kipi kwallet lcms ldap libkms libnotify live lua mad matroska mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg oggvorbis opengl openmp pam pango pcre pdf phonon pipelight plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification stream svg tcpd theora tiff truetype udev udisks unicode upower usb vcd vlm vorbis webkit widgets wxwidgets wxwindows x264 xa xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en_GB en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en en-GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4 python3_5" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Now, I am confused, since all of the packages that emerge is selecting come from the official repo, are stable and all of the conflicts are in the list of packages that are to be installed.
All of the packages that are installed and require a given package, are being upgraded and so are the packages that they require, so why does it complain? Do I need to uninstall the old ones before I emerge the new ones? I've always been able to solve similar problems by determining all of the complaining packages and then emerging them all at once, but now it still complains. As far as I can see, it's not caused by use flag disparity between the new and old versions, either.

Thank you for your help.

Edit: I have added the -u flag to the command and now it's emerging with no complaints. Thank you for reading.

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8
Page 8 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum