Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg / RadeonHD] X démarre pas - Aléatoire
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Feb 03, 2009 2:22 pm    Post subject: [Xorg / RadeonHD] X démarre pas - Aléatoire Reply with quote

Bonjour à tous,

Je me traine ce problème depuis quelques temps et je sature ^^ :

De temps en temps au démarrage de la machine quand XDM se lance il me met un zolie écran bleu comme quoi il y a tout plein d'erreur :
Code:
Shogun log # cat ~/xorg.log | grep WW
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) RADEONHD(0): rhdAtomAllocateFbScratch: FW FB scratch area 536854528 (size: 16384) extends beyond available framebuffer size 268435456
Shogun log # cat ~/xorg.log | grep EE
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.
(EE) RADEONHD(0): Failed to detect a connected monitor
(EE) Screen(s) found, but none have a usable configuration.

Sauf que le reste du temps, pas de message d'erreur et X démarre sans problème. Quand j'ai l'erreur il me suffit de me logger en console et de redémarrer xdm pour "résoudre" le problème.

mon xorg.conf
Code:
Shogun log # cat /etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "Layout-TV"
        Screen        "Screen-TV" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load "dri"
   Load  "dbe"     # Double buffer extension
   SubSection "extmod"
      Option       "omit xfree86-dga"   # don't initialise the DGA extension
   EndSubSection
   Load  "freetype"
   Load  "glx"
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "InputDevice"
   Identifier  "Keyboard1"
   Driver      "kbd"
   Option       "AutoRepeat" "500 30"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "fr"
EndSection

Section "InputDevice"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2"   
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Samsung-TV"
        HorizSync    67.5
        VertRefresh  60
   DisplaySize 812 457 # 60x60 Dpi resolution
EndSection

Section "Device"
       Identifier  "HD3870"
       Driver      "radeonhd"
EndSection

Section "Screen"
        Identifier "Screen-TV"
        Device     "HD3870"
        Monitor    "Samsung-TV"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1920x1080"
        EndSubSection
EndSection


N'hésitez pas si vous voulez plus de log, j'ai volontairement limité pour ne pas surcharger.

Gaby
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Feb 04, 2009 3:17 am    Post subject: Reply with quote

Quel est la versio du pilote radeonhd et celle de xorg ?
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Wed Feb 04, 2009 1:21 pm    Post subject: Reply with quote

Code:
gaby@Shogun ~ $ eix radeonhd
[I] x11-drivers/xf86-video-radeonhd
     Available versions:  (~)1.1.0 (~)1.2.0 (~)1.2.1 (~)1.2.3 (~)1.2.4 {debug}
     Installed versions:  1.2.4(21:11:16 21.12.2008)(-debug)
     Homepage:            http://wiki.x.org/wiki/radeonhd
     Description:         Experimental Radeon HD video driver.

gaby@Shogun ~ $ eix xorg-server
[I] x11-base/xorg-server
     Available versions:  1.3.0.0-r6 ~1.4.2 ~1.5.2 ~1.5.3 ~1.5.3-r1 {3dfx debug dmx dri hal input_devices_acecad input_devices_aiptek input_devices_calcomp input_devices_citron input_devices_digitaledge input_devices_dmc input_devices_dynapro input_devices_elo2300 input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_jamstudio input_devices_joystick input_devices_keyboard input_devices_magellan input_devices_microtouch input_devices_mouse input_devices_mutouch input_devices_palmax input_devices_penmount input_devices_spaceorb input_devices_summa input_devices_synaptics input_devices_tek4957 input_devices_tslib input_devices_ur98 input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl tslib video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_imstt video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nsc video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vermilion video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo video_cards_xgi xorg xprint}
     Installed versions:  1.3.0.0-r6(19:07:20 12.12.2008)(dri input_devices_keyboard input_devices_mouse ipv6 nptl sdl xorg -3dfx -debug -dmx -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics -input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick -input_devices_magellan -input_devices_microtouch -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -kdrive -minimal -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_impact -video_cards_imstt -video_cards_intel -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo -xprint)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


Gaby
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Feb 04, 2009 3:35 pm    Post subject: Reply with quote

Je pense que le problème vient du fait que tu utilises une vieille version de xorg.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Wed Feb 04, 2009 4:40 pm    Post subject: Reply with quote

Salut
Je completerais le post de titoucha avec çà
Code:

(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.
(EE) RADEONHD(0): Failed to detect a connected monitor
(EE) Screen(s) found, but none have a usable configuration.


quel version de xrandr as tu ? 1.2.3 !!!!

Code:

rickyload@Gentoo ~ $ eix xrandr
[I] x11-apps/xrandr
     Available versions:  1.2.2 (~)1.2.3 {debug}
     Installed versions:  1.2.3(03:28:58 21/06/2008)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         primitive command line interface to RandR extension

[I] x11-libs/libXrandr
     Available versions:  1.2.1 (~)1.2.2 (~)1.2.3 {debug}
     Installed versions:  1.2.3(17:06:12 08/07/2008)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org Xrandr library



Pour la détection de ton monitor , il me semble que tu peux passer quelques options comme ils le disent sur le wiki du radeonhd

==> http://www.x.org/wiki/radeonhd#head-28145e1625df634e3cdff6691fa85523f92af18e

Voilà si çà peut aider
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Wed Feb 04, 2009 7:21 pm    Post subject: Reply with quote

Code:
[I] x11-apps/xrandr
     Available versions:  1.2.2 ~1.2.3 {debug}
     Installed versions:  1.2.2(18:36:03 08.10.2007)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         primitive command line interface to RandR extension


Je vais tout tester avec les versions ~amd64 pour voir si ça persiste mais comme c'est aléatoire ....
Je ferais un retour en cas de problème.
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Thu Feb 05, 2009 5:09 pm    Post subject: Reply with quote

Bonjour,

Test non concluant même erreur ce soir en rentrant du taf ....
Les versions actuellement installées :
Code:
gaby@Shogun ~ $ eix xrandr
* lxde-base/lxrandr
     Available versions:  ~0.1
     Homepage:            http://lxde.sf.net/
     Description:         LXDE GUI interface to RandR extention

[I] x11-apps/xrandr
     Available versions:  1.2.2 (~)1.2.3 {debug}
     Installed versions:  1.2.3(20:51:51 04.02.2009)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         primitive command line interface to RandR extension

[I] x11-libs/libXrandr
     Available versions:  1.2.1 1.2.2 ~1.2.3 {debug}
     Installed versions:  1.2.2(19:42:58 08.02.2008)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org Xrandr library

Found 3 matches.
gaby@Shogun ~ $ eix xorg-server
[I] x11-base/xorg-server
     Available versions:  1.3.0.0-r6 (~)1.4.2 (~)1.5.2 (~)1.5.3 (~)1.5.3-r1 {3dfx debug dmx dri hal input_devices_acecad input_devices_aiptek input_devices_calcomp input_devices_citron input_devices_digitaledge input_devices_dmc input_devices_dynapro input_devices_elo2300 input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_jamstudio input_devices_joystick input_devices_keyboard input_devices_magellan input_devices_microtouch input_devices_mouse input_devices_mutouch input_devices_palmax input_devices_penmount input_devices_spaceorb input_devices_summa input_devices_synaptics input_devices_tek4957 input_devices_tslib input_devices_ur98 input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl tslib video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_imstt video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nsc video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vermilion video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo video_cards_xgi xorg xprint}
     Installed versions:  1.5.3-r1(21:00:35 04.02.2009)(hal input_devices_keyboard input_devices_mouse ipv6 nptl sdl video_cards_radeonhd xorg -3dfx -debug -dmx -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics -input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick -input_devices_magellan -input_devices_microtouch -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_tslib -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -kdrive -minimal -tslib -video_cards_apm -video_cards_ark -video_cards_ast -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_geode -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_impact -video_cards_imstt -video_cards_intel -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vermilion -video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo -video_cards_xgi)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers

gaby@Shogun ~ $ eix radeonhd
[I] x11-drivers/xf86-video-radeonhd
     Available versions:  (~)1.1.0 (~)1.2.0 (~)1.2.1 (~)1.2.3 (~)1.2.4 {debug}
     Installed versions:  1.2.4(21:49:52 04.02.2009)(-debug)
     Homepage:            http://wiki.x.org/wiki/radeonhd
     Description:         Experimental Radeon HD video driver.


mon xorg.conf (légèrement modifié suite à des erreurs après le passage en ~amd64) :
Code:
gaby@Shogun ~ $ cat /etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "Layout-TV"
        Screen        "Screen-TV" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
   Option "AllowEmptyInput" "off"
EndSection

Section "Files"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load "dri"
   Load  "dbe"     # Double buffer extension
   SubSection "extmod"
      Option       "omit xfree86-dga"   # don't initialise the DGA extension
   EndSubSection
   Load  "freetype"
   Load  "glx"
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "InputDevice"
   Identifier  "Keyboard1"
   Driver      "kbd"
   Option       "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "fr"
EndSection

Section "InputDevice"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2"   
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Samsung-TV"
        HorizSync    67.5
        VertRefresh  60
   DisplaySize 812 457 # 60x60 Dpi resolution
EndSection

Section "Device"
       Identifier  "HD3870"
       Driver      "radeonhd"
EndSection

Section "Screen"
        Identifier "Screen-TV"
        Device     "HD3870"
        Monitor    "Samsung-TV"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1920x1080"
        EndSubSection
EndSection


Arf j'ai oublié de récupérer le log de Xorg, l'erreur est grosse modo la même que précédemment et un restart de xdm suffit à passer outre.

Gaby
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Feb 10, 2009 5:24 pm    Post subject: Reply with quote

Voila le log du crash en étant en ~arch :
Code:
Shogun gaby #  cat /root/xorg.log.new | grep WW
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/TTF/" does not exist.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
(WW) RADEONHD(0): rhdAtomAllocateFbScratch: FW FB scratch area 536854528 (size: 16384) extends beyond available framebuffer size 268435456
(WW) RADEONHD(0): No outputs definitely connected, trying again...
(WW) RADEONHD(0): Unable to find initial modes
Shogun gaby #  cat /root/xorg.log.new | grep EE
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.
(EE) RADEONHD(0): Failed to detect a connected monitor
(EE) Screen(s) found, but none have a usable configuration.


A noter que le passage en ~arch rend toujours le problème aléatoire et a peu pres suivant la même période (plante tout les 2-3 boot).

Gaby
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Feb 11, 2009 3:37 am    Post subject: Reply with quote

Quand il démarre tu as quoi comme info pour RandR dans le xorg.0.log, pour voire quel mode il utilise et modifier la config de xorg en conséquence.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Wed Feb 11, 2009 5:19 pm    Post subject: Reply with quote

Avant le passage en ~arch de xorg-server&co :
Code:
Shogun ~ # cat xorg.log | grep RandR
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/digital for Output TMDS A
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/analog for Output DAC B
(II) RADEONHD(0): RandR: Adding RRoutput TV_7PIN_DIN for Output DAC B
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/digital for Output TMDS B
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/analog for Output DAC A
(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.

Après le passage en ~arch:
Code:
Shogun ~ # cat xorg.log.new | grep RandR
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/digital for Output TMDS A
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/analog for Output DAC B
(II) RADEONHD(0): RandR: Adding RRoutput TV_7PIN_DIN for Output DAC B
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/digital for Output TMDS B
(II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/analog for Output DAC A
(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.

J'ai depuis modifié mon xorg.conf en ajoutant à la section Device:
Code:
Option "NoRandR"

Et j'ai quand même planté X au boot ce soir. Pas eu la présence d'esprit de récupérer le log par contre :oops:
Comme d'hab un restart de XDM me lance X sans erreur et dans le log :
Code:
Shogun ~ # cat /var/log/Xorg.0.log | grep RandR
(II) RADEONHD(0): RandR 1.2 support disabled due to configuration
(==) RandR enabled
Voilou
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7896
Location: ~Brussels - Belgique

PostPosted: Wed Feb 11, 2009 9:01 pm    Post subject: Reply with quote

essaie de virer ton xorg.conf et utiliser /etc/hal/policy/* pour voir ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Thu Feb 12, 2009 6:19 pm    Post subject: Reply with quote

XavierMiller wrote:
essaie de virer ton xorg.conf et utiliser /etc/hal/policy/* pour voir ;)

Tu as un tuto à me conseiller sur ce sujet ? Vu le nombre de post lié à des soucis relatif à ces fichiers j'ai un peu peur de faire le pas ...
Sinon qu'est ce qui te fait penser que ça résolverait mon problème ?
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri Feb 13, 2009 4:49 am    Post subject: Reply with quote

Je ne pense pas que sa va résoudre ton problème, vu que hal/xorg sert à la gestion du clavier et de la souris.

Par contre je suis à court de solution.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Fri Feb 13, 2009 4:24 pm    Post subject: Reply with quote

Ca y est j'ai enfin trouvé comment reproduire le bug et je dois dire que c'est tout con et presque logique.
Je trouvais curieux que le bug n'arrive que au boot et pas lors d'un lancement de xdm à la main. Le message d'erreur indique que le driver ne trouve pas d'écran donc soit le driver ou un autre soft se prend les pieds dans le tapis, soit c'est que effectivement il ne trouve pas d'écran.
Mon PC est branché sur ma télé et lorsque je lance le PC, je n'allume pas forcement la télé en même temps. La télé reste tout de même en veille.
J'ai donc testé ce que je présentais et c'est bien à cause de la télé. Si je n'allume pas la télé, X plante. Si j'allume la télé avant le PC, X se lance. Et si je lance le PC télé éteinte que j'allume la télé après le boot, que je prépare le redémarrage de XDM et que j'éteint la télé avant de faire enter XDM plante.
C'est donc bien le fait que l'écran soit éteint (ou en veille) qui pertube le driver (ou autre chose).

Des idées pour éviter le problème ?

Gaby
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri Feb 13, 2009 4:29 pm    Post subject: Reply with quote

As-tu essayé le pilote proprio ati ?

J'ai une mythbox qui tourne sur une télé et je n'ai pas ces symptômes, bon j'utilise un pilote Nvidia c'est aussi peut être ça.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Fri Feb 13, 2009 5:20 pm    Post subject: Reply with quote

J'avais le driver ATI avant d'utiliser le radeonHD et je n'ai pas souvenir d'avoir ces problèmes non. J'étais passé sur la version libre carje n'arrivais plus à compiler le proprio. Certainement un probleme de compatibilité xorg / kernel / driver et j'ai biaisé en passant par le libre.
Je préfère rester sur le libre pour le moment, peut être qu'une prochaine version résoudra le problème.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri Feb 13, 2009 7:05 pm    Post subject: Reply with quote

La chose qui est un peu gênante avec le pilote libre c'est les mise à jour qui sont espacées, bon pour le redaonhd ça va encore.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Fri Feb 13, 2009 8:17 pm    Post subject: Reply with quote

En même temps je préfère un driver qui fonctionne très bien sur ce qui est implémenté plutot qu'un driver qui évolue très rapidement mais sans tourner rond. Je suis surpris de sa qualité.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Feb 14, 2009 5:36 am    Post subject: Reply with quote

C'est sur que le pilote libre est mieux codé, par contre, comme tu le soulignes, il n'a pas encore toutes les fonctionnalité, c'est ce qui me fait encore rester avec le pilote proprio.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Sat Feb 14, 2009 3:33 pm    Post subject: Reply with quote

rien à voir surement , mais quand tu dis que tu as mis tout à tu as cependant garder la meme version de libXrandr (1.2.2) alors que Xrandr

Code:
[I] x11-apps/xrandr
     Available versions:  1.2.2 (~)1.2.3 {debug}
     Installed versions:  1.2.3(20:51:51 04.02.2009)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         primitive command line interface to RandR extension
 
[I] x11-libs/libXrandr
     Available versions:  1.2.1 1.2.2 ~1.2.3 {debug}
     Installed versions:  1.2.2(19:42:58 08.02.2008)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org Xrandr library


le truc pas logique et aléatoire c'est bizarre.

bon courage

PS: j'avais entendu parlé que certain freeze ou autre être lié à la mémoire de la carte graphique (mauvais vidage) , moi j'y connais que dalle mais bon ça peut ptre servir.
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
adrislayer
n00b
n00b


Joined: 16 Aug 2005
Posts: 48

PostPosted: Mon Feb 16, 2009 11:13 pm    Post subject: Reply with quote

salut, juste pour te dire que j'ai une ati radeon 3470 mobility donc de la même série que toi.

Les pilotes radeonhd ne sont vraiment pas encore au point, même l'accélération 2D est absente et donc l'accélération de vidéo est absente. Je te conseil vivement les pilotes ati-drivers propriétaires.

Voici mon /etc/portage/package.unmask que j'ai du utiliser pour les installer:
[codecat /etc/portage/package.unmask
app-emulation/emul-linux-x86-baselibs
x11-drivers/ati-drivers
app-emulation/emul-linux-x86-xlibs][/code]

et voici la section de la carte graphique dans le xorg.conf
Code:
Section "Device"
    Identifier   "Ati Mobility 3470"
    VendorName   "AMD/ATI"
    BoardName   "AMD/ATI 3470 Mobility"

    Driver     "fglrx"
EndSection


il est apparemment conseillé de ne pas utiliser d'options, fglrx s'en occupe très bien tout seul si j'en crois une source.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Tue Feb 17, 2009 7:50 am    Post subject: Reply with quote

adrislayer wrote:
il est apparemment conseillé de ne pas utiliser d'options, fglrx s'en occupe très bien tout seul si j'en crois une source.


Exacte il suffit de regarder le fichier /var/log/Xorg.0.log pour s'en convaincre.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Tue Feb 17, 2009 8:01 am    Post subject: Reply with quote

Quote:

(EE) RADEONHD(0): RandR: No valid modes. Disabling RandR support.
(EE) RADEONHD(0): Failed to detect a connected monitor
(EE) Screen(s) found, but none have a usable configuration.


As tu essayé une resolution plus petite comme 1024x768 et passer de 24 bits à 16 bits pour voir ?
_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Feb 17, 2009 9:07 am    Post subject: Reply with quote

nico_calais wrote:
As tu essayé une resolution plus petite comme 1024x768 et passer de 24 bits à 16 bits pour voir ?

Non, je n'ai pas testé de changé les résolutions ou qualité. J'ai du mal à voir l'impact sur la détection de l'écran, tu pense à quoi ?

adrislayer wrote:
Les pilotes radeonhd ne sont vraiment pas encore au point, même l'accélération 2D est absente et donc l'accélération de vidéo est absente. Je te conseil vivement les pilotes ati-drivers propriétaires.

J'ai utilisé le driver ATI pendant 8 mois avec régulièrement des problèmes de mise à jour et le dernier mois, je n'avais plus de DRI ce qui me causait des lenteurs de scroll dans Firefox et d'autre petit désagrément. Pendant ce mois là, j'ai déséspéremment essayé de mettre à jour le driver mais impossible de trouver la combinaison driver / kernel / xorg qui va bien pour le faire. Je suis donc passer par radeonHD pour voir si l'herbe y était plus verte et je peux te dire que je tourne mieux avec ce driver. Pas de DRI pour le moment mais pas de problème de scroll dans Firefox, aucun problème graphique ou que/quoi ce soit.
Le seul reproche à faire à ce driver pour le moment c'est qu'il ne supporte pas encore la totalité des fonctions du chipset et qu'il plante s'il se lance écran éteint. Personnellement je préfère ces désagrément ;) (surtout depuis que je sais d'où vient le problème de plantage, je peux l'éviter sans problème).

fb99 wrote:
rien à voir surement , mais quand tu dis que tu as mis tout à tu as cependant garder la meme version de libXrandr (1.2.2) alors que Xrandr

Effectivement, je testerai ce soir en upgradant la lib. Merci pour le coup d'oeil j'étais passé au travers.

Gaby
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Feb 17, 2009 9:34 am    Post subject: Reply with quote

Un guide très utile pour configurer Xrandr et avoir un Xorg.conf moderne: http://wiki.debian.org/XStrikeForce/HowToRandR12
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum