Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] mplayerthumbs compile error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 988
Location: Bangalore, India

PostPosted: Wed Feb 04, 2009 10:42 pm    Post subject: [kde-testing] mplayerthumbs compile error Reply with quote

I try to compile mplayerthumbs from the kde-testing overlay but it fails.
Code:
[ 80%] [ 90%] Building CXX object src/CMakeFiles/mplayerthumbsconfig.dir/mplayerthumbscfg.o                                 
Building CXX object src/CMakeFiles/mplayerthumbsconfig.dir/mplayerthumbs.o                                                   
Linking CXX shared module ../lib/videopreview.so                                                                             
Linking CXX executable mplayerthumbsconfig                                                                                   
CMakeFiles/videopreview.dir/videopreview.o: In function `VideoPreview::~VideoPreview()':                                     
videopreview.cpp:(.text+0x43b): undefined reference to `ThumbCreator::~ThumbCreator()'                                       
CMakeFiles/videopreview.dir/videopreview.o: In function `VideoPreview::~VideoPreview()':                                     
videopreview.cpp:(.text+0x51b): undefined reference to `ThumbCreator::~ThumbCreator()'                                       
CMakeFiles/videopreview.dir/videopreview.o: In function `VideoPreview::~VideoPreview()':                                     
videopreview.cpp:(.text+0x5db): undefined reference to `ThumbCreator::~ThumbCreator()'                                       
CMakeFiles/videopreview.dir/videopreview.o:(.data.rel.ro._ZTI12VideoPreview[typeinfo for VideoPreview]+0x28): undefined reference to `typeinfo for ThumbCreator'                                                                                         
collect2: ld returned 1 exit status                                                                                         
make[2]: *** [lib/videopreview.so] Error 1                                                                                   
make[1]: *** [src/CMakeFiles/videopreview.dir/all] Error 2                                                                   
make[1]: *** Waiting for unfinished jobs....                                                                                 
[100%] Built target mplayerthumbsconfig                                                                                     
make: *** [all] Error 2                                                                                                     
 *                                                                                                                           
 * ERROR: media-video/mplayerthumbs-1.1-r1 failed.                                                                           
 * Call stack:                                                                                                               
 *               ebuild.sh, line   49:  Called src_compile                                                                   
 *             environment, line 3139:  Called kde4-base_src_compile                                                         
 *             environment, line 2281:  Called kde4-base_src_make                                                           
 *             environment, line 2341:  Called cmake-utils_src_make                                                         
 *             environment, line  802:  Called die                                                                           
 * The specific snippet of code:                                                                                             
 *           emake "$@" || die "Make failed!";                                                                               
 *  The die message:                                                                                                         
 *   Make failed!                                                                                                           
 *                                                                                                                           
 * If you need support, post the topmost build error, and the call stack if relevant.                                       
 * A complete build log is located at '/var/tmp/portage/media-video/mplayerthumbs-1.1-r1/temp/build.log'.                   
 * The ebuild environment file is located at '/var/tmp/portage/media-video/mplayerthumbs-1.1-r1/temp/environment'.           
 * This ebuild is from a repository named 'kde'                                                                             
 *                                                         

I'm using kde 4.2
Any help?
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 637

PostPosted: Wed Feb 04, 2009 10:49 pm    Post subject: Reply with quote

You'll need to apply the following patch:
Code:
--- mplayerthumbs-1.1.orig/src/CMakeLists.txt   2008-06-20 17:16:26.000000000 +0200
+++ mplayerthumbs-1.1/src/CMakeLists.txt   2009-01-31 01:49:36.859861291 +0100
@@ -9,7 +9,7 @@
 
 kde4_add_plugin(videopreview ${videopreview_PART_SRCS})
 
-target_link_libraries(videopreview ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${KDE4_KDEUI_LIBS} ${KDE4_KDECORE_LIBS})
+target_link_libraries(videopreview ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${KDE4_KDEUI_LIBS} ${KDE4_KDECORE_LIBS} ${KDE4_KIO_LIBS})
 
 install(TARGETS videopreview DESTINATION ${PLUGIN_INSTALL_DIR})


It just adds ${KDE4_KIO_LIBS} to target_link_libraries. Compiles here after doing that.
_________________
Gentoo Linux 13.0 | 3.8.0 | glibc 2.15 | gcc 4.7.3

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 988
Location: Bangalore, India

PostPosted: Wed Feb 04, 2009 11:11 pm    Post subject: Reply with quote

Thanks this patch did it.
It compiles now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum