Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
swsusp & tuxonice-sources-2.6.28-r1, no resume [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Tue Jan 27, 2009 10:51 am    Post subject: swsusp & tuxonice-sources-2.6.28-r1, no resume [RISOLTO] Reply with quote

Salve a tutti, utilizzo il kernel 2.6.28-r1 patchato con tuxonice (in altre parole utilizzo tuxonice-sources) su amd64 e sto avendo un problema strano nell'utilizzare il suspend-to-ram...
Una volta eseguito il suspend tramite il comando
Code:
# hibernate-ram

Il laptop rientra in funzione solo se tento di risvegliarlo nei primi secondi successivi alla sospensione....se invece lo lascio, per esempio, una notte intera senza toccarlo, il successivo tentativo fallisce miseramente in quanto vedo accendersi solo la spia dell'alimentazione e sento l'hd che gira...nessun altro segno di vita è presente.

Vi allego alcuni file che potrebbero aiutare
sysfs-ram.conf
Code:

UseSysfsPowerState mem
PowerdownMethod platform

#EnableVbetool yes
#RestoreVbeStateFrom /var/lib/vbetool/vbestate


Include common.conf

common.conf
Code:

Verbosity 0
LogFile /var/log/hibernate.log
LogVerbosity 2
LogTimestamp yes

Distribution gentoo
XDisplay :0

SaveClock restore-only

DisableWriteCacheOn /dev/sda

Unmount /mnt/pendrive /mnt/usb/1 /mnt/usb/2 /mnt/usb/3 /var/tmp/portage

Mount /var/tmp/portage

FullSpeedCPU yes

LockXScreenSaver yes

OnResume 20 nvclock -S 50

UnloadBlacklistedModules yes
LoadModules auto

SwitchToTextMode yes

Ovviamente il file common.conf è condiviso anche con il normale suspend-to-disk con il quale non ho alcun problema.
Potrebbe servire altro? Config del kernel?
Ovviamente i log non dicono niente perchè in fase di resume non vengono scritti. :cry:
Che possa c'entrare il dpms attivo?


Last edited by oRDeX on Thu Jan 29, 2009 8:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Tue Jan 27, 2009 9:44 pm    Post subject: Reply with quote

Non so quale sia il problema, però posso dirti che il DPMS non da alcun problema.

Invece potrebbero essere i driver video. Che driver utilizzi? Che scheda hai?
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Wed Jan 28, 2009 7:13 am    Post subject: Reply with quote

Utilizzo una NVIDIA 8400M (non ridete sotto il baffo :P) con driver 180.22.
Ho provato a rimettere la versione 177.82 (che utilizzavo in precedenza), ma il risultato è lo stesso...il fatto che il sistema smetta di riprendersi solo se è in sospensione da un tot di tempo non mi permette proprio di capire che possa essere :cry:
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Jan 28, 2009 11:26 am    Post subject: Reply with quote

ciao, anche io ho una nvidia come scheda grafica, ho il tuo medesimo problema utilizzando i tuxonice... problema che invece non ho mai riscontrato con i gentoo-sources. Devo però ammettere che non faccio un uso intensivo del suspend, solitamente spengo e riaccendo se non utilizzo il computer per molto tempo, altrimenti lo lascio acceso ;)
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Wed Jan 28, 2009 3:23 pm    Post subject: Reply with quote

Mah..il fatto è che uso tuxonice da un pò e non ho mai avuto di questi problemi...E comunque tuxonice non interagisce con il suspend-to-ram ma rimpiazza solo le funzionalità di suspend-to-disk.
Quindi il povero pinguino sul ghiaccio non dovrebbe c'entrare nulla :roll:
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Wed Jan 28, 2009 5:50 pm    Post subject: Reply with quote

non so che dirti... però a me con i tuxonice il suspend to ram non ha mai funzionato... con i gentoo-sources quando l'ho usato ha sempre funzionato...
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Wed Jan 28, 2009 6:41 pm    Post subject: Reply with quote

ma possibile che dmesg non dica nulla? o quantomeno metalog?

A me ricordo che con i driver intel usciva una scrittina balorda..
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Wed Jan 28, 2009 7:24 pm    Post subject: Reply with quote

Questa sera faccio un altro tentavio..guardo per bene l'orario in modo da capire se per caso venga loggato qualcosa al tentativo di resume.

Vi aggiorno appena possibile :wink:
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Thu Jan 29, 2009 7:19 am    Post subject: Reply with quote

Aggiornamento della situazione:
Ho reinstallato il driver NVIDIA 177.82 e la sospensione su ram semba aver funionato tranquillamente (sospeso ieri notte, ripristinato stamattina).

Adesso spero si comporti così anche per le prossime volte. Lascio il thread aperto per fare qualche eventuale aggiornamento. Quando vedrò che tutto va veramente come deve andare metterò il tag risolto :wink: :wink:

EDIT:
Aggiornamento della situazione 2:
Mi duole dirlo ma da quando ho installato i driver NVIDIA vecchi (177.82) pare che non ci sia più alcun problema.
Strano ma mi pareva di aver fatto dei test prima di postare.

Vabbè, meglio così! :wink: :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum