Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[webcam]problème micro (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Sat Jan 24, 2009 1:50 pm    Post subject: [webcam]problème micro (resolu) Reply with quote

Bonjour à tous,

J'ai un petit souci qui commence à me prendre sérieusement la tête.
Je viens d'acquérir une webcam Hercule Dualpix Exchange.
J'ai bien l'image sous skype (amsn par la même occasion pour tester), mais impossible d'activer le microphone. Pourtant avec arecord me permet bien d'enregistrer du son avec la webcam...
Dans kmix, l'interrupteur du microphone est "rouge" ce qui à priori ne me semble pas trop normal.
Donc je suis un petit perdu, et n'ai trouvé aucune solution... Si vous aviez une idée ?


Last edited by salamandrix on Wed Feb 04, 2009 1:28 am; edited 1 time in total
Back to top
View user's profile Send private message
fribadeau
Apprentice
Apprentice


Joined: 13 Jul 2003
Posts: 153
Location: Thonon (France)

PostPosted: Sat Jan 24, 2009 2:10 pm    Post subject: Reply with quote

Bonjour,

Pour Skype, je ne sais pas. Mais pour aMsn, les conversations video ne sont pas supportées.
Tu peux utiliser l'option webcam pour voir et être vu mais pas être entendu...
Back to top
View user's profile Send private message
VikingB
Apprentice
Apprentice


Joined: 19 May 2006
Posts: 263
Location: ~Brussels (B)

PostPosted: Sat Jan 24, 2009 5:05 pm    Post subject: Reply with quote

Normalement le témoin de micro doit être vert . Tu peux cliquer dessus et normalement cela doit passer au vert, et utiliser la réglette pour augmenter le son.
Sinon en console : alsamixer .
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Mon Jan 26, 2009 10:32 am    Post subject: Reply with quote

Hello salamandrix,

J'aimerai bien savoir comment tu as fait car moi j'ai une quickcam ultra et une 4000 pro, et sur aucune des deux je n'arrive à avoir le son, tu as mis quoi comme option dans ton noyau ?

D'avance merci
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Mon Jan 26, 2009 6:56 pm    Post subject: Reply with quote

Désolé de ne pas avoir donné de nouvelles plus tôt, mais un peu débordé en ce moment.

bouriquo >> j'ai activé dans le noyau snd_usb_audio (plus la suite) (Pour la vidéo : V4L, puis UVC (USB video class)).

Donc le problème à évolué. J'ai recompilé le kernel avec les pilotes alsa en modules (à la place d'en dur). Cela semble mieux passer mais il reste un gros hic :?
Effectivement si au démarrage la webcam est branché, snd_usb_audio est lancé, et la partie son de la webcam est déclarée par alsa comme la carte par défaut (0). Conséquence ni le micro de la webcam, ni la carte son du pc (déclarée comme carte 1) ne fonctionnent.

Y a-t-il une manip à faire sur la configuration des fichiers d'alsa ? Ou plutôt voir du côté d'udev ? pour que la carte son du pc soit toujours considérée par défaut.
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Tue Jan 27, 2009 2:52 pm    Post subject: Reply with quote

salamandrix wrote:
Y a-t-il une manip à faire sur la configuration des fichiers d'alsa ? Ou plutôt voir du côté d'udev ? pour que la carte son du pc soit toujours considérée par défaut.
Ni l'un ni l'autre mon colonnel ! :wink:
Ça se passe dans "/etc/modprobe.d/alsa". Je te mets ma configuration en vrac pour exemple :
Code:
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio
options snd-intel8x0 index=0
#options snd-usb-audio index=1 vid=046d pid=08c5
options snd-usb-audio index=1

# Set this to the correct number of cards.
options snd cards_limit=2
Bin, je ne sais pas si mon micro intégré à la webcam fonctionne avec ça mais ma carte son est initialisée la première et tout fonctionne parfaitement.

Enjoy !
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Wed Feb 04, 2009 1:27 am    Post subject: Reply with quote

Bon finalement résolu...

Cela dit yoyo en modifiant ce fichier il n'y a pas eu d'effet. Donc je suis retourné sur la solution suivante : en dur alsa avec la carte pci et en module l'usb audio... Je suspecte tout de même udev qui ne tient pas compte des fichiers ~/.asopud ou encore /etc/modprobe.d/alsa, ce qui berne alsa.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum