Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema in aggiornamento qt 4.3 -> 4.4
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Jan 20, 2009 5:58 pm    Post subject: Problema in aggiornamento qt 4.3 -> 4.4 Reply with quote

Code:
# emerge -aDNuv @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-terms/xterm-239 [237] USE="truetype unicode -Xaw3d -toolbar (-paste64%*)" 843 kB
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="glib qt3support ssl -debug -doc (-pch)" 102,858 kB
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="mysql odbc postgres qt3support sqlite -debug -firebird (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus glib mng nis qt3support tiff xinerama -debug -nas (-pch)" INPUT_DEVICES="-wacom" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug (-pch)" 0 kB
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug (-pch)" 0 kB
[ebuild     U ] dev-python/PyQt4-4.4.4-r1 [4.3.3] USE="X%* dbus%* opengl%* qt3support%* svg%* -debug -doc -examples -webkit%" 6,819 kB
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="dbus opengl qt3support (-accessibility%*) (-cups%*) (-debug%) (-doc%) (-examples%) (-firebird%) (-gif%*) (-glib%*) (-jpeg%*) (-mng%*) (-mysql%*) (-nas%) (-nis%*) (-odbc%*) (-pch%) (-png%*) (-postgres%*) (-sqlite%*) (-sqlite3%) (-ssl%*) (-tiff%*) (-xinerama%*) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

Total: 15 packages (3 upgrades, 12 new), Size of downloads: 110,519 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    ~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')

  ('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-test-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    >=x11-libs/qt-qt3support-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')
    ~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')

  ('ebuild', '/', 'x11-libs/qt-webkit-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
    ~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-opengl-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-opengl-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    >=x11-libs/qt-opengl-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')

  ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge') pulled in by
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
    >=x11-libs/qt-gui-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    (and 5 more)

  ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge') pulled in by
    ~x11-libs/qt-assistant-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-svg-4.4.2', 'merge') pulled in by
    >=x11-libs/qt-svg-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')
    ~x11-libs/qt-svg-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-sql-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-core-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge')
    >=x11-libs/qt-core-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')
    (and 5 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')
    ~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
    >=x11-libs/qt-dbus-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r1', 'merge')

  ('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-xmlpatterns-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    >=x11-libs/qt-4.3:4 required by ('installed', '/', 'app-text/poppler-bindings-0.8.7', 'nomerge')
    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'media-video/vlc-0.9.8a', 'nomerge')
    =x11-libs/qt-4* required by ('installed', '/', 'net-wireless/wpa_supplicant-0.5.7', 'nomerge')
Non riesco a capire da dove venga quel "<=x11-libs/qt-4.4.0_alpha:4" mi sono andato a guardare tutti gli ebuild incriminati ma non ne ho trovato traccia.
Stavolta non riesco proprio a capire. Bug di portage? (uso l'ultima versione)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Wed Jan 21, 2009 1:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Maialovic
Apprentice
Apprentice


Joined: 25 Apr 2006
Posts: 255

PostPosted: Tue Jan 20, 2009 7:17 pm    Post subject: Reply with quote

l'altro giorno quando ho aggiornato anche a me dava questo errore.....e' un problema che mi dava fin da quando provavo ad installare le qt incriminate erano keyworded.....credo che sia un errore dovuto a qualche programma che richiede le qt......cmq se disinstalli le qt-4.3.3 e poi fai emerge upgrade le installa senza problemi
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Jan 20, 2009 8:07 pm    Post subject: Re: Problema in aggiornamento Reply with quote

djinnZ wrote:
Code:

    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'media-video/vlc-0.9.8a', 'nomerge')


Non è che questo centra qualcosa?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Tue Jan 20, 2009 8:37 pm    Post subject: Reply with quote

a me risultavano bloccati due pacchetti, qt-core e qt-4.4.0_alpha:4, ho risolto aggiungendo <=x11-libs/qt-4.4.0_alpha:4 a package.mask, e il resto si è installato senza problemi
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Jan 21, 2009 1:19 pm    Post subject: Reply with quote

Non è un problema di soluzione (lo so che se rimuovo le qt e le reinstallo dovrebbe andare tutto a posto), è che vorrei capire da dove diavolo viene quel dannato <=x11-libs/qt-4.4.0_alpha:4 . Sul serio è la prima volta che non riesco a capire da dove venga un blocco.

Provo a vedere se è vlc l'origine, ma un = che diventa <= non mi torna... non corrispondono neppure le versioni...

Altri suggerimenti su come ispezionare le dipendenze?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Jan 21, 2009 2:27 pm    Post subject: Reply with quote

per i mod: perché cavolo il thread sticky sullo split di QT è chiuso??? :twisted:
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Jan 21, 2009 2:38 pm    Post subject: Reply with quote

Io ho risolto con un
Code:
emerge -C x11-libs/qt:4
e poi ho dato
Code:
emerge -vuND world
e tutto è andato a buon fine.
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
DevOne
Guru
Guru


Joined: 13 Jul 2005
Posts: 419

PostPosted: Wed Jan 21, 2009 4:52 pm    Post subject: Reply with quote

Anche a me da lo stesso problema....
penso che eliminando le qt, poi si risolva!
_________________
Real-time cooperative softair: http://www.softairrealfight.net
Qt generic-compass contribution: https://codereview.qt-project.org/#/c/92017
Open-source Virtual Keyboard QT widget: https://www.linux-apps.com/p/1132203/
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Jan 21, 2009 5:11 pm    Post subject: Reply with quote

djinnZ wrote:
Non è un problema di soluzione, è che vorrei capire da dove diavolo viene quel dannato <=x11-libs/qt-4.4.0_alpha:4
ripeto, non è il problema delle qt splitted, ci arrivo da solo... vorrei capire qual è il pacchetto che rompe (per segnalarlo se non è già stato fatto) ma non riesco a venirne a capo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Jan 21, 2009 6:55 pm    Post subject: Reply with quote

Quello che mostra il messaggio del blocco è la dipendenza come specificata nell'ebuild.

Se vlc vuole qt-4.3.x e uno qualunque dei qt-splitted ha
DEPEND="!<=x11-libs/qt-4.4.0_alpha:4"
ecco che hai il messaggio.

(o sbaglio qualcosa ? )
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Thu Jan 22, 2009 8:36 am    Post subject: Reply with quote

a quanto pare tutti i pezzi splitted di qt hanno un !<=x11-libs/qt-4.4.0_alpha:4 come dipendenza

comunque https://forums.gentoo.org/viewtopic-t-728726-start-0-postdays-0-postorder-asc-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum