Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Important bugfixes in portage-2.0.11
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Sun Jul 07, 2002 7:29 am    Post subject: Important bugfixes in portage-2.0.11 Reply with quote

Daniel Robbins wrote:
[gentoo-dev] Portage: good news and bad news

Hi Devs:

Bad news: I found a significant bug in Portage 2.0.10 and earlier that
could cause masking to work improperly, particularly if a package has a
~ entry in the profile's packages file.

Good news: I've fixed the problem in Portage 2.0.11 by rewriting
portage.py's portdbapi xmatch() and visible() methods. This has
resulted in a 44% speed-up in dependency calculations over Portage
2.0.10. If you thought things were fast before...

More good news: I've improved repoman to differentiate between
user-visible ebuilds with bad dependencies and masked ebuilds with bad
dependencies. When checking dependencies, user-visible ebuilds'
dependencies are only matched against user-visible ebuilds. But when
masked ebuilds are checked, deps are satisfied using *all* available
ebuilds. This should eliminate virtually all false positives in the
repoman DEPEND and RDEPEND QA tests. Type "repoman --help" for more
information on these new changes.

Enjoy!

--
Daniel Robbins
Chief Architect, Gentoo Linux
http://www.gentoo.org


Mailing list link: http://lists.gentoo.org/pipermail/gentoo-dev/2002-July/013444.html
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
Klavs
Guru
Guru


Joined: 22 May 2002
Posts: 536
Location: Denmark

PostPosted: Sun Jul 07, 2002 2:07 pm    Post subject: Reply with quote

That's great.. but cvs on cvs.gentoo.org seems to be DOWN :-(

# emerge rsync
>>> starting rsync with rsync://cvs.gentoo.org/gentoo-x86-portage...
rsync: failed to connect to cvs.gentoo.org: Connection refused
rsync error: error in socket IO (code 10) at clientserver.c(97)
_________________
Best regards,

Klavs Klavsen
Denmark

Working with Unix is like wrestling a worthy opponent.
Working with windows is like attacking a small whining child
who is carrying a .38.
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Sun Jul 07, 2002 2:12 pm    Post subject: Reply with quote

Klavs wrote:
That's great.. but cvs on cvs.gentoo.org seems to be DOWN :-(

# emerge rsync
>>> starting rsync with rsync://cvs.gentoo.org/gentoo-x86-portage...
rsync: failed to connect to cvs.gentoo.org: Connection refused
rsync error: error in socket IO (code 10) at clientserver.c(97)


Is not , this method was blocked for rsync!
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
Klavs
Guru
Guru


Joined: 22 May 2002
Posts: 536
Location: Denmark

PostPosted: Sun Jul 07, 2002 2:44 pm    Post subject: Reply with quote

Why? And how do I go about getting the new portage ebuild? it's not on any of the mirrors, that I've checked.
_________________
Best regards,

Klavs Klavsen
Denmark

Working with Unix is like wrestling a worthy opponent.
Working with windows is like attacking a small whining child
who is carrying a .38.
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Sun Jul 07, 2002 2:49 pm    Post subject: Reply with quote

Klavs wrote:
That's great.. but cvs on cvs.gentoo.org seems to be DOWN :-(

# emerge rsync
>>> starting rsync with rsync://cvs.gentoo.org/gentoo-x86-portage...
rsync: failed to connect to cvs.gentoo.org: Connection refused
rsync error: error in socket IO (code 10) at clientserver.c(97)


do it so:
#nano -w /etc/make.conf

In this file instead of "rsync://cvs.gentoo.org/gentoo-x86-portage"
enter rsync://rsync.gentoo.org/gentoo-portage

( save the file and exit )
#emerge rsync

Good luck
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
Klavs
Guru
Guru


Joined: 22 May 2002
Posts: 536
Location: Denmark

PostPosted: Sun Jul 07, 2002 4:27 pm    Post subject: Reply with quote

That worked.great. where and when was this change of rsync advertised? is it me whose just slow or?

Now I got some updates, but portage is still only v2.0.10 - anybody got v2.0.11?
_________________
Best regards,

Klavs Klavsen
Denmark

Working with Unix is like wrestling a worthy opponent.
Working with windows is like attacking a small whining child
who is carrying a .38.
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Sun Jul 07, 2002 4:30 pm    Post subject: Reply with quote

Have no idea about portage2.0.11 but the change of rsync address was made long time ago...
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Sun Jul 07, 2002 4:33 pm    Post subject: Reply with quote

Klavs wrote:
where and when was this change of rsync advertised?

About two months ago... You should periodically check the News & Announcements:

https://forums.gentoo.org/viewtopic.php?t=2051
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
Klavs
Guru
Guru


Joined: 22 May 2002
Posts: 536
Location: Denmark

PostPosted: Sun Jul 07, 2002 4:45 pm    Post subject: Reply with quote

My Gentoo install isn't two months old :-)

I'm using Gentoo-1.3a test iso for gcc-3.1 :-)

guess it wasn't updated, and it has worked until yesterday.

But I do keep an eye on news.

Tnx. Any of you got the 2.0.11 ebuild?
_________________
Best regards,

Klavs Klavsen
Denmark

Working with Unix is like wrestling a worthy opponent.
Working with windows is like attacking a small whining child
who is carrying a .38.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Sun Jul 07, 2002 4:50 pm    Post subject: Reply with quote

:oops: I installed something that updated my make files.
I missed that line with diff... all better now :D
Still no 2.0.11 though.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
iKiddo
Guru
Guru


Joined: 27 Jun 2002
Posts: 329
Location: Europe?

PostPosted: Tue Jul 09, 2002 12:58 pm    Post subject: Reply with quote

Not sure if you not already know, but apparently Portage 2.0.11 is available, I got it yesterdayevening (time region amsterdam :) ) when I did an emerge -pu world. Everything seems working here :) . Thought you might want to know...
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Tue Jul 09, 2002 1:01 pm    Post subject: Reply with quote

iKiddo wrote:
Not sure if you not already know, but apparently Portage 2.0.11 is available


Um...thanks, but wasn't that the point of the original post? (entitled, "Important bugfixes in portage-2.0.11") :)

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Scandium
Retired Dev
Retired Dev


Joined: 22 Apr 2002
Posts: 340
Location: Germany

PostPosted: Tue Jul 09, 2002 1:02 pm    Post subject: Reply with quote

klieber wrote:
iKiddo wrote:
Not sure if you not already know, but apparently Portage 2.0.11 is available


Um...thanks, but wasn't that the point of the original post? (entitled, "Important bugfixes in portage-2.0.11") :)

--kurt


lol :)
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Tue Jul 09, 2002 1:44 pm    Post subject: Reply with quote

I upgraded portage from 2.0.10 to 2.0.11 yesterday. I found out it has 1 bug:
emerge -b portage does not generate the .tbz2 for 2.0.11.
The -b option works for other packages, it does not work for portage itself.
Version 2.0.10 does not have this problem.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Tue Jul 09, 2002 3:15 pm    Post subject: Reply with quote

klieber wrote:
iKiddo wrote:
Not sure if you not already know, but apparently Portage 2.0.11 is available


Um...thanks, but wasn't that the point of the original post? (entitled, "Important bugfixes in portage-2.0.11") :)

--kurt
What is the trick to finding it? I have it now, but not when I made my previous post in this thread.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Tue Jul 09, 2002 4:12 pm    Post subject: Reply with quote

kanuslupus wrote:
What is the trick to finding it?


I think part of it has to do with what rsync server you hit and how fast it updates. rsync servers are supposed to update every 30 minutes with the master server, but some may not follow that schedule as religiously.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Tue Jul 09, 2002 4:14 pm    Post subject: Reply with quote

klieber wrote:
I think part of it has to do with what rsync server you hit and how fast it updates. rsync servers are supposed to update every 30 minutes with the master server, but some may not follow that schedule as religiously.

--kurt
Heathens... repent! repent! :D
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
jean-michel
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2002
Posts: 142
Location: Somewhere East of the Atlantic

PostPosted: Wed Jul 10, 2002 7:19 pm    Post subject: Still having portage problems with clean install -> 2.0.1 Reply with quote

The following problem arises with portage 2.0.11, off of a clean build from a 1.2 iso:

Code:

# emerge -up system

These are the packages that I would merge, in order.

Calculating system dependencies -
!!! Error: couldn't find match for sys-devel/ld.so in update (likely old /var/db/pkg entry)


Where the hell does ld.so come from, and does anyone know how I fix this? Note this is a clean, fresh install of Gentoo, to which has only been added some local ebuild categories with the following script:

Code:

KCCO_SECTION_LIST="kcco-3rdParty kcco-admin kcco-apps kcco-libs kcco-tablet"

[ ...]

# clean out old stuff
for n in ${KCCO_SECTION_LIST}; do rm -rf /usr/portage/$n ; done
emerge --clean rsync

#
# copy over kcco ebuilds
#
rsync -aCzv rsync://${KCCO_EBUILD_HOST}${KCCO_EBUILD_DIR} /usr/portage

# now, fix categories file

for n in ${KCCO_SECTION_LIST}
  do echo "$n" >> /usr/portage/profiles/categories
done


This misbehavior began somewhere early in the portage 2.0.x releases, and persists in 2.0.11. Any help would be greatly appreciated.
_________________
The Struggle for the Future of Human Evolution Begins: Autonomy the SciFi Series!
Back to top
View user's profile Send private message
Scandium
Retired Dev
Retired Dev


Joined: 22 Apr 2002
Posts: 340
Location: Germany

PostPosted: Thu Jul 11, 2002 12:04 pm    Post subject: Reply with quote

2.0.12 closed quite many bugs, too !
(emerge --help rsync now really helps, and doesn't sync etc. etc.)

works quite well here...


But as in another thread I see that there is a .so failure related to gcc....doesn't happen to me (yet)... well :)


Last edited by Scandium on Thu Jul 11, 2002 12:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Thu Jul 11, 2002 12:20 pm    Post subject: Reply with quote

The recent portage problems seem to have quieted down quite a bit. While there are still one or two people having problems, the majority of folks seem to be happy with 2.0.11

unsticking thread.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum