Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema con K3B
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 19, 2009 11:26 am    Post subject: [RISOLTO] Problema con K3B Reply with quote

Salve, devo masterizzare un CD urgente importante e mi esce sto errore in K3B, è la prima volta che mi propone sta cosa quindi deve essere tutto frutto di un aggiornamento che ho fatto chissà quando (non masterizzo da un bel po').

Forse ho vagamente capito a cosa si riferisce pero' non so dove andare a risolvere cosa, mi date un aiuto per cortesia che ho bisogno di spedire urgentemente sti dati ?

Ecco l'errore che trovo all'avvio di K3B

Quote:
L'insieme di caratteri locale è ANSI_X3.4-1968
L'insieme di caratteri locali del tuo sistema (per esempio quello usato per codificare i nomi di file) è impostato ad ANSI_X3.4-1968. È improbabile che ciò sia intenzionale. Molto probabilmente l'insieme dei caratteri locali non è impostato affatto. Un'impostazione non valida porterà problemi quando si creano progetti dati.
Soluzione: Per impostare nella maniera corretta l'insieme di caratteri locali assicurati che le variabili d'ambiente LC_* siano impostate. Normalmente gli strumenti che regolano le impostazioni della distribuzione già provvedono a farlo.


Last edited by lsegalla on Mon Apr 20, 2009 2:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Jan 19, 2009 1:08 pm    Post subject: Reply with quote

controlla di aver seguito la guida alla localizzazione in modo da avere utf-8, e che il filesystem dove risiedono i dati sia anch'esso in utf-8
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 19, 2009 1:26 pm    Post subject: Reply with quote

Peach wrote:
controlla di aver seguito la guida alla localizzazione in modo da avere utf-8, e che il filesystem dove risiedono i dati sia anch'esso in utf-8

Ti riferisci a questa?
http://www.gentoo.org/doc/it/guide-localization.xml?style=printable

Io in /etc/env.d non trovo il file /etc/env.d/02locale, infatti:
Code:

gentoo-linux env.d # ls
00basic                  08nspr       20ant                  30sane          45qt3    50ncurses   60ladspa  90opera            99kde-env    gcc
03opengl                 08nss        20java-config          37fontconfig    50gconf  50qtdir3    70klibc   98ca-certificates  99libstdc++
05binutils               10ICAClient  20udev                 44qt4           50gtk2   50slib      70less    98texlive          99splash
05gcc-i686-pc-linux-gnu  10stuffit    30java-finalclasspath  45kdepaths-3.5  50guile  50xerces-c  90games   99gentoolkit-env   binutils


Non ho capito se questo file devo crearlo... non c'è scritto, oppure non l'ho letto (mi va bene usarlo per tutto il sistema, ho letto la guida)

-- EDIT ---
Aggiungo anche
Code:
luca@gentoo-linux ~ $ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=


Quindi credo proprio che manchi tutto, ora sto spippolando sui files, non so ancora se sto facendo giusto ma spero di si... :-)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Jan 19, 2009 1:33 pm    Post subject: Reply with quote

devi crearlo
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 19, 2009 1:39 pm    Post subject: Reply with quote

Ho creato il file /etc/env.d/02locale con il seguente codice all'interno
Code:
LANG="it_IT.utf8@euro"
LC_COLLATE="C"


quindi sono uscito in console e ho fatto
Code:
env-update && source /etc/profile


Detto questo ho riavviato e dopo il riavvio il problema in K3B persiste, inoltre se eseguo LOCALE vedo:
Code:
luca@gentoo-linux ~ $ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT.utf8@euro
LC_CTYPE="it_IT.utf8@euro"
LC_NUMERIC="it_IT.utf8@euro"
LC_TIME="it_IT.utf8@euro"
LC_COLLATE=C
LC_MONETARY="it_IT.utf8@euro"
LC_MESSAGES="it_IT.utf8@euro"
LC_PAPER="it_IT.utf8@euro"
LC_NAME="it_IT.utf8@euro"
LC_ADDRESS="it_IT.utf8@euro"
LC_TELEPHONE="it_IT.utf8@euro"
LC_MEASUREMENT="it_IT.utf8@euro"
LC_IDENTIFICATION="it_IT.utf8@euro"
LC_ALL=
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Jan 19, 2009 1:58 pm    Post subject: Reply with quote

ti sei scordato di editare /etc/locale.gen e lanciare localedef mi sa
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 19, 2009 2:06 pm    Post subject: Reply with quote

djinnZ wrote:
ti sei scordato di editare /etc/locale.gen e lanciare localedef mi sa


Ora ho continuato editando (e creando) il file /etc/locale.gen all'interno del quale ho messo:
Code:
en_GB ISO-8859-1
en_GB.UTF-8 UTF-8
it_IT/ISO-8859-1
it_IT@euro/ISO-8859-15


Quindi:
Code:
gentoo-linux luca # locale-gen
 * Generating 3 locales (this might take a while) with 1 jobs
 *  (1/3) Generating en_GB.ISO-8859-1 ...                                                                                                             [ ok ]
 *  (2/3) Generating en_GB.UTF-8 ...                                                                                                                  [ ok ]
 *  (3/3) Generating it_IT/ISO-8859-1 ...
character map file `it_IT@euro/ISO-8859-15' not found: No such file or directory
cannot open locale definition file `it_IT/ISO-8859-1': Not a directory                                                                                [ !! ]
 * Perhaps you meant to use a space instead of a / in your config file ?
 * Generation complete


Quindi ho sostituito la / con i punti e quindi:
Code:
gentoo-linux luca # locale-gen
 * Generating 3 locales (this might take a while) with 1 jobs
 *  (1/3) Generating en_GB.ISO-8859-1 ...                                                                                                             [ ok ]
 *  (2/3) Generating en_GB.UTF-8 ...                                                                                                                  [ ok ]
 *  (3/3) Generating it_IT.ISO-8859-1 ...
character map file `it_IT@euro.ISO-8859-15' not found: No such file or directory
/usr/share/i18n/locales/it_IT:24: LC_IDENTIFICATION: unknown character in field `address'                                                             [ !! ]
 * Generation complete


Ho provato anche con localedef giusto per seguire quel che mi dicevi
Code:
gentoo-linux luca # localedef
Try `localedef --help' or `localedef --usage' for more information.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Jan 19, 2009 4:07 pm    Post subject: Reply with quote

it_IT@euro/ISO-8859-15 non è utf8, devi aggiungere it_IT.utf8@euro, ti consiglio di togliere il GB e sostituirlo con l'US.
Documentazione wrote:
localedef -c -i en_US -f ISO-8859-15 en_US.ISO-8859-15
a questo mi riferivo
Il mio locale.gen
Code:
en_US ISO-8859-1
en_US.UTF-8 UTF-8
it_IT ISO-8859-1
it_IT.UTF-8 UTF-8
it_IT@euro ISO-8859-15
con LINGUAS="it en" in make.conf, lancia locale.gen, controlla che nel kernel i supporti per 437 850 ansi 8859-1 8859-11 e utf8 siano builtin e dovrebbe funzionare.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 19, 2009 4:40 pm    Post subject: Reply with quote

Ho fatto tutto, ho passato il locale.gen come il tuo, ho lanciato localedef e ho modificato anche il make.conf e quindi lanciato locale-gen
Tutto ancora non funziona, sono entrato dentro al kernel (Kernel 2.6.27-gentoo-r7 for x86...) e precisamente sono andato in:
FILE SYSTEMS -> NATIVE LANGUAGE SUPPORT (è sempre un problema per me trovare le voci nel kernel)

850 l'ho attivato ora
437, 8859-1 erano già builtin
8859-11 non esiste proprio nella lista

Ora ho lanciato la compila ma non so se la cosa andrà a buon fine a sto punto... qualche altra cosa da provare?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Jan 19, 2009 5:18 pm    Post subject: Reply with quote

8O ... 8859-15 ... :? ma non si può sbagliare a scrivere? Ovviamente devono concordare make.conf e locale.gen en o en_US corrispondono a US en_GB in make conf vuole en_GB in locale.gen.
A questo punto dovrebbe sparire l'errore per file non trovato.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Jan 20, 2009 8:32 am    Post subject: Reply with quote

THEOSAURUS MODE ON

Code:
ma non si può sbagliare a scrivere?

si, infatti:
Quote:
con LINGUAS="it en" in make.conf, lancia locale.gen
e io
Quote:
e quindi lanciato locale-gen


THEOSAURUS MODE OFF
:P :P :P :P

Il kernel è ricompilato e ho riavviato.
Il mio locale.gen coincide col tuo.
In /etc/make.conf ho indicato LINGUAS="it us"
Ho verificato che sto usando quello giusto appena ricompilato con uname -r

Ancora non funziona, il sintomo in K3B è sempre il medesimo.
1. Forse devo ancora usare localedef che non mi sembra di averlo fatto in questi ultimi passaggi ?
2. Forse è da riconfigurare qualcosa anche in K3B ?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Jan 20, 2009 6:09 pm    Post subject: Reply with quote

locale-gen non fa altro che lanciare in sequenza localedef per i set definiti in locale.gen quindi sei a posto.
L'errore
Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dovrebbe essere sparito ormai e locale dovrebbe essere impostato su it_IT.UTF-8 e UNICODE=yes in rc.conf.

nella guida che hai linkato trovo una incoerenza: in locale.gen it_IT@euro ma nell'output di locale it_IT.UTF-8@euro. (scen se ci sei batti un colpo...)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jan 21, 2009 3:57 pm    Post subject: Reply with quote

Ho mandato una mail a SCEN intanto...
Detto questo rc.conf non mi sembra del tutto a posto

Code:

UNICODE="yes"
EDITOR="/bin/nano"


C'è solo questo....
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Jan 21, 2009 10:50 pm    Post subject: Reply with quote

djinnZ wrote:
nella guida che hai linkato trovo una incoerenza: in locale.gen it_IT@euro ma nell'output di locale it_IT.UTF-8@euro. (scen se ci sei batti un colpo...)

Cazzarola, c'è sì un errore nel Codice 3.10!

E difatti genera l'errore che ha riscontrato lsegalla!

Grazie della segnalazione, correggo immantinente 8)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Jan 22, 2009 11:29 am    Post subject: Reply with quote

Scusate ma mi sono un po' perso... alla fine avete una soluzione per me ? :)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Jan 22, 2009 11:37 am    Post subject: Reply with quote

Usi app-cdr/cdrtools o app-cdr/cdrkit?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Jan 22, 2009 11:39 am    Post subject: Reply with quote

Scen wrote:
Usi app-cdr/cdrtools o app-cdr/cdrkit?

Code:

luca@gentoo-linux ~ $ eix cdrtools
* app-cdr/cdrtools
     Available versions:  2.01.01_alpha34 ~2.01.01_alpha41 ~2.01.01_alpha42 ~2.01.01_alpha50-r3 2.01.01_alpha51 ~2.01.01_alpha52 ~2.01.01_alpha53 {unicode}
     Homepage:            http://cdrecord.berlios.de/
     Description:         A set of tools for CD/DVD reading and recording, including cdrecord

luca@gentoo-linux ~ $ eix cdrkit
[I] app-cdr/cdrkit
     Available versions:  1.1.6 1.1.8 ~1.1.9 {hfs kernel_FreeBSD kernel_linux unicode}
     Installed versions:  1.1.8(14:47:59 10/27/08)(kernel_linux unicode -hfs -kernel_FreeBSD)
     Homepage:            http://cdrkit.org/
     Description:         A set of tools for CD/DVD reading and recording, including cdrecord


(ma io nemmeno sapevo di averlo cdrkit)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Jan 22, 2009 1:22 pm    Post subject: Reply with quote

Dacci qualche info: cosa ti riporta
Code:

locale

?

Ti succede cercando di masterizzare qualsiasi file? Quando ti viene restituito quell'errore che descrivi nel primo messaggio?

X scrupolo, riportaci anche l'output di
Code:

env

lanciato da konsole (immagino tu stia utilizzando KDE :P )

Stai usando KDE 3.5.x o 4.x ?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Jan 22, 2009 1:34 pm    Post subject: Reply with quote

Pronti ecco le info in piu'... :)

1. utilizzo kde 3.5, non mi son mai azzardato a sfiorare il 4 per ora
2. l'errore esce appena entro in k3b, non serve che io inizi qualche progetto, è sufficiente aprire il K3B e mi esce subito quell'errore insieme al K3B
3. l'errore di locale mi era sparito, ora lo rivedo, non ci capisco piu' na mazza
Code:

gentoo-linux luca # locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT.utf8@euro
LC_CTYPE="it_IT.utf8@euro"
LC_NUMERIC="it_IT.utf8@euro"
LC_TIME="it_IT.utf8@euro"
LC_COLLATE=C
LC_MONETARY="it_IT.utf8@euro"
LC_MESSAGES="it_IT.utf8@euro"
LC_PAPER="it_IT.utf8@euro"
LC_NAME="it_IT.utf8@euro"
LC_ADDRESS="it_IT.utf8@euro"
LC_TELEPHONE="it_IT.utf8@euro"
LC_MEASUREMENT="it_IT.utf8@euro"
LC_IDENTIFICATION="it_IT.utf8@euro"
LC_ALL=


4. ENV
Code:

gentoo-linux luca # env
MANPATH=/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man:/etc/java-config/system-vm/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man:/opt/opera/share/man
KDE_MULTIHEAD=false
DM_CONTROL=/var/run/xdmctl
SHELL=/bin/bash
KDEWM=/usr/bin/fusion-icon
TERM=xterm
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/luca/.gtkrc-2.0:/home/luca/.kde3.5/share/config/gtkrc-2.0
GS_LIB=/home/luca/.fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/luca/.gtkrc:/home/luca/.kde3.5/share/config/gtkrc
WINDOWID=39845893
QTDIR=/usr/qt/3
KDE_FULL_SESSION=true
ANT_HOME=/usr/share/ant-core
USER=root
PRELINK_PATH_MASK=/usr/lib/klibc
LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:
GDK_USE_XFT=1
GUILE_LOAD_PATH=/usr/share/guile/1.8
KDEDIR=/usr/kde/3.5
XERCESC_NLS_HOME=/usr/share/xerces-c/msg
SESSION_MANAGER=local/gentoo-linux:/tmp/.ICE-unix/13486
CONFIG_PROTECT_MASK=/etc/env.d/java/ /etc/udev/rules.d /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/ca-certificates.conf /etc/texmf/web2c /etc/revdep-rebuild /etc/splash
PAGER=/usr/bin/less
XDG_CONFIG_DIRS=/usr/kde/3.5/etc/xdg
KONSOLE_DCOP=DCOPRef(konsole-16094,konsole)
PATH=/sbin:/bin:/usr/sbin:/usr/bin
DESKTOP_SESSION=kde-3.5
LC_COLLATE=C
PWD=/home/luca
KONSOLE_DCOP_SESSION=DCOPRef(konsole-16094,session-1)
JAVA_HOME=/etc/java-config-2/current-system-vm
EDITOR=/bin/nano
JAVAC=/etc/java-config-2/current-system-vm/bin/javac
KDE_SESSION_UID=1000
LANG=it_IT.utf8@euro
KDEDIRS=/usr:/usr/local:/usr/kde/3.5
QMAKESPEC=linux-g++
HOME=/root
SHLVL=3
ICAROOT=/opt/ICAClient
JDK_HOME=/etc/java-config-2/current-system-vm
XCURSOR_THEME=none
SCHEME_LIBRARY_PATH=/usr/share/slib/
LOGNAME=root
LESS=-R -M --shift 5
CVS_RSH=ssh
GCC_SPECS=
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-9uvz6Huhls,guid=b4d8281a40b0f6d38789c6f3497826fd
ROOTPATH=/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/ICAClient:/opt/stuffit/bin:/usr/qt/3/bin:/usr/games/bin
CLASSPATH=.
XDG_DATA_DIRS=/usr/share:/usr/kde/3.5/share:/usr/local/share
LESSOPEN=|lesspipe.sh %s
PKG_CONFIG_PATH=/usr/qt/3/lib/pkgconfig
INFOPATH=/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info
DISPLAY=:0.0
LADSPA_PATH=/usr/lib/ladspa
OPENGL_PROFILE=xorg-x11
USB_DEVFS_PATH=/dev/bus/usb
SANE_CONFIG_DIR=/etc/sane.d
LDPATH=/usr/kde/3.5/lib:
CONFIG_PROTECT=/usr/kde/3.5/share/config /usr/kde/3.5/env /usr/kde/3.5/shutdown /usr/share/config
XAUTHORITY=/root/.xauthPskGwv
COLORTERM=
_=/bin/env
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Jan 22, 2009 7:24 pm    Post subject: Reply with quote

it_IT -> 8859-1
it_IT@euro -> 8859-15 (ovvero 8859-1 con il simbolo dell'euro)
it_IT.UTF-8 -> utf8 (che a sua volta comprende il simbolo dell'euro e tutte le 8859 per quel che so)

it_IT.UTF-8@euro è un controsenso. In ogni caso localedef --list-archive cosa riporta?

Seconda cosa: devi configurare /etc/locale.nopurge nello stesso modo o rischi che ad ogni invocazione di localepurge ti spazzi via le localizzazioni giuste (di default risparmia solo en e de mi pare) e poi i programmi si incazzano.

Il mio localedef --list-archive
Code:
en_US
en_US.iso88591
en_US.utf8
it_IT
it_IT.iso88591
it_IT.iso885915@euro
it_IT.utf8
it_IT@euro
italian
ed il mio locale.nopurge
Code:
en
en_US
en_US.UTF-8
it
it_IT
it_IT.UTF-8
it_IT@euro
ed il mio 02locale
Code:
LC_ALL="it_IT.UTF-8"
LANG="it_IT.UTF-8"
LC_COLLATE="C"



Ma l'errore di k3b lo vedi nei log di X o avviandolo dalla stessa konsole che hai usato per lanciare il comando locale?

@scen: mi pare che la guida usi le opzioni di localizzazione per le tabelle 8859-1 e 15 anche per uf8 mentre sono due cose diverse e l'errore è nel codice 3.1 non nel 3.10. Per esempio
Code:
LANG="it_IT@euro" se si usa la mappatura "tradizionale" LANG="it_IT.UTF-8" se si usa la mappatura utf-8
sarebbe più corretto. Ovviamente la versione en corrisponde quindi non è un refuso di traduzione.
Lo dico perchè uso queste impotazioni senza problemi. (o mi sono perso qualcosa?)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Jan 22, 2009 10:41 pm    Post subject: Reply with quote

djinnZ wrote:
i@scen: mi pare che la guida usi le opzioni di localizzazione per le tabelle 8859-1 e 15 anche per uf8 mentre sono due cose diverse e l'errore è nel codice 3.1 non nel 3.10. Per esempio
Code:
LANG="it_IT@euro" se si usa la mappatura "tradizionale" LANG="it_IT.UTF-8" se si usa la mappatura utf-8
sarebbe più corretto. Ovviamente la versione en corrisponde quindi non è un refuso di traduzione.
Lo dico perchè uso queste impotazioni senza problemi. (o mi sono perso qualcosa?)

No no, è che la guida originale fa gli esempi di localizzazione in tedesco, ma a me pareva poco utile tradurre pari pari, e ho deciso di mettere gli esempi per la localizzazione in italiano.

Vedo di sistemare i vari esempi di codice, rendendoli coerenti.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
stardast
n00b
n00b


Joined: 20 Feb 2009
Posts: 2

PostPosted: Fri Feb 20, 2009 6:10 pm    Post subject: Reply with quote

Ciao! Anch'io sono alle prese con lo stesso problema, con una complicazione in più:

Quote:
dast paolo # cat /etc/locale.gen
en_US ISO-8859-1
en_US.UTF-8 UTF-8
it_IT ISO-8859-1
it_IT@euro ISO-8859-15
it_IT.UTF-8 UTF-8


Quote:
dast paolo # cat /etc/env.d/02locale
LC_ALL="it_IT.UTF-8"
LANG="it_IT_UTF-8"
LC_COLLATE="C"


o anche:

Quote:
dast paolo # cat /etc/env.d/02locale
LC_ALL="it_IT.UTF-8"
LANG="it_IT.utf8@euro"
LC_COLLATE="C"


Quote:

dast paolo # locale
LANG=it_IT_UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=it_IT.UTF-8


con queste impostazioni K3B non da messaggi di errore, ma nella shell e con dolphin (uso kde4.2 e ext4) non vedo più le lettere accentate (sostituite da simboletti), se invece setto:

Quote:
dast paolo # cat /etc/env.d/02locale
LANG="it_IT.utf8@euro"
LC_COLLATE="C"


Quote:
dast paolo # locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT.utf8@euro
LC_CTYPE="it_IT.utf8@euro"
LC_NUMERIC="it_IT.utf8@euro"
LC_TIME="it_IT.utf8@euro"
LC_COLLATE=C
LC_MONETARY="it_IT.utf8@euro"
LC_MESSAGES="it_IT.utf8@euro"
LC_PAPER="it_IT.utf8@euro"
LC_NAME="it_IT.utf8@euro"
LC_ADDRESS="it_IT.utf8@euro"
LC_TELEPHONE="it_IT.utf8@euro"
LC_MEASUREMENT="it_IT.utf8@euro"
LC_IDENTIFICATION="it_IT.utf8@euro"
LC_ALL=


i file con caratteri accentati vengono visualizzati correttamente ma K3B mi da lo stesso messaggio di lsegalla.
Se imposto LC_CTYPE e LC_MESSAGES (=it_IT.utf8) posso far sparire i primi due
Quote:
locale: Cannot set LC_* to default locale: No such file or directory

mentre LC_ALL non ho proprio capito come impostarlo, la guida dice che è sconsigliato usarlo però se non lo imposto locale mi restituisce quella segnalazione...

Un altro problema che ho con questa configurazione è che se provo ad aprire un file accentato con VLC (un mp3) o Gwenview (un jpg) non lo apre, con RealPlayer11 o gimp si (gimp anche se lo apre dice:
Quote:
Execution error for procedure 'gimp-image-set-filename': Invalid byte sequence in conversion input

)

Idee o suggerimenti?

Grazie mille!
Paolo

PS make.conf contiente LINGUAS="it us", locale.nopurge è lo stesso di djinnZ e rc.conf contiene UNICODE=yes


Edit: ah, dimenticavo... se lancio ufed ottengo
Quote:

dast paolo # ufed
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_COLLATE = "C",
LANG = "it_IT.utf8@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Last edited by stardast on Fri Feb 20, 2009 9:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Fri Feb 20, 2009 7:05 pm    Post subject: Reply with quote

Solo io vedo tutto sfasato?
Non ci sono problemi con i quote?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Sat Feb 21, 2009 10:36 am    Post subject: Reply with quote

anche io vedo sfasato. credo sia colpa della riga LS_COLORS in questo post
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Sat Feb 21, 2009 10:51 am    Post subject: Reply with quote

devilheart wrote:
anche io vedo sfasato. credo sia colpa della riga LS_COLORS in questo post


Ero sul windows della mia ragazza. Qui su gentoo/firefox si vede bene.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum