Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Yet another qt slot conflict [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
moosh
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2004
Posts: 148

PostPosted: Mon Jan 19, 2009 7:07 am    Post subject: Yet another qt slot conflict [SOLVED] Reply with quote

This is what I got after --sync'ing today:

Code:
# emerge -uDNpv world system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-db/sqlite-3.6.6.2 [3.5.9] USE="threadsafe -debug -doc -soundex -tcl" 2,250 kB [0]
[ebuild     U ] app-arch/cpio-2.9-r2 [2.9-r1] USE="nls" 741 kB [0]
[ebuild     U ] net-misc/dhcpcd-4.0.7 [4.0.2] USE="compat zeroconf" 52 kB [0]
[ebuild     U ] media-libs/libpng-1.2.34 [1.2.33] 503 kB [0]
[ebuild     U ] dev-libs/mpfr-2.3.2 [2.3.1_p1] 798 kB [0]
[ebuild     U ] dev-python/sip-4.7.9 [4.7.3] USE="-debug" 461 kB [0]
[ebuild     U ] media-libs/libmpeg2-0.5.1 [0.4.1] USE="X sdl" 513 kB [?=>0]
[ebuild     U ] app-text/hunspell-1.2.8 [1.2.6] USE="ncurses nls readline" 766 kB [0]
[ebuild     U ] sys-apps/groff-1.19.2-r3 [1.19.2-r1] USE="X -cjk" 2,836 kB [?=>0]
[ebuild     U ] mail-mta/ssmtp-2.62-r4 [2.62-r3] USE="ipv6 ssl -maxsysuid -md5sum" 56 kB [0]
[ebuild     U ] x11-libs/wxGTK-2.8.9.1-r3 [2.8.8.1] USE="X opengl sdl -debug -doc -gnome -gstreamer -odbc -pch" 27,315 kB [0]
[ebuild     U ] x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4 -debug -doc -examples" 2,097 kB [0]
[ebuild     U ] dev-python/PyQt-3.17.6 [3.17.4] USE="-debug -doc -examples" 795 kB [0]
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="qt3support ssl -debug -doc -glib -pch" 102,858 kB [0]
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres" 0 kB [0]
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus mng nas qt3support tiff -debug -glib -nis -pch -xinerama" INPUT_DEVICES="-wacom" 0 kB [0]
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch" 0 kB [0]
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch" 0 kB [0]
[ebuild     U ] net-im/skype-2.0.0.72 [2.0.0.68] USE="-qt-static" 14,751 kB [0]
[ebuild     U ] dev-python/PyQt4-4.4.4-r1 [4.3.3] USE="X%* dbus%* opengl%* svg%* -debug -doc -examples -qt3support% -webkit%" 6,819 kB [0]
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch" 0 kB [0]
[ebuild     U ] dev-python/qscintilla-python-2.3.2 [2.1] USE="qt4" 0 kB [0]
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="dbus opengl -qt3support* (-accessibility%*) (-cups%*) (-debug%) (-doc%) (-examples%) (-firebird%) (-gif%*) (-glib%) (-jpeg%*) (-mng%*) (-mysql%) (-nas%*) (-nis%) (-odbc%) (-pch%) (-png%*) (-postgres%) (-sqlite%) (-sqlite3%) (-ssl%*) (-tiff%*) (-xinerama%) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB [0]
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

Total: 29 packages (17 upgrades, 12 new), Size of downloads: 163,602 kB
Conflict: 1 block (1 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

  ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
    >=x11-libs/qt-4.3:4 required by ('installed', '/', 'app-text/poppler-bindings-0.8.7', 'nomerge')
    >=x11-libs/qt-4.2.0:4 required by ('installed', '/', 'app-crypt/qca-2.0.0-r2', 'nomerge')

  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    =x11-libs/qt-4.3*:4 required by ('ebuild', '/', 'x11-libs/qscintilla-2.3.2', 'merge')
    (and 2 more)


Apparently, qscintilla requires qt-4.3* while qt-4.4.2 is about to be merged. There is also the qt-4.4.0_alpha mentioned which I do not understand. Anyone knows what to do?


Last edited by moosh on Mon Jan 19, 2009 2:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1678
Location: Edinburgh, UK

PostPosted: Mon Jan 19, 2009 8:17 am    Post subject: Re: Yet another qt slot conflict Reply with quote

I've got a similar problem, though it looks different. It's manifesting itself on two of my machines. Any help would be appreciated.

Best,

Alex

On my work machine, I get this:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-db/sqlite-3.6.6.2  USE="threadsafe -debug -doc -soundex -tcl"
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="qt3support ssl -debug -doc -glib -pch"
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres"
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus qt3support tiff -debug -glib -mng -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom"
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch"
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch"
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch"
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3]
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)


The home machine's output looks a bit different.

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-libs/wxGTK-2.8.9.1-r3 [2.8.8.1]
[ebuild     U ] dev-python/wxpython-2.8.9.1-r2 [2.8.8.1] USE="cairo%*"
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="qt3support ssl -debug -doc -glib -pch"
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres"
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus qt3support tiff -debug -glib -mng -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom"
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch"
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch"
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch"
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3]
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

  ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
    >=x11-libs/qt-4.3:4 required by ('installed', '/', 'app-text/poppler-bindings-0.8.7', 'nomerge')
    x11-libs/qt required by world
    >=x11-libs/qt-4.2.0:4 required by ('installed', '/', 'app-crypt/qca-2.0.0-r2', 'nomerge')

  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'x11-misc/qcomicbook-0.4.0', 'nomerge')
    <x11-libs/qt-4.4:4 required by ('installed', '/', 'x11-themes/qtcurve-qt4-0.59.6', 'nomerge')
    (and 3 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
MaratIK
n00b
n00b


Joined: 02 Apr 2003
Posts: 20
Location: Moscow, Russia

PostPosted: Mon Jan 19, 2009 8:50 am    Post subject: Reply with quote

The same problem here:

Code:
$ sudo emerge -upvDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] app-arch/cpio-2.9-r2 [2.9-r1] USE="nls" 0 kB
[ebuild     U ] media-libs/libpng-1.2.34 [1.2.33] 503 kB
[ebuild     U ] dev-db/sqlite-3.6.6.2 [3.5.9] USE="doc tcl threadsafe -debug -soundex" 4,411 kB
[ebuild     U ] sys-devel/gdb-6.8-r1 [6.7.1-r3] USE="nls -multitarget% -test -vanilla" 15,337 kB
[ebuild     U ] dev-python/sip-4.7.9 [4.7.3] USE="-debug" 461 kB
[ebuild  N    ] net-mail/mailbase-1  USE="pam" 0 kB
[ebuild     U ] mail-mta/ssmtp-2.62-r4 [2.62-r3] USE="ipv6 ssl -maxsysuid -md5sum" 0 kB
[ebuild     U ] sys-apps/groff-1.19.2-r3 [1.19.2-r1] USE="X -cjk" 0 kB
[ebuild     U ] x11-libs/qscintilla-2.3.2 [2.1-r1] USE="doc examples python qt4 -debug" 2,097 kB
[ebuild     U ] dev-python/PyQt-3.17.6 [3.17.4] USE="doc examples -debug" 795 kB
[ebuild     U ] x11-libs/wxGTK-2.8.9.1-r3 [2.8.8.1] USE="X doc gnome gstreamer odbc opengl sdl -debug -pch" 27,315 kB
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="doc glib qt3support ssl -debug -pch" 102,858 kB
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="odbc qt3support sqlite -debug (-firebird) -mysql -pch -postgres" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus glib mng nas qt3support tiff xinerama -debug -nis -pch" INPUT_DEVICES="-wacom" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch" 0 kB
[ebuild     U ] dev-python/PyQt4-4.4.4-r1 [4.3.3] USE="X%* dbus%* doc examples opengl%* qt3support%* svg%* webkit%* -debug" 6,819 kB
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="dbus opengl qt3support (-accessibility%*) (-cups%*) (-debug%) (-doc%*) (-examples%*) (-firebird%) (-gif%*) (-glib%*) (-jpeg%*) (-mng%*) (-mysql%) (-nas%*) (-nis%) (-odbc%*) (-pch%) (-png%*) (-postgres%) (-sqlite%*) (-sqlite3%*) (-ssl%*) (-tiff%*) (-xinerama%*) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB
[ebuild     U ] dev-python/qscintilla-python-2.3.2 [2.1] USE="qt4" 0 kB
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

Total: 26 packages (13 upgrades, 13 new), Size of downloads: 160,591 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

  ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
    >=x11-libs/qt-4.3:4 required by ('installed', '/', 'app-text/poppler-bindings-0.8.7', 'nomerge')
    >=x11-libs/qt-4.3:4 required by ('installed', '/', 'media-video/avidemux-2.4.3', 'nomerge')
    >=x11-libs/qt-4.2.0:4 required by ('installed', '/', 'app-crypt/qca-2.0.0-r2', 'nomerge')
    (and 3 more)

  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'media-video/vlc-0.9.8a', 'nomerge')
    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'sci-astronomy/stellarium-0.9.1-r1', 'nomerge')
    =x11-libs/qt-4.3* required by ('installed', '/', 'media-video/mkvtoolnix-2.4.0', 'nomerge')
    (and 8 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
MaratIK
n00b
n00b


Joined: 02 Apr 2003
Posts: 20
Location: Moscow, Russia

PostPosted: Mon Jan 19, 2009 9:11 am    Post subject: Reply with quote

Hm,
Code:
sudo emerge -C x11-libs/qt:4
cures this problem
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Mon Jan 19, 2009 9:23 am    Post subject: Reply with quote

indeed it does!! nice one
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
hmalissa
n00b
n00b


Joined: 23 Jan 2007
Posts: 20

PostPosted: Mon Jan 19, 2009 9:53 am    Post subject: Reply with quote

MaratIK wrote:
Hm,
Code:
sudo emerge -C x11-libs/qt:4
cures this problem


That didn't really solve the problem.
After running that command I get:

Code:
# emerge --ask --deep --newuse --update world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] app-arch/cpio-2.9-r2 [2.9-r1]
[ebuild     U ] media-libs/libpng-1.2.34 [1.2.33]
[ebuild     U ] dev-db/sqlite-3.6.6.2 [3.5.9]
[ebuild     U ] dev-libs/mpfr-2.3.2 [2.3.1_p1]
[ebuild     U ] dev-python/sip-4.7.9 [4.7.3]
[ebuild     U ] sys-devel/gdb-6.8-r1 [6.7.1-r3] USE="-multitarget%"
[ebuild     U ] sys-apps/groff-1.19.2-r3 [1.19.2-r1]
[ebuild     U ] app-text/hunspell-1.2.8 [1.2.6]
[ebuild     U ] mail-mta/ssmtp-2.62-r4 [2.62-r3]
[ebuild  NS   ] x11-libs/qt-4.3.3 [3.3.8b-r1] USE="accessibility cups dbus doc gif jpeg mng opengl png qt3support ssl tiff zlib -debug -examples -firebird -glib -mysql -nas -nis -odbc -pch -postgres -sqlite -sqlite3 -xinerama" INPUT_DEVICES="-wacom"
[ebuild     U ] x11-libs/qscintilla-2.3.2 [2.1-r1]
[ebuild     U ] dev-python/PyQt-3.17.6 [3.17.4]
[ebuild     U ] dev-python/qscintilla-python-2.3.2 [2.1]
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="doc qt3support ssl -debug -glib -pch"
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres"
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus mng qt3support tiff -debug -glib -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom"
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch"
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch"
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch"
[ebuild  NS   ] x11-libs/qt-4.4.2 [3.3.8b-r1] USE="dbus opengl -qt3support"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

  ('ebuild', '/', 'x11-libs/qt-4.3.3', 'merge') pulled in by
    =x11-libs/qt-4.3*:4 required by ('installed', '/', 'net-im/skype-2.0.0.63', 'nomerge')
    (and 1 more)

  ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
    x11-libs/qt required by world


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


Does anybody know how to fix that?
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Mon Jan 19, 2009 10:42 am    Post subject: Reply with quote

i dont get that here

emerge --ask --deep --newuse --update world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Nothing to merge; would you like to auto-clean packages? [Yes/No]

mind you i did do an update world first, then ran your command
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
MaratIK
n00b
n00b


Joined: 02 Apr 2003
Posts: 20
Location: Moscow, Russia

PostPosted: Mon Jan 19, 2009 11:11 am    Post subject: Reply with quote

hmalissa wrote:
MaratIK wrote:
Hm,
Code:
sudo emerge -C x11-libs/qt:4
cures this problem


That didn't really solve the problem.
After running that command I get:

...
[/code]

Does anybody know how to fix that?


Add this line to the file "/etc/portage/package.mask"
Code:
=x11-libs/qt-4.3*


After that you can find package(s) which depends on Qt-4.3
Back to top
View user's profile Send private message
moosh
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2004
Posts: 148

PostPosted: Mon Jan 19, 2009 2:31 pm    Post subject: Reply with quote

MaratIK, your advice solved my problem. Thanks!
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1430
Location: Germany

PostPosted: Mon Jan 19, 2009 5:15 pm    Post subject: Reply with quote

You better mask older qt-4 versions this way:
Code:
<x11-libs/qt-4.4:4
This covers all qt-4 versions lower that version 4.4 but none of the qt-3 ebuilds.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Aad-Jan
n00b
n00b


Joined: 02 Feb 2006
Posts: 16
Location: Utrecht - The Netherlands

PostPosted: Tue Jan 20, 2009 5:58 pm    Post subject: Reply with quote

MaratIK thx
_________________
“Those who surrender freedom for security will not have, nor do they deserve, either one.”

― Benjamin Franklin
Back to top
View user's profile Send private message
milomak
Apprentice
Apprentice


Joined: 10 Apr 2008
Posts: 268

PostPosted: Tue Jan 20, 2009 7:31 pm    Post subject: Reply with quote

yep that did the trick for me as well. MaratIK thnks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum