Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO]Freetype subpixel font rendering - lcd monitors Pt 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 27, 28, 29  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
IvanMajhen
Guru
Guru


Joined: 10 Jun 2006
Posts: 385
Location: Croatia

PostPosted: Sat Jan 31, 2009 1:44 am    Post subject: Reply with quote

It is trailer. :P

Which other libraries? Freetype, libxft and fontconfig are the same. Cairo is not used in qt.
Back to top
View user's profile Send private message
mwhitlock
Tux's lil' helper
Tux's lil' helper


Joined: 07 Aug 2006
Posts: 75
Location: Weare, NH

PostPosted: Sat Jan 31, 2009 4:39 am    Post subject: Reply with quote

IvanMajhen wrote:
It is trailer. :P

Which other libraries? Freetype, libxft and fontconfig are the same. Cairo is not used in qt.

I believe this should answer your question (and all other related questions) once and for all:

http://labs.trolltech.com/blogs/2008/09/01/subpixel-antialiasing-on-x11/
Back to top
View user's profile Send private message
PinguinoLoco
n00b
n00b


Joined: 04 Feb 2009
Posts: 21

PostPosted: Wed Feb 04, 2009 5:20 pm    Post subject: Reply with quote

Hi. I'm new too gentoo and after following these font threads I'm not 100% satisfied with my fonts (although they have improved greatly). I have quite a few doubts:

1) I have freetype compiled to include the BCI code but I'm not sure on how it works...
Does the -bindist use flag generate code for both autohint and BCI hinting methods?
Does the autohint option in fontconfig select the hinting method (on=autohint, off=BCI)?
Do free fonts include information for the BCI hinter? If they don't, would they render worse than with autohint?
Would it be possible to select the hinting method between autohint and BCI for each font or font directory?
If using BCI hinting, does the selectiong of hinting type (slight, medium, full) have any effect?

2) I'm using devnull overlay with cleartype enabled and enabling the lcd filter does not seem to make any difference (11-lcd-filter-lcddefault.conf). Also, setting it on and changind the filer mode (lcdslight, lcddefault, lcdlegacy) doesn't show a difference. I suspect I may have something wrong and it is not being applied.
Does the filter depend on other settings to be applied?
Is the lcd-filter compatible with the antialias setting in fontconfig or do we have to choose one?

3) KDE 4.2 fonts look great for me. They are sharp and thin. Fonts for GTK and KDE 3.5 apps look good, but they are heavier (someone also mentioned this issue earlier). I know QT4, QT3, Cairo and GTK render differently, but is it possible to set all fonts to look as light as on KDE 4.2?

4) Okular does not use subpixel hinting for me. I've read a comment from another user stating the same issue. I guess it is a okular/poppler issue. Can something be done via font configuration?

Thanks in advance for your support.


Last edited by PinguinoLoco on Thu Feb 05, 2009 11:46 am; edited 2 times in total
Back to top
View user's profile Send private message
natros
n00b
n00b


Joined: 26 Sep 2003
Posts: 70

PostPosted: Wed Feb 04, 2009 11:43 pm    Post subject: Reply with quote

I think I like the cleartype but the cleartype patch for libXft is not as good the the one for the cairo. There's a small difference between gtk aplications and non gtk applications. I'm looking forward to see an improved patch for libXft.
_________________
-=[abit ip35 pro core2quad q6600 (oc 3.0 ghz) 8 gb ram 2x320 raid0 ext4 xfx8800gt 512mb]=-
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Mon Feb 23, 2009 1:31 pm    Post subject: Reply with quote

I am having problems with font renderigns on some websites using some font sizes. For example on http://blogs.msdn.com/tims/archive/2009/01/12/the-bumper-list-of-windows-7-secrets.aspx
http://img14.imageshack.us/img14/7002/35842846.png
If I increase size of webpage all text becomes good-looking: http://img5.imageshack.us/img5/9536/81911550.png
Code:
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-vera.conf *
  [10]  25-unhint-nonlatin.conf
  [11]  30-metric-aliases.conf *
  [12]  30-urw-aliases.conf *
  [13]  40-nonlatin.conf *
  [14]  45-latin.conf *
  [15]  49-sansserif.conf *
  [16]  50-user.conf
  [17]  51-local.conf
  [18]  59-dejavu.conf *
  [19]  60-latin.conf *
  [20]  65-fonts-persian.conf *
  [21]  65-khmer.conf
  [22]  65-nonlatin.conf *
  [23]  69-unifont.conf *
  [24]  70-no-bitmaps.conf *
  [25]  70-yes-bitmaps.conf
  [26]  80-delicious.conf *
  [27]  90-synthetic.conf *

I am using latest packages from devnull overlay.
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Mon Feb 23, 2009 4:41 pm    Post subject: Reply with quote

I am using the lcd-filtering overlay (-ubuntu, +cleartype) and while GTK applications (including Firefox) look fantastic, Qt (4.5.0-rc1, ~AMD64) for some reason using grayscale AA as opposed to subpixel hinting. Furthermore, OpenOffice.org (3.0.1, GTK) also only uses grayscale AA.

Here is my fontconfig stuff:
Code:

iodine freddie # eselect fontconfig list
Available fontconfig .conf files ( * is enabled ):
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-vera.conf *
  [10]  25-unhint-nonlatin.conf
  [11]  30-metric-aliases.conf *
  [12]  30-urw-aliases.conf *
  [13]  40-nonlatin.conf *
  [14]  45-latin.conf *
  [15]  49-sansserif.conf *
  [16]  50-user.conf *
  [17]  51-local.conf *
  [18]  60-latin.conf *
  [19]  65-fonts-persian.conf *
  [20]  65-khmer.conf
  [21]  65-nonlatin.conf *
  [22]  69-unifont.conf *
  [23]  70-no-bitmaps.conf *
  [24]  70-yes-bitmaps.conf
  [25]  80-delicious.conf *
  [26]  90-synthetic.conf *


Qt stuff:
Code:

iodine freddie # emerge -av qt-gui

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-gui-4.5.0_rc1-r1  USE="accessibility cups dbus glib gtkstyle pch raster -custom-cxxflags -debug -mng -nas -nis -qt3support -tiff -xinerama" 0 kB


Font stuff:
Code:

iodine freddie # emerge -av freetype fontconfig cairo libXft

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/freetype-2.3.8  USE="X cleartype -bindist -debug -doc -fontforge -ubuntu -utils" 0 kB [1]
[ebuild   R   ] media-libs/fontconfig-2.6.0-r2  USE="-doc -ubuntu" 0 kB [1]
[ebuild   R   ] x11-libs/libXft-2.1.13  USE="cleartype -debug -ubuntu" 0 kB [1]
[ebuild   R   ] x11-libs/cairo-1.8.6  USE="X cleartype glitz opengl svg xcb -debug -directfb -doc -ubuntu" 0 kB [1]

Total: 4 packages (4 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/lcd-filtering


Can anyone help me. Qt applications really are starting to stand out as quite ugly beasts. (Qt4 apps, I have no Qt3 applications on the system.)

Regards, Freddie.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Mon Feb 23, 2009 4:44 pm    Post subject: Reply with quote

Evilguru
Try to disable
[16] 50-user.conf *
[17] 51-local.conf *
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Mon Feb 23, 2009 5:20 pm    Post subject: Reply with quote

ssmaxss wrote:
Evilguru
Try to disable
[16] 50-user.conf *
[17] 51-local.conf *


No effect.

Code:

freddie@iodine ~ $ eselect fontconfig list
Available fontconfig .conf files ( * is enabled ):
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-vera.conf *
  [10]  25-unhint-nonlatin.conf
  [11]  30-metric-aliases.conf *
  [12]  30-urw-aliases.conf *
  [13]  40-nonlatin.conf *
  [14]  45-latin.conf *
  [15]  49-sansserif.conf *
  [16]  50-user.conf
  [17]  51-local.conf
  [18]  60-latin.conf *
  [19]  65-fonts-persian.conf *
  [20]  65-khmer.conf
  [21]  65-nonlatin.conf *
  [22]  69-unifont.conf *
  [23]  70-no-bitmaps.conf *
  [24]  70-yes-bitmaps.conf
  [25]  80-delicious.conf *
  [26]  90-synthetic.conf *
.

Qt4 applications (and OpenOffice, but that is more of an outcast) do not use subpixel hinting.

Regards, Freddie.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Mon Feb 23, 2009 5:41 pm    Post subject: Reply with quote

That several hourse of my use of qt 4.5 I haven't noticed any problems with fonts. I was using devnull overlay though. Maybe you should try it?
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Mon Feb 23, 2009 10:03 pm    Post subject: https://bugs.gentoo.org/show_bug.cgi?id=260076 Reply with quote

I have improved the freetype[cleartype] ebuild a litte. We only have libXft and freetype in devnull overlay now, which is enough for cleartype+lcdfilter.

We are also working on a set of ebuilds which is gonna support cleartype and ubuntu patches. However there are issues with the ubuntu patches, they don't really work yet. We hope we can fix this soon, until then you have to use cleartype with lcdfilter (which does look great too, the only disadvantage is wrong spacing with tiny fonty like the very last line in the footer of this page, but isn't a problem for me :)

Btw: I get great results with: cleartype: autohint + hinting + hintfull and subpixel rendering turned on in fontconfig.

Also I have opened a bug to get freetype and libXft with cleartype useflag into portage, you can vote for it if you want.


Last edited by ocin on Tue Feb 24, 2009 2:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
bi3l
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 268
Location: France

PostPosted: Mon Feb 23, 2009 10:15 pm    Post subject: Reply with quote

ocin wrote:
I am also working

WE ARE also working...
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Mon Feb 23, 2009 10:55 pm    Post subject: Reply with quote

bi3l wrote:
ocin wrote:
I am also working

WE ARE also working...

Sorry :oops:
Also thank you for the ebuilds with the ubuntu patches :)
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Mon Feb 23, 2009 11:35 pm    Post subject: Reply with quote

bi3l wrote:
ocin wrote:
I am also working

WE ARE also working...

Is that the Royal plural? ;)
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Tue Feb 24, 2009 11:48 am    Post subject: Re: https://bugs.gentoo.org/show_bug.cgi?id=260076 Reply with quote

ocin wrote:

Btw: I get great results with: cleartype: autohint + hinting + hintfull + lcdfilter-lcddefault and subpixel rendering turned on in fontconfig.

Which package provides hintfull.conf, lcdfilter.conf? fontconfig from portage doesn't have them, devnull overlay lacks fontconfig package.

BTW: media-libs/freetype's manifest in devnull has hashes for removed patches.
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Tue Feb 24, 2009 1:03 pm    Post subject: Reply with quote

I have switched to the devnull overlay and (re-)emerge fontconfig libXft and cairo. (Freetype would not emerge due to a dodgy manifest file.)

In short: no change. GTK+ applications still look great, Qt applications are still not using subpixel rendering.

Code:

freddie@iodine ~/Music/Eagles/The Best Of Eagles $ eselect fontconfig list
Available fontconfig .conf files ( * is enabled ):
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-vera.conf *
  [10]  25-unhint-nonlatin.conf
  [11]  30-metric-aliases.conf *
  [12]  30-urw-aliases.conf *
  [13]  40-nonlatin.conf *
  [14]  45-latin.conf *
  [15]  49-sansserif.conf *
  [16]  50-user.conf *
  [17]  51-local.conf *
  [18]  60-latin.conf *
  [19]  65-fonts-persian.conf *
  [20]  65-khmer.conf
  [21]  65-nonlatin.conf *
  [22]  69-unifont.conf *
  [23]  70-no-bitmaps.conf *
  [24]  70-yes-bitmaps.conf
  [25]  80-delicious.conf *
  [26]  90-synthetic.conf *


Regards, Freddie.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Tue Feb 24, 2009 1:19 pm    Post subject: Reply with quote

To emerge freetype you can go to /usr/local/layman/devnull/media-libs/freetype and do
Code:
ebuild freetype-...-.ebuild digest
to recreate broken manifest.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Tue Feb 24, 2009 1:22 pm    Post subject: Reply with quote

Are you using KDE? What are your settings for fonts in systemsettings->Appearence?
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Tue Feb 24, 2009 1:35 pm    Post subject: Reply with quote

ssmaxss wrote:
Are you using KDE? What are your settings for fonts in systemsettings->Appearence?

I am using GNOME. (Portage ~AMD64.)

Regards, Freddie.
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Tue Feb 24, 2009 2:00 pm    Post subject: Reply with quote

Digestes are fixed.
You will miss most 10-* (aa+hinting) configs, I'm looking into that.


Last edited by ocin on Tue Feb 24, 2009 2:26 pm; edited 2 times in total
Back to top
View user's profile Send private message
paladin-zero
Guru
Guru


Joined: 19 May 2004
Posts: 322

PostPosted: Tue Feb 24, 2009 2:02 pm    Post subject: Reply with quote

Evilguru wrote:

Qt4 applications (and OpenOffice, but that is more of an outcast) do not use subpixel hinting.


Try running qtconfig. Select the "Fonts" tab, change "Family" from the generic "Sans Serif" (or whatever you have listed there) to something like DejaVu Sans or Bitstream Vera Sans, and make sure you have "Style" set to "Normal".
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Tue Feb 24, 2009 2:53 pm    Post subject: Reply with quote

Changes:
- re-added fontconfig with ubuntu-05_add_hinting_and_antialiasing_confs.patch
- removed IUSE defaults (just enable the cleartype useflag globally)
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Tue Feb 24, 2009 3:00 pm    Post subject: Reply with quote

Fontconfig won't install
Code:
emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/freetype-2.2.1[-ubuntu]".

Because there is no ubuntu flag at all in freetype from devnull.
Couldn't it be tested somehow? I heard about tool called repoman. Could it detect such errors?
BTW: there is no USE flag called ubuntu in fontconfig from devnull. So expressions like
Code:
RDEPEND="ubuntu? ( >=media-libs/freetype-2.2.1[ubuntu,-cleartype] )
    !ubuntu? ( >=media-libs/freetype-2.2.1[-ubuntu] )
seems wrong.
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Tue Feb 24, 2009 3:13 pm    Post subject: Reply with quote

duuuuuuh forgot to change that, fixed.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Tue Feb 24, 2009 3:15 pm    Post subject: Reply with quote

Thanks!
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1293
Location: Netherlands

PostPosted: Wed Feb 25, 2009 1:09 pm    Post subject: Reply with quote

Code:
>>> Verifying ebuild manifests

!!! A file listed in the Manifest could not be found: /usr/portage/local/layman/devnull/media-libs/freetype/files/331-hmtx-no-shorts.diff

;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 27, 28, 29  Next
Page 4 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum