Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Access Violation durante emerge di vlc
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Dec 30, 2008 10:35 am    Post subject: [RISOLTO] Access Violation durante emerge di vlc Reply with quote

Facendo l'emerge di vlc in fase dopo il make mi dà questo errore (allego l'ultima parte):

Code:

make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.8a/work/vlc-0.9.8a'
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-0.9.8a/work/vlc-0.9.8a'
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-26070.log"

open_wr:   /var/cache/samba/gencache.tdb
open_wr:   /var/cache/samba/gencache.tdb
--------------------------------------------------------------------------------

>>> Failed to emerge media-video/vlc-0.9.8a, Log file:

>>>  '/var/tmp/portage/media-video/vlc-0.9.8a/temp/build.log'

 * GNU info directory index is up-to-date.


qualche suggerimento per me ?
non mi è mai capitato un errore di questo tipo, non mi sembra di vedere suggerimenti di nessun tipo a video...


Last edited by lsegalla on Mon Jan 05, 2009 9:14 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Dec 30, 2008 12:27 pm    Post subject: Reply with quote

normalmente sono bachi dell'ebuild o del binario, che determinano un comportamento anomalo nell'ultima fase di installazione del programma (la copiatura dei documenti da /tmp/portage al sistema vero e proprio). potenzialmente, potrebbe essere un problema molto pericoloso. addirittura, potrebbe trattarsi di un tentativo deliberato di compromettere il tuo sistema.

nel tuo caso, c'è un tentativo di sovrascrivere la cache di samba. potrebbe essere un tentativo di riempirla di materiale pornografico.
verificare la presenza di problemi similari su bugzilla è la prima cosa da fare. se manca aggiungi la tua segnalazione.

successivamente, supposto che si tratti di un fatto non doloso (in fondo, a te la cache potrebbe non importare più di tanto), puoi fare un backup della cache e provare a rimuoverla, oppure puoi salvare samba con quickpkg e disinstallarlo provvisoriamente, per vedere se il problema si ripresenta.

un'altra possibilità di workaround dovrebbe essere quella di specificare l'opzione -sandbox nella variabile FEATURES di /etc/make.conf.
controlla su man portage o su man emerge per sicurezza.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Dec 30, 2008 4:07 pm    Post subject: Reply with quote

vlc aveva qualche problema di sicurezza, in più non capisco cosa debba andare a fare nella cache di samba.
Verifica se non è già stato aperto ed apri di corsa un bug, potrebbe anche essere un mirror compromesso.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Dec 30, 2008 4:41 pm    Post subject: Reply with quote

djinnZ wrote:
vlc aveva qualche problema di sicurezza

dall'indice del forum
purtroppo, però, la versione che lsegalla sta installando dovrebbe superare il bug.
io ho aggiornato senza problemi.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Dec 30, 2008 6:56 pm    Post subject: Reply with quote

oggi stavo per aprire il bug, avevo compilato metà campi poi nello scrupolo di controllare che non ci fosse già qualcosa di aperto ho perso un sacco di tempo... e lavora di qui e lavora di là anche oggi la giornata lavorativa è finita e adesso mi sa che non vedro' il pc del lavoro per qualche giorno...

appena torno faccio un aggiornamento e anche un emerge per vedere se la cosa si sistema per capire se è un ebuild sputtanato ma al momento non ho piu' i dati sottomano per riportare il tutto nel dettaglio o fare prove... oppure provo ad aggiornare a quella versione che hai linkato prima

(che dite? lo apro ora con quel che ho?)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Dec 30, 2008 7:59 pm    Post subject: Reply with quote

lsegalla wrote:

(che dite? lo apro ora con quel che ho?)

avresti dovuto farlo prima.
quello che ti serve è solamente un emerge --info e il testo dell'errore.
dopodichè è compito loro mostrarsi classificare il problema o, eventualmente, richiedere nuovi dati.

senza le informazioni sul sistema, temo che la tua segnalazione risulterebbe inusabile.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Dec 30, 2008 8:04 pm    Post subject: Reply with quote

cloc3 wrote:
lsegalla wrote:

(che dite? lo apro ora con quel che ho?)

avresti dovuto farlo prima.
quello che ti serve è solamente un emerge --info e il testo dell'errore.
dopodichè è compito loro mostrarsi classificare il problema o, eventualmente, richiedere nuovi dati.

senza le informazioni sul sistema, temo che la tua segnalazione risulterebbe inusabile.

...e allora son costretto a far tutto appena posso, purtroppo di giorno se lavora :-)
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Jan 05, 2009 9:14 am    Post subject: Reply with quote

Puo' essere che sia stato il pacchetto scazzato a sto punto?
Oggi ho fatto un
Code:

eix-sync
emerge -uDN world


VLC stavolta è andato su e non ha avuto problemi, la versione a memoria mi sembra la stessa della volta scorsa in cui ho aperto sto thread.
Segno come risolto intanto...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum