Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]emerge kde-meta packages masked
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sat Sep 24, 2011 11:06 pm    Post subject: [solved]emerge kde-meta packages masked Reply with quote

I've only recently set up my gentoo installation and now I'm trying to get kde to install. We have worked in a previous thread to get X working and since we are at a loss for how to get it to work with fglrx I've decided to just get it working with vesa.

When I do emerge -av kde-meta I get the error:

Code:
* IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies  ... done!

!!! All ebuilds that could satisfy "~x11-libs/qt-gui-4.7.2[accessibility=,aqua=,debug=,qt3support]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.7.2::gentoo (masked by: )

(dependency required by "x11-libs/qt-qt3support-4.7.2" [ebuild])
(dependency required by "kde-base/kscd-4.6.5" [ebuild])
(dependency required by "kde-base/kdemultimedia-meta-4.6.5" [ebuild])
(dependency required by "kde-base/kde-meta-4.6.5" [ebuild])
(dependency required by "kde-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


This is my make.conf
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"

#GENTOO_MIRRORS="ftp://gentoo.chem.wisc.edu/gentoo/"

RSYNC="ftp://gentoo.chem.wisc.edu/gentoo/"
USE="-gtk -gnome qt4 kde dvd alsa cdr udev"
#USE="-gnome -kde -minimal -qt4 dbus jpeg lock session startup-notification thunar udev X"
VIDEO_CARDS="fglrx"
INPUT_DEVICES="evdev synaptics"

GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/"

SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"

#EMERGE_DEFAULT_OPT="--autounmask=y"


In there I have commented out the autounmask (tried with 'y' and 'n') and I tried to install xfce (the other commented out use flags). When I emerge xfce or kde I get errors about unmasking.

Any help appreciated.


Last edited by donttrip on Mon Sep 26, 2011 4:29 am; edited 1 time in total
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Sep 25, 2011 5:35 am    Post subject: Reply with quote

That's a strange error, normally portage will give a bit more information as to why a package is masked. Try running `emerge --sync` and then post the output of `emerge -pv1 qt-gui`.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sun Sep 25, 2011 5:58 am    Post subject: Reply with quote

mark_alec wrote:
That's a strange error, normally portage will give a bit more information as to why a package is masked. Try running `emerge --sync` and then post the output of `emerge -pv1 qt-gui`.


Code:

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild   R    ] x11-libs/qt-gui-4.7.2  USE="accessibility cups exceptions glib (-aqua) -dbus -debug -egl -gtkstyle -mng -nas -nis -pch -private-headers -qt3support -raster -tiff -trace -xinerama" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Sep 25, 2011 6:03 am    Post subject: Reply with quote

If you try installing kde-meta? (It doesn't appear that anything is wrong with qt-gui).
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sun Sep 25, 2011 6:09 am    Post subject: Reply with quote

mark_alec wrote:
If you try installing kde-meta? (It doesn't appear that anything is wrong with qt-gui).


Same error about x11-libs/qt-gui-4.7.2 as in top post.

Also since my old thread about startx was replied to and now we have two threads for the same thing now.

https://forums.gentoo.org/viewtopic-t-895306-postdays-0-postorder-asc-start-25.html
Back to top
View user's profile Send private message
whiteghost
Guru
Guru


Joined: 26 Jul 2009
Posts: 373
Location: north dakota

PostPosted: Sun Sep 25, 2011 6:15 am    Post subject: Reply with quote

this helped me when installing gentoo

adding this line to make.conf

Code:
ACCEPT_KEYWORDS="~x86"


i found a whole system with that was better than adding it to individual packages.

i have the kde overlay installed and
Code:
emerge -pv qt-gui
[ebuild   R    ] x11-libs/qt-gui-4.7.4  USE="accessibility dbus exceptions glib mng qt3support tiff (-aqua) -cups -debug -egl -gtkstyle -nas -nis -pch -private-headers -raster -trace -xinerama"

_________________
www.informationclearinghouse.info
May you re-discover what the poor in 18th century France discovered, that rich people's heads can be mechanically separated from their shoulders if they refuse to listen to reason.
Back to top
View user's profile Send private message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sun Sep 25, 2011 6:39 am    Post subject: Reply with quote

I added:
Code:

ACCEPT_KEYWORDS ="~x86"


then did emerge kde-meta

It told me to use qt3support in USE flag

Then I added qt3support flag

Then I did emerge qt-gui

That's going right now.
Back to top
View user's profile Send private message
whiteghost
Guru
Guru


Joined: 26 Jul 2009
Posts: 373
Location: north dakota

PostPosted: Sun Sep 25, 2011 6:44 am    Post subject: Reply with quote

a handy tool is euse.

man euse

to add a use flag

euse -E <useflag>
_________________
www.informationclearinghouse.info
May you re-discover what the poor in 18th century France discovered, that rich people's heads can be mechanically separated from their shoulders if they refuse to listen to reason.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Sep 25, 2011 6:59 am    Post subject: Reply with quote

whiteghost wrote:
this helped me when installing gentoo

adding this line to make.conf

Code:
ACCEPT_KEYWORDS="~x86"
You should not use ~arch (unstable) unless you are confident with what you are doing.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sun Sep 25, 2011 7:08 am    Post subject: Reply with quote

whiteghost wrote:
a handy tool is euse.

man euse

to add a use flag

euse -E <useflag>


Thanks I made a note of it

emerge qt-gui was sucessful but emerge -av kde-meta didn't work

I was unable to #emerge -av kde-meta > kde-meta.txt

All that was written to that file was:
Code:

These are the packages ... , in order:

caculating dependences ..... done!


The output from emerge -av kde-meta was long and I was unable to type it all out

some of it was

Code:

NOTE: This --autounmask behavior can be disabled by setting EMERGE_DEFAULT_OPTS="--autounmask=n" in make.conf

USE --autounmask-write to write changes to config files (honoring CONFIG_PROTECT)


I did try again with the folloing in my make.conf

Code:

EMERGGE_DEFAULT_OPTS="--autounmask=n"



emerge -av kde-meta
Code:

These are the packages that would be merged, in order:

Calculating dependencies  ... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/qt-gui-4.7.0:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-gui-4.7.4::gentoo (Change USE: +dbus)
(dependency required by "kde-base/libkcompactdisc-4.7.1" [ebuild])
(dependency required by "kde-base/kdemultimedia-meta-4.7.1" [ebuild])
(dependency required by "kde-base/kde-meta-4.7.1" [ebuild])
(dependency required by "kde-meta" [argument])


Still adding more use flags as suggested so far: dbus, ogg, vorbis, declarative.. so on will report back
Back to top
View user's profile Send private message
donttrip
n00b
n00b


Joined: 19 Sep 2011
Posts: 22

PostPosted: Sun Sep 25, 2011 7:18 am    Post subject: Reply with quote

Well thanks

Looks like it is installing now something like 439 things to go

Once qt3support flag was entered then it was just a matter of feeding it all the other use flags it wanted, probably 8 or so after that and then emerge -av kde-meta started.

This will just run while I sleep now.

Now do I just startx when it's done or is there more work to do?
Back to top
View user's profile Send private message
whiteghost
Guru
Guru


Joined: 26 Jul 2009
Posts: 373
Location: north dakota

PostPosted: Sun Sep 25, 2011 7:28 am    Post subject: Reply with quote

Quote:
Still adding more use flags as suggested so far: dbus, ogg, vorbis, declarative.. so on will report back


you must not have desktop profile selected

use

eselect profile list

eselect profile set
_________________
www.informationclearinghouse.info
May you re-discover what the poor in 18th century France discovered, that rich people's heads can be mechanically separated from their shoulders if they refuse to listen to reason.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum