Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[glade-sharp et gtk-glade] dépendance cyclique [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Fri Dec 26, 2008 3:03 pm    Post subject: [glade-sharp et gtk-glade] dépendance cyclique [Résolu] Reply with quote

Bonjour à tous,

Je rencontre le petit problème concernant gtk-glade et son copain glade-sharp. J'ai cru comprendre que dans la nouvelle version de gtk-sharp, glade serait inclus, d'ou le use glade dessus. J'ai donc désinstallé gtk-glade, et comme conseillé sur les forums anglais, fais un emerge -1 gtk-sharp.

Code:
Calculating dependencies... done!
[ebuild  N    ] dev-dotnet/gtk-sharp-2.12.7  USE="glade -doc" 0 kB



A partir de là, que je le recompile ou non, il m'est impossible de mettre à jour mon world :

Code:
[blocks B     ] dev-dotnet/glade-sharp ("dev-dotnet/glade-sharp" is blocking dev-dotnet/gtk-sharp-2.12.7)



J'ai mis dev-dotnet/gtk-sharp ~x86 dans packages.keyword mais celà n'y fait rien. J'ai essayé pas mal de choses et là je sèche, malgrès les quelques réponses apportées dans les posts du forum anglais.

Quelqu'un aurait il une suggestion ? Merci :)


Last edited by bouyafa on Mon Dec 29, 2008 10:37 am; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 500

PostPosted: Fri Dec 26, 2008 3:13 pm    Post subject: Reply with quote

Visiblement, les fonctionnalités de glade sharp sont incluses dans gtk-sharp si tu le compile avec le use glade.

Ajoute la ligne:

Code:
dev-dotnet/gtk-shark glade
a
Code:
/etc/portage/package.use
(si besoin, semble être mis par ton profile) puis
Code:
emerge -C glade-sharp && emerge -1 gtk-sharp
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Fri Dec 26, 2008 6:47 pm    Post subject: Reply with quote

Bien après avoir fait ça comme je le disais, l'update de mon world se trouve toujours bloquée.

Quote:
[blocks B ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-assistant-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)
[blocks B ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.5)


Bizarrement le soucis change ... :/ J'ai donc emerge -C x11-libs/qt x11-libs/qt-core, rien n'y fait non plus. Ca tourne toujours en rond cette histoire :/
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Sat Dec 27, 2008 2:10 pm    Post subject: Reply with quote

Je ne m'en sors pas vraiment, j'ai maintenant un soucis avec qt

Quote:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

('installed', '/', 'x11-libs/qt-4.4.2', 'nomerge') pulled in by
=x11-libs/qt-4* required by ('installed', '/', 'net-wireless/wpa_supplicant-0.5.7', 'nomerge')
x11-libs/qt required by world

('ebuild', '/', 'x11-libs/qt-4.3.5', 'merge') pulled in by
=x11-libs/qt-4.3* required by ('installed', '/', 'dev-python/PyQt4-4.3.3', 'nomerge')
(and 2 more)



D'habitude qt a toujours bien voulu s'installer en multi slot pourquoi là ça lui pose problème ?
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Dec 28, 2008 3:47 am    Post subject: Reply with quote

Tu as le même problème que lui : https://forums.gentoo.org/viewtopic-t-721970-highlight-.html

Tu dois faire ceci :

Tu dois masquer qt-4.3.* (/etc/portage/package.mask) et assure toi d'avoir PyQt4-4.4*, il se peut que tu dois obligé de l'ajouter dans /etc/portage/package.keywords

Tu dois avoir PyQt4-4.4.x pour que ça fonctionne avec qt-4.4.x.
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Mon Dec 29, 2008 10:37 am    Post subject: Reply with quote

Ah yes j'avais démaské PyQt ... pas PyQt4 @#@¹] ! Voilà comme tu me l'indiques, ça marche impecable là, j'ai lancé mon world. Merci beaucoup !!
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Dec 29, 2008 12:10 pm    Post subject: Reply with quote

Pas de problème, bonne compilation :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum