Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200812-22 ] Ampache: Insecure temporary file usage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Tue Dec 23, 2008 11:26 pm    Post subject: [ GLSA 200812-22 ] Ampache: Insecure temporary file usage Reply with quote

Gentoo Linux Security Advisory

Title: Ampache: Insecure temporary file usage (GLSA 200812-22)
Severity: normal
Exploitable: local
Date: December 23, 2008
Bug(s): #237483
ID: 200812-22

Synopsis

An insecure temporary file usage has been reported in Ampache, allowing for symlink attacks.

Background

Ampache is a PHP based tool for managing, updating and playing audio files via a web interface.

Affected Packages

Package: www-apps/ampache
Vulnerable: < 3.4.3
Unaffected: >= 3.4.3
Architectures: All supported architectures


Description

Dmitry E. Oboukhov reported an insecure temporary file usage within the gather-messages.sh script.

Impact

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Ampache users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/ampache-3.4.3"


References

CVE-2008-3929
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum