Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sistema risponde con latenze esagerate
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Sun Apr 19, 2009 2:00 pm    Post subject: Reply with quote

@MajinJoko è uno di quei fattori che viene vagliato dai dev del kernel, purtroppo le cause precise del bug non sono ancora state isolate!
Probabile trattasi di race condition o insieme di fattori che portano al bug, pensa che solo da poco hanno adottato un test per misurare la latenza del sistema in relazione ai processi i/o.
Con un vecchio IDE il problema non lo avverto.......

Ciao
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Apr 19, 2009 9:34 pm    Post subject: Reply with quote

mack1 wrote:
Con un vecchio IDE il problema non lo avverto.......


Infatti io con il mio IDE non lo avverto. Ma con lo stesso IDE, passando ai driver SATA, ci sono caduto dentro in pieno.

Grazie per le risposte
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue May 05, 2009 10:25 am    Post subject: Reply with quote

Il bug 12309 è stato chiuso con "RESOLVED INSUFFICIENT_DATA", tradotto "se hai problemi di latenza apri un nuovo bug portando prove che possano aiutare a capire".
Sono state proposte varie cause, ma allo stato attuale, secondo me la situazione è ancora poco chiara, visto che soluzioni definitive non sono state trovate :evil: .

<Finite le cattive notizie>

<Lo stato dell'arte>

Sono state proposte diverse patch che vanno a modificare diversi sottosistemi del kernel a dimostrazione di quanto sia nebuloso/rognoso il problema :? .
Qui notizie sulla nuova versione del kernel 2.6.30:

http://www.h-online.com/open/Kernel-Log-What-s-coming-in-2-6-30-File-systems-New-and-revamped-file-systems--/news/113157

Sul forum internazionale alcuni utenti che hanno provato la 2.6.30-rc4 confermano che, sebbene il "rospo" non sia scomparso :twisted: , la situazione sia migliorata considerevolmente :D 8) :D 8) (non avendola testata non so darvi notizie di prima mano, ma tutti concordano sul miglioramento).

Ciao
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Tue May 05, 2009 4:18 pm    Post subject: Reply with quote

mack1 wrote:
Sono state proposte varie cause, ma allo stato attuale, secondo me la situazione è ancora poco chiara, visto che soluzioni definitive non sono state trovate :evil:


sono tue interpretazioni che non corrispondono alla realtà.
il problema è stato individuato perfettamente (grazie a Linus) ma la sua soluzione non è di facile applicazione.

mack1 wrote:
Sul forum internazionale alcuni utenti che hanno provato la 2.6.30-rc4 confermano che, sebbene il "rospo" non sia scomparso :twisted: , la situazione sia migliorata considerevolmente :D 8) :D 8) (non avendola testata non so darvi notizie di prima mano, ma tutti concordano sul miglioramento).


sono tutti test inutili, Linus ha già spiegato più che chiaramente che il .30 non è la soluzione al problema ma è un primo tentativo di risolvere i problemi di fsync/scheduler/fs usando dei workaround (fonte LWN); il problema c'è e rimarrà fino a quando fsync e scheduler non verranno riscritti per supportare in modo decoroso le Write Cache degli HD (alleluja! i linuxari se ne sono accorti con 10 anni di ritardo rispetto ai *BSD) unitamente con le Write Barrier (sia soft che hard), fino ad allora ci dobbiamo tenere i workaround.

p.s.: è interessante notare come questo bug del kernel abbiamo fatto "folleggiare" la mente delle persone passando dai complotti MS per giungere fino ai mille e uno segreti militari di RedHat, ci mancavano solo i templari e il Codice da Vinci ed avremmo fatto l'en plein; peccato, sarà per la prossima volta.
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue May 05, 2009 8:06 pm    Post subject: Reply with quote

Hai ragione ho appena letto su LWN, io seguivo la cosa su Kernel Bug Tracker e c'erano solo tracce dello spiegone di LWM, per chi fosse interessato:

http://lwn.net/Articles/326471/

Ho appena finito di provare il vanilla 2.6.30-rc4 e la situazione è migliorata anche se di poco.... meglio di niente.

Ps:I complottisti, a mio avviso, trovano terreno fertile in mancanza di chiare ed immediate risposte, ed essendo un problema di lunga data (fin dal 2.6.18, settembre 2006) e di difficile catalogazione, ha generato le più disparate teorie, forse Linus avrebbe dovuto intervenire prima :wink: .

Ciao
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Thu May 14, 2009 10:21 am    Post subject: Reply with quote

non so se può essere significativo, ma guardate questi benchmark:

http://www.phoronix.com/data/img/results/linux_opensolaris_kernel/6.png

Su 2.6.30 x86 si è avuto un bel miglioramento, mentre su 2.6.30 amd64 il miglioramento è drastico. Di fianco c'è anche il kernel Solaris (nexenta) con cui fare un confronto
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun May 24, 2009 11:34 am    Post subject: Reply with quote

Ciao a tutti.
Vorrei una vostra opinione riguardo a questo problema: dovendo installare Gentoo su un portatile con disco sata, come posso "cercare di evitare" di cadere in questo problema? Io vorrei comunque installare un sistema a 64 bit, ma visto che dovrei poi per forza di cose usare i driver sata del kernel, non vorrei ritrovarmi con un pc inutilizzabile (o quasi, ovvio..).

Grazie!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sun May 24, 2009 12:38 pm    Post subject: Reply with quote

Attualmente da quanto ho letto ci sono dei significativi miglioramenti con il kernel 2.6.30,
installare kernel appena rilasciati spesso comporta problemi con i driver binari, vedi nvidia, ati. Spesso si devono utilizzare i driver opensource per qualche tempo, oppure andare a pescare tra i beta.
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sun May 24, 2009 1:37 pm    Post subject: Reply with quote

Appena ho un momento provo il 2.6.30*.
Attualmente ho i gentoo-sources-2.6.29-r3, ed ho crash molto frequenti, diciamo ogni 24-48 ore di lavoro. Ho imparato a risolvere temporaneamente killano hald.

Farò qualche test, vi farò sapere sicuramente....
_________________
LP
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun May 24, 2009 2:29 pm    Post subject: Reply with quote

mhh.. la mia domanda era forse ancor più terra terra: "installando un sistema a 64 bit e dovendo usare i driver sata, quante possibilità ho di non soffrire di questo problema?"
:?:
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sun May 24, 2009 5:05 pm    Post subject: Reply with quote

al momento attuale, stando a package.gentoo.org, il vanilla 2.6.30 non è nemmeno disponibile per amd64.
_________________
LP
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Mon May 25, 2009 11:57 am    Post subject: Reply with quote

MajinJoko wrote:
mhh.. la mia domanda era forse ancor più terra terra: "installando un sistema a 64 bit e dovendo usare i driver sata, quante possibilità ho di non soffrire di questo problema?"
:?:


nessuna, il problema della latenza dei processi di I/O è indipendente dall'architettura del processore e/o dal tipo di driver PATA/SATA che usate (fanno eccezione i driver per i controller IDE totalmente hardware) e/o dalla distro. (IMHO) Ti tieni il sistema così come è, con le sue latenze esagerate (che si notato solo se inizi a spostare svariati Gb per diverso tempo) e aspetti la stabilizzazione del kernel (1 o 2 mesi massimo, sperando che tutto vada bene).

p.s.: Linus sta riscrivendo tutto lo scheduler I/O del kernel per eliminare alla fonte il problema delle latenze, quindi presumo che la soluzione definitiva al problema arriverà con il .31 o il .32
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Mon May 25, 2009 12:34 pm    Post subject: Reply with quote

Grazie per la risposta più che esauriente. 8)
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Tue May 26, 2009 10:12 am    Post subject: Reply with quote

lucapost wrote:
al momento attuale, stando a package.gentoo.org, il vanilla 2.6.30 non è nemmeno disponibile per amd64.
ci sono le rc
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Tue May 26, 2009 12:10 pm    Post subject: Reply with quote

Non mi sembra ci sia alcuna keyword per amd64: http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.6.30_rc7.ebuild?view=markup.
_________________
LP
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Tue May 26, 2009 4:57 pm    Post subject: Reply with quote

http://packages.gentoo.org/package/vanilla-sources

Qui si ha una visione d'insieme migliore della situazione delle keyword 8)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Tue May 26, 2009 6:37 pm    Post subject: Reply with quote

ecco perchè devo insallare gentoo sul nuovo computer e sono indeciso se rimettere amd64 oppure x86... ho notato che il "supporto" per x86 è maggiore. ebuild aggiornati prima, flash più stabile, etc etc... un sistema amd64 dovrebbe essere più prestante nei calcoli, però sembra a volte essere relegata a "serie B" (qua il kernel .30 non c'è ancora per amd64, neanche marcato come instabile, e non capisco il motivo, visto che l'ebuild è sempre lo stesso)
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Wed May 27, 2009 10:35 am    Post subject: Reply with quote

lordalbert wrote:
(qua il kernel .30 non c'è ancora per amd64, neanche marcato come instabile, e non capisco il motivo, visto che l'ebuild è sempre lo stesso)
tanto devi comunque smascherarlo, farlo con ~amd64 o ** non cambia molto. del resto uno che prova un kernel che non è stabile nemmeno per gli sviluppatori è uno che sa quello che fa. comunque se volete provare il .30 mettete almeno la rc7 che la rc6 (e forse le precedenti) scazza con reiserfs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum