Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome, dvd, automount e UDF
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Dec 06, 2008 9:44 am    Post subject: gnome, dvd, automount e UDF Reply with quote

Ciao a tutti,

da qualche tempo a questa parte ho questo "problema": i dvd scritti in UDF (dal mio registratore di dvd stand-alone) sono auto-montati sul mio sistema (credo da Hal :?: ) ma risultano illeggibili da chiunque non sia root, in quanto si ottiene un errore di permessi insufficienti.
Cercando sul forum, ho visto che il problema è legato al filesystem UDF, e si supera montando il dvd con l'opzione "-fs iso9660".
Così, ho aggiunto all'fstab questa riga:
Code:
/dev/hdc      /mnt/cdrom   iso9660      users,noauto,user   0 0


Ora, i dvd li posso vedere, montandoli a mano da terminale. Tuttavia, la scocciatura è che in nautilus non compare più un'icona per ogni dispositivo "montabile", ma solo per quelli montati.
Quindi, quello che volevo chiedervi è se esiste una soluzione ad uno qualsiasi di questi problemi:
1) forzare Hal a montare il dvd in iso9660 (e, ancor meglio, potergli definire un punto di mount)
(oppure)
2) far ricomparire in nautilus i dispositivi montabili (a tal proposito una precisazione: in computer:/// vedo l'icona "unita dvd+rw", ma non credo sia legata al mio fstab, tanto che provando a montare il dvd da lì ottengo quel fastidioso "impossibile montare la posizione - impossibile montare il file")

Per completezza vi dico anche:
Quote:
gnome-base/gnome
Installed versions: 2.22.3(2.0)(15:19:06 09/09/2008)(cdr cups dvdr esd ldap -accessibility -mono)
sys-apps/hal
Installed versions: 0.5.11-r1(13:31:52 23/06/2008)(X acpi crypt doc kernel_linux -apm -debug -dell -disk-partition -kernel_FreeBSD -laptop -selinux)
gnome-base/gnome-vfs
Installed versions: 2.22.0(2)(18:21:41 25/11/2008)(acl doc fam hal ipv6 samba ssl -avahi -debug -gnutls -kerberos)
gnome-base/gnome-mount
Installed versions: 0.6(18:26:19 13/08/2007)(gnome -debug -kernel_FreeBSD)


Ringrazio fin d'ora chiunque possa darmi qualche buon consiglio.

Buona giornata
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum