Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE]Choisir ses versions de package(non-résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Philippe
n00b
n00b


Joined: 02 Dec 2008
Posts: 7

PostPosted: Fri Dec 05, 2008 4:06 pm    Post subject: [EMERGE]Choisir ses versions de package(non-résolu) Reply with quote

Re-bonjour,
voila mon second problème, je souhaiterai via emerge choisir la version de l'option à installer.
Sur une install php, choisir la version de php, les options à installer avec leur version (genre mysql51 plutot que mysql50)...
J'ai vu que l'on pouvais gérer les options à installer avec la variable USE mais pas leur version.
Aussi, si j'installe certaine chose depuis les sources comme MySQL51, puis-je indiquer à emerge d'utiliser mon install mysql plutot que son choix préalable ? ou dois-je tout installer depuis les sources ?
Merci
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Fri Dec 05, 2008 4:15 pm    Post subject: Reply with quote

Tu peux gérer les versions avec /etc/portage/package.mask et/ou /etc/portage/package.unmask

Exemple :
Dans /etc/portage/package.mask :

Code:
<=sys-apps/file-4.18


Dans cet exemple, toute version inferieur ou egale à 4.18 pour le paquet file est masquée et ne seront donc pas prises en comptes pour portage.
_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
Philippe
n00b
n00b


Joined: 02 Dec 2008
Posts: 7

PostPosted: Fri Dec 05, 2008 4:34 pm    Post subject: Reply with quote

nico_calais wrote:
Tu peux gérer les versions avec /etc/portage/package.mask et/ou /etc/portage/package.unmask

Exemple :
Dans /etc/portage/package.mask :

Code:
<=sys-apps/file-4.18


Dans cet exemple, toute version inferieur ou egale à 4.18 pour le paquet file est masquée et ne seront donc pas prises en comptes pour portage.


Merci pour ta réponse mais ta solution consiste uniquement à retirer un paquet à partir d'une version, en admettant que je veuille faire pointer la construction de emerge vers mon dossier mysql installé y-a-t-il une solution du genre --with-mysql=/usr/local/... à imposer à emerge ?
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Fri Dec 05, 2008 4:48 pm    Post subject: Reply with quote

Salut,

Essaie d'exporter la variable EXTRA_ECONF dans ton environnement avant d'emerger php.
Code provenant de l'eclass de php :
Quote:

# Support user-passed configuration parameters
[[ -z "${EXTRA_ECONF}" ]] && EXTRA_ECONF=""

# Set the correct compiler for cross-compilation
tc-export CC

# We don't use econf, because we need to override all of its settings
./configure --prefix=${destdir} --host=${CHOST} --mandir=${destdir}/man --infodir=${destdir}/info --sysconfdir=/etc --cache-file=./config.cache ${my_conf} ${EXTRA_ECONF} || die "configure failed"
emake || die "make failed"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum