Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Problème de curseur [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Thu Dec 04, 2008 6:45 pm    Post subject: [Xorg] Problème de curseur [resolu] Reply with quote

Bonjour

Suite à une installation de xorg toute fraiche et fonctionnelle, le curseur de la souris est décalé avec son effet.
C'est pas simple à expliqué mais j'ai un décalage entre le curseur souris et l'endroit ou xorg interprete sa position.
Je n'ai pas de problème avec GPM en console donc à priori ce n'est pas matériel.
Je suis sur un portable avec un touchpad synaptics et aucune erreur dans les log xorg.

C'est grave docteur ?

Gaby


Last edited by Gaby on Mon Dec 08, 2008 7:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Dec 04, 2008 7:56 pm    Post subject: Reply with quote

là pour le coup c'est space
Tu veux dire que tu vois sur l'écran le curseur en position x,y mais que le clique lui serait genre de x-50,y+50 ?
C'est "régulier"? je veux dire le décalage: c'est toujours le même en tout point de l'écran?

C'est purement logiciel amha. Peux tu nous refiler la config de ton device dans xorg.conf (meme si je doute que le soucis vienne de là), la sortie d'un eix pour xorg-server, x11-drivers/xf86-input-synaptics, x11-drivers/xf86-input-mouse, x11-drivers/xf86-input-evdev, x11-proto/inputproto ? (et ton make.conf tiens)
(on verra les use flag qui sont appliqués ou non ainsi que les versions des softs)

J'ai un touchpad synaptics sur mon latptop mais il fonctionne très bien si je le fais passer sur le driver générique plutôt que synaptics, t'as essayés? Genre ça:
Code:

Section "InputDevice"

    Identifier   "Souris"
    Driver   "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/psaux"

    Option "ZAxisMapping"   "4 5 6 7"

EndSection

_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Thu Dec 04, 2008 9:10 pm    Post subject: Reply with quote

kwenspc wrote:
là pour le coup c'est space
Tu veux dire que tu vois sur l'écran le curseur en position x,y mais que le clique lui serait genre de x-50,y+50 ?
C'est "régulier"? je veux dire le décalage: c'est toujours le même en tout point de l'écran?


C'est tout à fait ça, le clic est décalé de facilement 3cm en +X et 2cm en -Y (0;0 étant le coin inf gauche) par rapport au curseur. Du coup quand j'arrive en butée en bas a droite, le curseur est lui bien dans l'ecran. Par contre dans le coin opposé le curseur ne sort pas de l'ecran, je ne peux donc pas cliquer sur une barre de titre en grand format.

Extrait de Xorg.conf :
Code:

#Section "InputDevice"
#            Identifier    "Mouse0"
#            Driver        "mouse"
#            Option       "Protocol" "auto"
#            Option       "Device" "/dev/input/mice"
#            Option       "ZaxisMapping" "4 5 6 7"
#EndSection

Section "InputDevice"
            Identifier    "Mouse0"
            Driver        "synaptics"
            Option       "SendCoreEvents" "true"
            Option       "Device" "/dev/input/mice"
            Option       "UpDownScrolling" "1"
            Option       "LeftRightScrolling" "0"
            Option       "TapButton2" "2"
            Option       "TapButton3" "3"
EndSection

La partie commentée est issu de la config automatique de xorg (j'avais oublié l'input synaptics dans make.conf a ce moment là mais j'ai recompiler xorg-server depuis) le problème était strictement identique.

Code:

sh-3.2# eix xorg-server
[I] x11-base/xorg-server
     Available versions:  1.3.0.0-r6 ~1.4.2 ~1.5.2 {3dfx debug dmx dri hal input_devices_acecad input_devices_aiptek input_devices_calcomp input_devices_citron input_devices_digitaledge input_devices_dmc input_devices_dynapro input_devices_elo2300 input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_jamstudio input_devices_joystick input_devices_keyboard input_devices_magellan input_devices_microtouch input_devices_mouse input_devices_mutouch input_devices_palmax input_devices_penmount input_devices_spaceorb input_devices_summa input_devices_synaptics input_devices_tek4957 input_devices_tslib input_devices_ur98 input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl tslib video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_imstt video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nsc video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vermilion video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo video_cards_xgi xorg xprint}
     Installed versions:  1.3.0.0-r6(16:42:33 30.11.2008)(dri input_devices_keyboard input_devices_mouse input_devices_synaptics nptl sdl video_cards_savage xorg -3dfx -debug -dmx -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics -input_devices_evdev -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick -input_devices_magellan -input_devices_microtouch -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_void -input_devices_wacom -ipv6 -kdrive -minimal -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_impact -video_cards_imstt -video_cards_intel -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_vga -video_cards_via -video_cards_vmware -video_cards_voodoo -xprint)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


Code:
sh-3.2# eix x11-drivers/xf86-input-synaptics
* x11-drivers/xf86-input-synaptics
     Available versions:  ~0.15.2-r2 ~0.99.1 {debug hal}
     Homepage:            http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads

sh-3.2# eix x11-drivers/xf86-input-mouse
[I] x11-drivers/xf86-input-mouse
     Available versions:  1.2.2 ~1.2.2-r1 1.2.3 ~1.3.0 {debug}
     Installed versions:  1.2.3(22:01:21 25.11.2008)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org driver for mouse input devices

sh-3.2# eix x11-drivers/xf86-input-evdev
* x11-drivers/xf86-input-evdev
     Available versions:  1.1.5-r1 ~1.1.5-r2 ~1.2.0 ~1.99.2-r2 ~2.0.1 ~2.0.2 ~2.0.4 ~2.0.5 ~2.0.6 ~2.0.7 {debug hal}
     Homepage:            http://xorg.freedesktop.org/
     Description:         Generic Linux input driver

sh-3.2# eix x11-proto/inputproto
[I] x11-proto/inputproto
     Available versions:  1.4.2 1.4.2.1 ~1.4.3 ~1.4.3-r1 ~1.4.4
     Installed versions:  1.4.2.1(23:48:51 21.11.2008)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org Input protocol headers


Code:

ACCEPT_KEYWORDS="x86"
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=athlon-tbird -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j3"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "

USE="-qt3 -qt4 -gnome -gtk -kde -dvd alsa -cdr a52 glitz svg pdf png -arts -perl -ipv6 -cups"

INPUT_DEVICES="keyboard mouse synaptics"
VIDEO_CARDS="savage"

LINGUAS="fr"

PORTDIR_OVERLAY="/usr/local/portage /usr/portage"


J'avais eu le même problème avec les livecd utilisés avant l'installation (toutou linux et sysresccd).

Gaby
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Dec 05, 2008 7:13 am    Post subject: Reply with quote

Gaby wrote:

J'avais eu le même problème avec les livecd utilisés avant l'installation (toutou linux et sysresccd).

:? ça pourrait donc être matériel? C'est vraiment étrange comme problème car si Xorg est capable d'afficher le curseur à un certain endroit, il n'y a aucune raison pour qu'il place l'évènement clique ailleurs. (d'ailleurs le clique ne donne pas de position non?)

Mais j'y pense, ce pourrait-il que ton touchpad est foiré, c-a-d que lorsque du cliques en fait ça appuie aussi légèrement sur le touchpad? bon ça m'étonnerait que ce soit ça aussi parce qu'en fait tu verrais le curseur bouger amha.

Pour le coup, je sèche. :|
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Fri Dec 05, 2008 8:11 am    Post subject: Reply with quote

kwenspc wrote:
ça pourrait donc être matériel? C'est vraiment étrange comme problème car si Xorg est capable d'afficher le curseur à un certain endroit, il n'y a aucune raison pour qu'il place l'évènement clique ailleurs. (d'ailleurs le clique ne donne pas de position non?)


Si c'était matériel, le curseur devrait également être décalé lorsque je suis en mode console avec gpm. Ici ce n'est pas le cas.
Je dois avoir quelque *ubuntu pour tester ce soir on verra ce que ça donne.

Pour ma part, je vois le fonctionnement de xorg différemment, le curseur théorique se trouve sur le clic et xorg affiche l'image du curseur au dessus. Je ne sais pas comment le vérifier mais c'est comme ça que je l'aurais conçu.


kwenspc wrote:
Mais j'y pense, ce pourrait-il que ton touchpad est foiré, c-a-d que lorsque du cliques en fait ça appuie aussi légèrement sur le touchpad? bon ça m'étonnerait que ce soit ça aussi parce qu'en fait tu verrais le curseur bouger amha.


Je n'ai pas de si gros doigt que ça ;) et pour que le curseur se déplace de plusieurs cm je m'en rendrais compte ^^
De plus le curseur n'attend pas le coin en bas à gauche donc ce n'est pas la cause.

Gaby
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Dec 05, 2008 9:07 am    Post subject: Reply with quote

Gaby wrote:

Si c'était matériel, le curseur devrait également être décalé lorsque je suis en mode console avec gpm. Ici ce n'est pas le cas.

Je sais bien, mais le fait que tu ais rencontrés ça sur des livecd... Je sais pas si c'était un bug logiciel il y aurait tout un tas de personne affectée.

[edit]Essais avec une souris normal via l'usb, juste pour voir[/edit]
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Fri Dec 05, 2008 9:43 am    Post subject: Reply with quote

j'ai lu un post avec un problème similaire sur le forum EN, style la semaine dernière, pas contre je n'arrive pas à remettre la main dessus, je ne sais pas si c'est résolu ou pas. mais tu peux tenter la recherche de ce coté là et nous tenir informés! :)
_________________
The End of the Internet!
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Fri Dec 05, 2008 12:11 pm    Post subject: Reply with quote

kwenspc wrote:
[edit]Essais avec une souris normal via l'usb, juste pour voir[/edit]

J'ai reconfiguré mon xorg.conf pour prendre en compte une souris et j'en ai profité pour mettre le touchpad sur le bon dev (mouse1 ald mice). Le problème reste strictement le même ....
On peut donc écarter un problème matériel.

Je boot sur un livecd ubuntu pour voir et je vous dit ce qu'il en est.

@truc : j'ai regardé dans la section Desktop sans sucès, tu te souviens si le gars avait la solution ?

Gaby

EDIT :
Sous le liveCd Ubuntu je n'ai pas le soucis. J'ai regardé le xorg.conf mais celui-ci n'a aucune info interessante, uniquement les Identifier et juste pour l'ecran et la carte graphique. Aucune info sur la souris ou le touchpad.
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Mon Dec 08, 2008 10:18 am    Post subject: Reply with quote

J'ai créé un topic sur ce problème dans le forum anglais section Desktop ici
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Mon Dec 08, 2008 10:44 am    Post subject: Reply with quote

Salut,

Tu devrais essayer d'upgrader x11-base/xorg-server à la version 1.4.2, et passer par evdev/hal.
Back to top
View user's profile Send private message
Enlight
Advocate
Advocate


Joined: 28 Oct 2004
Posts: 3519
Location: Alsace (France)

PostPosted: Mon Dec 08, 2008 10:57 am    Post subject: Reply with quote

J'ai vu que tu parlais d'avoir utilisé plusieures distributions mais juste histoire d'être sur, tu n'utilises pas un thème de curseur spécifique?
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Mon Dec 08, 2008 11:58 am    Post subject: Reply with quote

J'ai le problème avec le xorg.conf par defaut généré par xorg-config, pas de thèmes de curseur donc.

Sur le forum anglais on me sugere également d'utiliser evdev mais je ne vois pas trop en quoi ça pourrais amélioré sachant que j'ai le même problème avec la souris et le touchpad en ayant utilisé les drivers mouse et synaptics. J'en déduis que le problème ne viens pas de la captation du signal. Je testerais tout de même.

Gaby
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Mon Dec 08, 2008 1:01 pm    Post subject: Reply with quote

Gaby wrote:

Sur le forum anglais on me sugere également d'utiliser evdev mais je ne vois pas trop en quoi ça pourrais amélioré sachant que j'ai le même problème avec la souris et le touchpad en ayant utilisé les drivers mouse et synaptics. J'en déduis que le problème ne viens pas de la captation du signal. Je testerais tout de même.

Gaby

Beaucoup de bugs ont été corrigé entre la version 1.3 et 1.4 de xorg. Il y a une entrée du changelog de xorg-server qui date du mois de juin qui dit :
Quote:

The 1.4.x series bump also contains large quantities of other bugfixes and will be a
stable candidate in 30 days.

Bon, la stabilisation n'a pas encore eu lieu :roll:
Et evdev/hal, c'est le futur, autant y passer tout de suite. Essaye, tu verras bien si çà règle le problème ou non.
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Mon Dec 08, 2008 7:29 pm    Post subject: Reply with quote

Résolu :

Je n'ai plus de problème avec :
Code:
Option "SWCursor" "True"

dans la section graphic cards de xorg.conf

Par contre je n'ai pas trouver d'info sur cette option, quelqu'un peut m'en dire plus ?

Gaby
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Mon Dec 08, 2008 7:40 pm    Post subject: Reply with quote

Quote:
Option ``SWCursor'' specifies that the mouse pointer is to be drawn by software, which is much slower.

http://www.x.org/archive/X11R6.8.0/doc/ati5.html
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Tue Dec 09, 2008 5:17 am    Post subject: Reply with quote

je ne comprends pas trop la définition de cette option, le pointeur est d'une façon ou d'une autre dessiné par un soft (Xorg), donc de quel autre software parle-t-il.
Si quelqu'un pouvait éclairer ma lanterne.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 09, 2008 6:57 am    Post subject: Reply with quote

Pas tout a fait :
- dans le cas du curseur hardware, la gestion du curseur est dédiée à la carte graphique => X donne une position, basta, la carte graphique se débrouille avec.
- Dans le cas du curseur en soft, c'est X qui dessine le curseur sur le buffer graphique, avant de l'envoyer à l'affichage => c'est plus lent, et tu verras que par exemple, si tu passes le curseur sur un overlay (XV, une vidéo quoi), il va clignoter !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Gaby
Apprentice
Apprentice


Joined: 03 Aug 2005
Posts: 251

PostPosted: Tue Dec 09, 2008 7:32 am    Post subject: Reply with quote

Donc si je comprend bien, le problème ne vient ni de X ni de mes périphériques de pointage mais du driver de ma carte graphique ?
C'est une S3 savage, c'est pourtant une carte ancienne (trop ?) et le PC date de 2001.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Tue Dec 09, 2008 7:42 am    Post subject: Reply with quote

Merci @guilc pour ces précisions. :D
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum