Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Broadcom wireless
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Mon Dec 01, 2008 11:08 pm    Post subject: Broadcom wireless Reply with quote

Ciao a tutti..rieccomi qua :) sto cercando di installare la mia scheda wireless...mi sono fatto un giro in rete ed ho troavto che i driver per la mia broadcom sono gia nel kernel, infatti riconfigurandolo ora se do iwconfig la vedo, ho solo un paio di problemi a verificarne l'effettivo funzionamento..priam con ubuntu se premevo il tasto di accenzione (la scheda è integrata) si illuminava...ora invece nulla :S quindi mi sa che qualcosa non va...ho provato con ndiswrapper ad installare i driver originali e a fare un modprobe ndswrapper ma nulla...anche al riavvio niente luce blu... :S come devo fare.??? sono due giorni che sto provando ma rieco a capire dove sbaglio...
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Tue Dec 02, 2008 2:43 am    Post subject: Reply with quote

il fatto che non si illumini non vuole necessariamente dire che non vada. puo' voler anche dire che non hai compilato il supporto per i led del pc nel kernel!
si, hai letto bene. esiste il supporto per i led :D
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Tue Dec 02, 2008 3:12 am    Post subject: Reply with quote

sisi ricordo:P ma lo abiliati..infatti quello per togliere il volume funziona:P comunque le ho provate di tutte...guide con ndiswrapper etc ma non c'è verso...eppure con ubuntu non mi dava nessun problema; comunque ho fatto cosi:
emerso ndiswrapper, scaricato driver, ndiswrapper -i fil.inf ed infine modprobe ndiswrapper...giusto??
Comunque sia per provare se la connessione funziona ed è un problema di led...come faccio?:P non ho trovato ancora nessun programma grafico per gestire le connessioni...
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Tue Dec 02, 2008 8:44 am    Post subject: Reply with quote

prima di pasticciare con ndiswrapper, hai installato il firmware?

quanto al programma, puoi usare wicd
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Tue Dec 02, 2008 11:43 am    Post subject: Reply with quote

scusa la mia ignoranza:P ma il firmware non si installa con ndiswrapper??:P comunque sia l'unica cosa che ho "attivato" è la voce wireless broadcom ricompilando il kernel (nnon l'ho messo come modulo l'ho proprio incluso con la Y andrà bene??)
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Tue Dec 02, 2008 2:26 pm    Post subject: Reply with quote

l'unica cosa che ho trovato in rete riguardo l'installaazione del firmware è di usare bcm43xx-fwcutter e di estrarlo in /lib/firmware...ma ora che faccio?? qualcno non mi puo dire quali dovrebebro essere i passaggi? io ho ricompilato il kernel con i moduli bc43 ho riavviato ho fatto modprobe dei moduli ed estratto con bcm43xx-fwutter come primad etto...cosa sbaglio??
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Wed Dec 03, 2008 11:58 am    Post subject: Reply with quote

ho risolto=) forse nel peggiore dei modi possibili ma sicuramente ora va^^ praticamente avevo aggiornato i firmware dal sito e seguito varie guide nulla non c'era verso, alla fine ho messo una live ubuntu ho configurato la wireless ed ho controllato che firmware metteva in /lib/firmware ed ho notato che ne metteva altri oltre che b43 cosi ho copiato quelli in piu e gli ho messi in gentoo /lib/firmware ed ora funziona^^
p.s. non so come mai non ciho pensato prima..:S
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Wed Dec 03, 2008 1:47 pm    Post subject: Reply with quote

Ci puoi dire quali sono quelli in più?

Andrea
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Wed Dec 03, 2008 2:28 pm    Post subject: Reply with quote

ti posto il comando ls ;comunque gli unici che possono incastrarci qualcosa suppongo siano gli iwlwifi...gli altri gli ho comunque lasciati anche se tanti non so neanche cosa siano (anzi se me lo dite mi fate un favore :P) perche mi serviranno probabilmente in futuro...

Code:

aic94xx-seq.fw
atmel_at76c502-wpa.bin
atmel_at76c502.bin
atmel_at76c502_3com-wpa.bin
atmel_at76c502_3com.bin
atmel_at76c502d-wpa.bin
atmel_at76c502d.bin
atmel_at76c502e-wpa.bin
atmel_at76c502e.bin
atmel_at76c503-i3861.bin
atmel_at76c503-i3863.bin
atmel_at76c503-rfmd-0.90.2-140.bin
atmel_at76c503-rfmd-acc.bin
atmel_at76c503-rfmd.bin
atmel_at76c504.bin
atmel_at76c504_2958-wpa.bin
atmel_at76c504a_2958-wpa.bin
atmel_at76c504c-wpa.bin
atmel_at76c505-rfmd.bin
atmel_at76c505-rfmd2958.bin
atmel_at76c505a-rfmd2958.bin
atmel_at76c506-wpa.bin
atmel_at76c506.bin
dvb-fe-or51132-qam.fw
dvb-fe-or51132-vsb.fw
dvb-fe-or51211.fw
dvb-fe-tda10046.fw
dvb-ttpci-01.fw
dvb-usb-avertv-a800-02.fw
dvb-usb-bluebird-01.fw
dvb-usb-dib0700-1.10.fw
dvb-usb-dibusb-5.0.0.11.fw
dvb-usb-dibusb-6.0.0.8.fw
dvb-usb-dtt200u-01.fw
dvb-usb-tvwalkert.fw
dvb-usb-umt-010-02.fw
dvb-usb-vp702x-01.fw
dvb-usb-vp7045-01.fw
dvb-usb-wt220u-02.fw
dvb-usb-wt220u-fc03.fw
dvb-usb-wt220u-zl0353-01.fw
ipw2100-1.3-i.fw
ipw2100-1.3-p.fw
ipw2100-1.3.fw
ipw2200-bss.fw
ipw2200-ibss.fw
ipw2200-sniffer.fw
isl3877
isl3886
isl3887usb_bare
isl3890
isl3890usb
iwlwifi-3945-1.ucode
iwlwifi-3945.ucode
iwlwifi-4965-1.ucode
iwlwifi-4965.ucode
ql2100_fw.bin
ql2200_fw.bin
ql2300_fw.bin
ql2322_fw.bin
ql2400_fw.bin
rt2561.bin
rt2561s.bin
rt2661.bin
rt73.bin
v4l-cx2341x-dec.fw
v4l-cx2341x-enc.fw
v4l-cx2341x-init.mpg
v4l-cx25840.fw
v4l-pvrusb2-24xxx-01.fw
v4l-pvrusb2-29xxx-01.fw
zd1201-ap.fw
zd1201.fw

Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Dec 03, 2008 4:17 pm    Post subject: Reply with quote

dai un'occhiata a questo link: http://linuxwireless.org/en/users/Drivers/b43, e nota che in portage sono presenti i seguenti pacchetti:
Code:
#> eix fwcutter --only-names
net-wireless/b43-fwcutter
net-wireless/bcm43xx-fwcutter

infine, se non combini da solo, intanto posta il risultato di:
Code:
lspci |grep Network

_________________
LP
Back to top
View user's profile Send private message
redo86
n00b
n00b


Joined: 29 Nov 2008
Posts: 43
Location: Pisa

PostPosted: Wed Dec 03, 2008 8:00 pm    Post subject: Reply with quote

grazie mille per l'interessamento..ma ho gia risolto^^ l'ho scritto un post piu su mi sa...:P comunque non ci avevo fatto caso su emerge avevo cercato direttamente bcm43, venendo da ubuntu sapevo gia cosa cercare...
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Thu Dec 04, 2008 9:28 am    Post subject: Reply with quote

redo86 wrote:
grazie mille per l'interessamento..ma ho gia risolto^^ l'ho scritto un post piu su mi sa
.....

si certo, avevo letto, ma quest'ultima è un pò più ordinata come procedura da seguire, alla gentoo-way insomma ;-)
_________________
LP
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Mon Jan 05, 2009 1:30 pm    Post subject: Reply with quote

Io invece avrei bisogno di aiuto.
Ho dato emerge b43-fwcutter e ho seguito le istruzioni:
Code:
wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta_mimo.o
ed ora?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Mon Jan 05, 2009 1:52 pm    Post subject: Reply with quote

bandreabis wrote:
Io invece avrei bisogno di aiuto.
Ho dato emerge b43-fwcutter e ho seguito le istruzioni:
Code:
wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta_mimo.o
ed ora?


spero tu abbia messo come FIRMWARE_INSTALL_DIR = /lib/firmware
poi niente, assicurati che si caricato il modulo b43 del tuo kernel e controlla che rilevi la scheda..

modprobe b43, dmesg ecc ecc per un po' di diagnostica

Che broadcom hai?
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Mon Jan 05, 2009 2:19 pm    Post subject: Reply with quote

Elbryan wrote:
bandreabis wrote:
Io invece avrei bisogno di aiuto.
Ho dato emerge b43-fwcutter e ho seguito le istruzioni:
Code:
wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta_mimo.o
ed ora?


spero tu abbia messo come FIRMWARE_INSTALL_DIR = /lib/firmware
poi niente, assicurati che si caricato il modulo b43 del tuo kernel e controlla che rilevi la scheda..

modprobe b43, dmesg ecc ecc per un po' di diagnostica

Che broadcom hai?

Ho dimenticato di rportare l'impostazione della directory, ma l'ho fatto (anzi c'erano già).
Per il resto iwconfig vede wlan0
ma non so come fare a connettermi alla rete senza fili.
Sono capace solo di connettermi wired con pppoe.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
viralex
Apprentice
Apprentice


Joined: 24 Apr 2008
Posts: 237
Location: Viareggio (Lu,Italy)

PostPosted: Mon Jan 05, 2009 5:22 pm    Post subject: Reply with quote

Io ho una broadcom, ma non uso i driver del kernel, non sono riuscito a farli andare con il kernel 26 e il 27. Con il 28 non so..
più precisamente ho questa 06:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

Prova questi : http://www.broadcom.com/support/802.11/linux_sta.php sono i driver ufficiali, vanno perfettamente! (uso wicd)

nel readme c'è la guida cmq io faccio così per compilarli e installarli.

Estrai i file dall'archivio, e apri un terminale nella cartella e poi :

Code:
make -C /lib/modules/$(uname -r)/build M=$(pwd) clean
make -C /lib/modules/$(uname -r)/build M=$(pwd)
mkdir /lib/modules/$(uname -r)/misc
wl.ko /lib/modules/$(uname -r)/misc
update-modules -f
modprobe wl
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Mon Jan 05, 2009 5:36 pm    Post subject: Reply with quote

Io ho questa:
Code:
lspci |grep Network
06:02.0 Network controller: Broadcom Corporation BCM4311 [AirForce 54g] 802.11a/b/g PCI Express Transceiver (rev 02)

e i b43 con wicd non riesco a connettermi, vede la rete ma non posso connettermi.
E poi vuole sapere i DNS.. che devo mettrci?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Fri Jan 09, 2009 11:35 am    Post subject: Reply with quote

bandreabis wrote:

E poi vuole sapere i DNS.. che devo mettrci?
quelli del provider, o quelli di opendns (208.67.222.222)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum