Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con script che richiedono baselayout-2
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Nov 26, 2008 8:53 pm    Post subject: Problema con script che richiedono baselayout-2 Reply with quote

Salve a tutti.
Da qualche giorno ho ripartizionato i miei dischi e ho deciso di fare un RAID sul quale ripristinare lo stage4 della mia Gentoo precedentemente backuppata.
Dal momento che ora utilizzo RAID 0, 1 e LVM2, ho installato mdadm, lvm2 e device-mapper, ma all'avvio ottengo questi messaggi:
Code:
* The device-mapper init script is written for baselayout-2
* Please do not use it with baselayout-1
* The lvm init script is written for baselayout-2
* Please do not use it with baselayout-1
* The mdraid init script is written for baselayout-2
* Please do not use it with baselayout-1

La cosa non da dei problemi all'atto pratico, infatti funziona tutto bene, solo che avendo impostato xdm nel runlevel di default, vorrei che KDM mi apparisse sempre alla fine della fase di boot, cosa che invece non accade perché ottengo quei messaggi e vengo sempre redirezionato sulla prima console.

Ho provato anche a emergere baselayout-2, ma è ancora marcato come testing in portage e mi ha dato qualche problema.. ovvero alla fine del boot lo script local non parte. Alla fine quindi sono tornato a baselayout-1.
Come posso risolvere?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Nov 26, 2008 11:32 pm    Post subject: Reply with quote

Baselayout 2 è meraviglioso, prova a scrivere qui che problemi hai con local (hai seguito la guida per l'aggiornamento, vero?).
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Thu Nov 27, 2008 7:47 am    Post subject: Reply with quote

Anch'io uso da qualche mese baselayout2+OpenRC senza problemi. Alcuni script vengono modificati/spostati o non più utilizzati(local.start e local.stop diventano local), in gran parte viene fatto tutto in automatico, ma qualche cosa devi farla a mano. Onde non scrivere un sacco di cacate e soprattutto di cose che magari hai già fatto aspetto di saperne di più...
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Nov 27, 2008 1:06 pm    Post subject: Reply with quote

Doh!
In effetti non avevo seguito la guida alla migrazione! :roll: :roll:
Pensavo bastasse un "semplice aggiornamento". Ora ho fatto tutto, ma rimane un problema. Lo script local parte e i messaggi riguardanti baselayout all'avvio ovviamente non compaiono più.
Io all'avvio ho impostato lo splash-theme e fino a che non mettessi baselayout-2 funzionava bene. Ora rimane per tutto il tempo del boot nello stato "Initializing kernel..." e non mi fa vedere la "progress bar" relativa al boot nè tantomeno premendo F2 mi va in modalità verbose.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum