Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage 2.2 hard masked: si, ma guardate il motivo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Mon Nov 24, 2008 1:40 pm    Post subject: portage 2.2 hard masked: si, ma guardate il motivo Reply with quote

sono rimasto un po' stranito quando ho visto che avevano mascherato le versioni 2.2 di portage, ma ho pensato che avessero un valido motivo, tipo un maxibug che comprometteva la stabilita'.
poi vado a leggere il package.mask e trovo:
Code:
# Zac Medico <zmedico@gentoo.org> (24 Nov 2008)
# In order to ensure that portage-2.1.6 gets sufficient testing,
# portage-2.2 will be masked in package.mask until portage-2.1.6 has
# been marked stable. If you would like to continue using portage-2.2
# then you should unmask it (instead of downgrading to portage-2.1.6).


a me pare assurdo usare un sistema (il mask) che normalmente e' dato per risolvere problemi di sicurezza, per "costringere al testing" gli utenti.
oltretutto probabilmente una parte di coloro che usano gentoo, non si porra' nemmeno il problema di andare a leggersi la motivazione, fara' il downgrade e perdera' le belle funzionalita' aggiuntive della 2.2, credendo che si tratti solo di un problema di sicurezza o simili.

se pensate che questa sia, invece, una cosa giusta, illuminatemi in proposito.


Last edited by ckx3009 on Mon Nov 24, 2008 6:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Nov 24, 2008 2:16 pm    Post subject: Reply with quote

in realtà sul planet ( o in bugzilla, non ricordo ) c'è scritto che la 2.1.6 ha comunque molte delle features della 2.2 ed è per questo che hanno bisogno di molto testing prima di rilasciare stabile la 2.1.6.

Tenere il sistema in ~, comunque, comporta questo genere di scocciature: in teoria lo si dovrebbe fare anche per testare i pacchetti, non solo per avere il bleeding edge.

Normalmente io (ma penso anche molti altri ) quando un pacchetto che ho installo viene mascherato indago il motivo e decido, credo che sia abbastanza normale per un utente gentoo che di base dovrebbe essere un pochino più attento dell'ubuntista di turno.
Se pensi che la 2.2 comunque ti va benissimo o non te ne frega una cippa di testare la 2.1.6 (legittimamente eh, intendiamoci) allora basta smascherare e vivere felici, non mi sembra tutta questa gran questione....

EDIT: typo :oops:
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum


Last edited by Onip on Mon Nov 24, 2008 6:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Nov 24, 2008 2:19 pm    Post subject: Reply with quote

hai tagliato un pezzo:
Zac Medico wrote:

2.1.6_rc1 release. The portage-2.1.6 branch is very close to portage-2.2
except that the unstable features, package sets and preserve-libs, have
been removed.

adesso la versione stabile di portage è la 2.1.4.5.
la versione 2.1.6_rc1 contiene il grosso delle novità della 2.2, con l'esclusione delle parti più instabili.

la versione 2.2 è di sviluppo avanzato.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Mon Nov 24, 2008 6:10 pm    Post subject: Reply with quote

cloc3 wrote:
hai tagliato un pezzo

il pezzo non l'ho tagliato...e' solo che nel package.mask non c'e'.

in ogni caso io avrei adottato altri metodi, certo non avrei costretto a smascherare un pacchetto.

Onip,
ti assicuro che non sono molti quelli che vanno a vedersi le motivazioni dei mask.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Nov 24, 2008 6:39 pm    Post subject: Reply with quote

ckx3009 wrote:
Onip,
ti assicuro che non sono molti quelli che vanno a vedersi le motivazioni dei mask.

Chiarisco che sto parlando dell'hard mask e non della "normale" mascheratura con ~. Mi sembra strano che qualcuno si vede un programma che ha installato mascherato a quel modo da un giorno all'altro (o meglio, da un synch all'altro) e non si preoccupa nemmeno un po': i motivi potrebbero essere i più svariati dalla rimozione dal portage tree (e quindi bisogna cercare alternative) a gravi falle di sicurezza (e anche qui un check mi sembra necessario).
Oh, potrebbe anche essere che il dev ha bevuto una birra di troppo, ma in genere non è così. :)
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Mon Nov 24, 2008 9:20 pm    Post subject: Reply with quote

che si parlava dell'hard mask era sottointeso :P

spero che i nostri amati dev non bevano troppe birre quando sono "in servizio" per portage :D
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Tue Nov 25, 2008 10:46 pm    Post subject: Reply with quote

Visto che c'e` questo thread incui si discute di portage-2.2 non ne apro uno nuovo.
Vorrei portare una lamentela (contro chi? bhuu); Possibile che un sacco di ebuild che nascono in questo periodo vengono realizzati sfruttando EAPI 2 nonostante le versioni di portage che supportino tale interfaccia sono ancora masked (soft e hard)?!?!?!
Provo ad aggiornare un pacchetto, ed ha una dipendenza la cui versione ha un ebuild fatto con EAPI2...Cerco di aggiornare il sistema e la libreria dev-libs/poco ha cancellato l'ebuild della versione attuale a favore di una il cui ebuild sfrutta EAPI2 ( conclusione: mi becco un messaggio di errore ogni volta)....Ma come mai tutta questa fretta? Ed ora io cosa dovrei fare? PAssare a portage-2.1.6 (o 2.2) o lamentarmi ancora finche` la nuova versione non diventi stabile?

:cry: :cry: :cry:
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Wed Nov 26, 2008 7:58 am    Post subject: Reply with quote

oRDeX wrote:
Visto che c'e` questo thread incui si discute di portage-2.2 non ne apro uno nuovo.
Vorrei portare una lamentela (contro chi? bhuu); Possibile che un sacco di ebuild che nascono in questo periodo vengono realizzati sfruttando EAPI 2 nonostante le versioni di portage che supportino tale interfaccia sono ancora masked (soft e hard)?!?!?!
Provo ad aggiornare un pacchetto, ed ha una dipendenza la cui versione ha un ebuild fatto con EAPI2...Cerco di aggiornare il sistema e la libreria dev-libs/poco ha cancellato l'ebuild della versione attuale a favore di una il cui ebuild sfrutta EAPI2 ( conclusione: mi becco un messaggio di errore ogni volta)....Ma come mai tutta questa fretta? Ed ora io cosa dovrei fare? PAssare a portage-2.1.6 (o 2.2) o lamentarmi ancora finche` la nuova versione non diventi stabile?

:cry: :cry: :cry:

Effettivamente ho notato anch'io questa cosa, ovviamente non sono tanti gli ebuild EAPI 2, ma, in realtà, non dovrebbero neanche esserci, o meglio potrebbero essere affiancati a quelli "normali"...bah...
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed Nov 26, 2008 10:35 am    Post subject: Reply with quote

oRDeX wrote:
Visto che c'e` questo thread incui si discute di portage-2.2 non ne apro uno nuovo.
Vorrei portare una lamentela (contro chi? bhuu); Possibile che un sacco di ebuild che nascono in questo periodo vengono realizzati sfruttando EAPI 2 nonostante le versioni di portage che supportino tale interfaccia sono ancora masked (soft e hard)?!?!?!
Provo ad aggiornare un pacchetto, ed ha una dipendenza la cui versione ha un ebuild fatto con EAPI2...Cerco di aggiornare il sistema e la libreria dev-libs/poco ha cancellato l'ebuild della versione attuale a favore di una il cui ebuild sfrutta EAPI2 ( conclusione: mi becco un messaggio di errore ogni volta)....Ma come mai tutta questa fretta? Ed ora io cosa dovrei fare? PAssare a portage-2.1.6 (o 2.2) o lamentarmi ancora finche` la nuova versione non diventi stabile?

:cry: :cry: :cry:


Esatto, pure io! Sono stato costretto a passare a portage 2.2 per quel motivo...
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Wed Nov 26, 2008 10:47 am    Post subject: Reply with quote

IMHO è un periodo di transizione, e un processo che se mai parte mai vedrà la luce: se non ci sono ebuild che usano eapi2 nessuno si prenderà mai la briga di aggiornarli: se tanto devo modificarlo, tanto vale modificarlo per quello che verrà. Dato che i tempi non sono molto lunghi, qualche settimana di attesa per un package nuovo può valerne la pena, se in quel lasso ti tempo vengon provate e testate tutte quelle feature che si potranno sfruttare con la messa in stable di portage 216 .
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Wed Nov 26, 2008 1:44 pm    Post subject: Reply with quote

Sono d'accordo con ciò, ma secondo me questa transizione non la stanno attuando nel migliore dei modi...Come se all'improvviso tutti i server diventino IPv6 e chi ha ancora il provider in IPv4 si aggancia ( :lol: :lol: ).
Faccio di nuovo riferimento alla libreria "poco": NON ESISTE PIU` alcun ebuild EAPI (anche quello da cui ho installato la mia versione attuale è stato rimosso), l'unico esistente sfrutta EAPI2. Penso che sarebbe stato il caso di fare degli ebuild con "retrocompatibilità" (forse troppo costoso o impossibile) o quanto meno creare doppie versioni degli ebuild.
Ora voti tutti state dicendo che la nuova versione di portage è ormai abbastanza matura...ma non è possibile che ebuild UFFICIALI e non mascherati sfruttino capacità di un gestore dei pacchetti (cuore di una distro) UFFICIALMENTE MASKED (soft o hard che sia non fa differenza).

:roll:
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 27, 2008 12:18 pm    Post subject: Reply with quote

Come sempre cerco di scagliare qualche lancia a favore dei Gentoo devs: dev-libs/poco mi pare sia instabile, per cui sti problemi di ebuild EAPI2, in teoria, penso che li riscontrino solo utenti con pacchetti o tutto il sistema non completamente stabile!

Per cui, nella zona "instabile", ci stanno ste magagne di transizione, IMHO.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Sat Nov 29, 2008 11:32 am    Post subject: Reply with quote

Scen wrote:
Come sempre cerco di scagliare qualche lancia a favore dei Gentoo devs: dev-libs/poco mi pare sia instabile, per cui sti problemi di ebuild EAPI2, in teoria, penso che li riscontrino solo utenti con pacchetti o tutto il sistema non completamente stabile!


Credo che ordex si stia lamentando perchè vorrebbe evitare di portare mezzo sistema in ~ solo per una "misera" libreria, non ha tutti i torti ma purtroppo gestire n-versioni dello stesso ebuild richiede più tempo e risorse che gestire una versione sola ;-)
_________________
Ciao da me!
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Thu Dec 04, 2008 12:33 am    Post subject: Reply with quote

Comunque il problema della libreria poco si e` manifestato perche` la versione da me installata e` la 1.3.2 (soft masked, ok, ma EAPI), successivamente e` uscita la versione 1.3.3_p1 (soft masked anche questa, ma EAPI2). Tutto ok direte, ma poi scompare dal portage l'ebuild della 1.3.2.
Risultato:
Quote:

# emerge -uDpvN world

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
dev-libs/poco

Sempre.
Perchè non può mettere la 1.3.3 in quanto MASKED per via delle EAPI2, ma non trova nessun ebuild che simboleggi l'attuale installazione :roll: :roll: [/code]
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Dec 04, 2008 10:54 am    Post subject: Reply with quote

Proprio per sistemare "a sberle": copia l'ebuild nell'overlay locale, modificalo alla versione che hai gia` installata, modifica la dicitura in maniera che finga di essere EAPI 1 e spera di non doverlo mai reinstallare :)
Almeno portage non si dovrebbe lamentare, credo.
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Thu Dec 04, 2008 11:04 pm    Post subject: Reply with quote

preferisco che continui a darmi il "warning" :P :P
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2414
Location: イタリアのロディで

PostPosted: Sat Dec 27, 2008 10:41 am    Post subject: Reply with quote

A quando la "stabilizzazione" di portage 2.1.6?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Mon Dec 29, 2008 9:23 am    Post subject: Reply with quote

Oggi... portage-2.1.6.4
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Dec 29, 2008 9:54 am    Post subject: Reply with quote

e l'ultimo update di portage 2.2 ha il digest sballato... che strazio con questi mirror ultimamente :evil:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Mon Dec 29, 2008 8:28 pm    Post subject: Reply with quote

dynamite wrote:
Oggi... portage-2.1.6.4


ma questa versione gestisce le nuove EAPI?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum