Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[reboot] pc ne reboot pas [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Mon Nov 24, 2008 12:49 pm    Post subject: [reboot] pc ne reboot pas [résolu] Reply with quote

'alute

un problème étrange, j'ai fait un petit serveur, tout neuf et tout propre, avec le minimum et un kernel hardened, tout marche bien sauf que le pc ne s'eteint pas completement, il me marque : system is halted, et pareil pour le reboot (restarting systemt)

j'ai pourtant bien l'acpi d'activé, j'ai essayé avec apm, shutdown -hP now etc ... mais rien n'y fait. j'ai essayé sur 2 machines différente (des dell optiplex 360 et 330)

y a t'il un rapport avec le kernel hardened ? quelqu'un a t'il eu ce problème ?
_________________
Pourquoi faire simple quand on peut faire compliqué ?


Last edited by sd44 on Thu Dec 04, 2008 11:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Mon Nov 24, 2008 6:12 pm    Post subject: Reply with quote

Salut,
J'ai eu 2 fois ce problème par le passé :
- une fois il me manquait l'acpi dans le kernel
- une autre fois il n'était pas activé dans le bios
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Mon Nov 24, 2008 7:39 pm    Post subject: Reply with quote

l'acpi est activé partout, j'ai beau cherché je trouve pas le problème !

help 8O
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Tue Nov 25, 2008 9:17 am    Post subject: Reply with quote

Vu sur LKML

Apparement c'est un bug du noyau, car il semblerait qu'il y ait un fix pour cela dans le noyau 2.6.28-rc6
lkml wrote:
Steve Conklin (1):
x86: quirk for reboot stalls on a Dell Optiplex 330
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Tue Nov 25, 2008 11:47 am    Post subject: Reply with quote

merci de l'info.

je doutte que cela provienne du matos etant donnée que je reboot bien avec une gentoo normal ou une knoppix ...

hier j'ai recompilé le kernel sans pax et grsec mais rien n'y fait ...
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Thu Dec 04, 2008 11:26 pm    Post subject: Reply with quote

problème résolu !

Apparement c'est bien un bug du noyau spécifique aux optiplex 330 , 360 et sans doute quelques autres dell.

pour solutionner le probleme il faut ajouter reboot=b dans le grub.conf :

title Gentoo Linux 2.6.25
root (hd0,1)
kernel /boot/kernel-2.6.25-hardened-r10 root=/dev/sda2 reboot=b

un fix est en effet en prepa dans la serie 2.6.28 etc ..
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum