Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Prima installazione Gentoo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Wed Nov 26, 2008 12:22 am    Post subject: Reply with quote

purtroppo non posso montare alcuna partizione....
mi dice di spingere un bottone e avvia il grub....
se premo su gentoo riporta nuovamente l'errore che ho scritto...
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Wed Nov 26, 2008 12:41 am    Post subject: Reply with quote

era sottointeso che devi farlo in chroot dal livecd. ora che non hai il kernel attivo, non puoi avviare senza livecd.

booti da cd di gentoo e quando ha finito:

- mount /dev/PARTIZIONE_ROOT /mnt/gentoo
- mount /dev/PARTIZIONE_BOOT /mnt/gentoo/boot (solo se hai una partizione di boot, altrimenti salta questa riga)
- mount -t proc none /mnt/gentoo/proc
- chroot /mnt/gentoo /bin/bash
- env-update && source /etc/profile

in questo modo hai:
- montato la partizione root in mnt/gentoo
- montato la partizione di boot in /mnt/gentoo/boot
- montato la "directory dei processi" in /mnt/gentoo/proc
- chrootato, quindi spostato la tua root directory dal cd al disco fisso, usando, come riga di comando, bash, invece di sh
- caricato dal disco alcune impostazioni

ora sei pronto a: lanciare il comando che ti ho detto per vedere cosa c'e' nella directory di boot. e per cercare o di correggere il grub.conf o di installare l'immagine del kernel nella partizione di boot in modo corretto.
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Wed Nov 26, 2008 2:36 pm    Post subject: Reply with quote

fatto è uscito:


Quote:

drwxr-xr-x 19 root root 4.0k Nov 25 14:36 ...
-rw--------- 1 root root 989 Nov 25 14:36 .bash_history
drwxr-xr-x 2 root root 4.0k Nov 25 14:28 bin
drwxr-xr-x 2 root root 4.0k Nov 25 12:40 boot
drwxr-xr-x 10 root root 36k Jun 17 19:42 dev
drwxr-xr-x 33 root root 4.0k Nov26 13:01 etc
drwxr-xr-x 2 root root 4.0k Jun 17 19:37 home
lrwxrwxrwx 1 root root 5 Nov 25 12:56 lib -> lib64
drwxr-xr-x 2 root root 4.0k Jun 17 20:49 lib32
drwxr-xr-x 7 root root 4.0k Nov 25 14:28 lib64
drwx------- 2 root root 16k Nov 25 12:38 lost+found
drwxr-xr-x 4 root root 4.0k Jun 17 19:41 mnt
drwxr-xr-x 2 root root 4.0k Jun 17 19:37 opt
-rw-r--r--- 1 root root 30M Nov 25 12:59 portage-2008.0.tar.bz2
-rw-r--r--- 1 root root 552 Nov 25 13:00 portage-2008.0.tar.bz2.DIGESTS
dr-xr-xr-x 70 root root 0 Nov 26 12:58 proc
drwx------- 2 root root 4.0K Jun 17 19:37 root
drwxr-xr-x 2 root root 4.0K Nov 25 14:28 sbim
-rw-r--r---- 1 root root 125M Nov 25 12:52 stage3-amd64-2008.0.tar.bz2
-rw-r--r---- 1 root root 395 Nov 25 12:53 stage3-amd64-2008.0.tar.bz2.DIGESTS
drwxr-xr-x 2 root root 4.0K Jun 17 19:37 sys
drwxrwxrwt 2 root root 4.0K Nov 25 14:35 Tmp
drwxr-xr-x 13 root root 4.0K Nov 25 13:01 usr
drwxr-xr-x 12 root root 4.0K Jun 17 20:51 var


cosa devo fare?
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Wed Nov 26, 2008 8:41 pm    Post subject: Reply with quote

nessun consiglio?
help meeeeeeeeeee :'(
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Nov 27, 2008 12:19 am    Post subject: Reply with quote

spulciando il sito mi sn imbattuto nella guida errori comuni di grub!

ho trovato l'eerore n.15 e fatto come dice sulla guida:
Quote:



cd /boot
ls
cd /usr/src/linux/
# make menuconfig
# make
cp /usr/src/linux/arch/i386/boot/bzImage /boot



a questo punto mi dice: NO SUCH FILE OR DIRECTORY....
sbaglio nel digitare l'ultimo comando o cosa? come dovrei procedere? aiuto
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Thu Nov 27, 2008 7:50 am    Post subject: Reply with quote

Probabilmente la tua immagine del kernel sta in arch/x86/boot/bzImage...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Nov 27, 2008 8:35 am    Post subject: Reply with quote

Ma usare genkernel ed evitare tutte queste complicazioni è troppo poco "eroico"? :twisted:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Thu Nov 27, 2008 10:02 am    Post subject: Reply with quote

djinnZ wrote:
Ma usare genkernel ed evitare tutte queste complicazioni è troppo poco "eroico"? :twisted:


genkernel *è* il male, quanto di peggio mai inventato! :P

Comunque sia: make install e passa la paura (ricordatevi di avere la /boot montata però).

(vi fa lui vmlinuz, system-map e altre robe.. inoltre crea la copia di backup del kernel attuale in vmlinuz-old).

Nulla vi vieta comunque di andare a prendervi a mano la bzImage o di farvi una directory backup contenente un kernel sicuramente funzionante :)
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Nov 27, 2008 10:14 am    Post subject: Reply with quote

certo che ho usato genkernel!
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Nov 27, 2008 11:31 am    Post subject: Reply with quote

con il comando cp /usr/linux/arch/x86/boot/bzImage /boot
copia tutto...
dopo dò i comandi:
exit e rebbot, quando si riavvia continua a darmi l'errore 15.....
cosa sbaglio?
Back to top
View user's profile Send private message
Deus Ex
Guru
Guru


Joined: 16 Nov 2005
Posts: 489
Location: Patavium

PostPosted: Thu Nov 27, 2008 11:45 am    Post subject: Reply with quote

Bob87 wrote:
con il comando cp /usr/linux/arch/x86/boot/bzImage /boot
copia tutto...
dopo dò i comandi:
exit e rebbot, quando si riavvia continua a darmi l'errore 15.....
cosa sbaglio?


Visto che la riga che hai nel grub.conf è questa:

Code:
kernel /boot/kernel-genkernel-amd64-2.6.26-gentoo-r3 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3


allora ti conviene modificarla in

Code:
kernel /boot/bzImage root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3


se no è ovvio che grub si lamenta, visto che cerca un file che non esiste ;)
_________________
Deus Ex
--
L’inflazione che caccia nelle mani dell’individuo, in un gesto solo, miliardi di marchi, lasciandolo più miserabile di prima, dimostra punto per punto che il denaro è un’allucinazione collettiva.
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Nov 27, 2008 11:50 am    Post subject: Reply with quote

quindi dovrei ricompilare la riga del grub.con giusto?
Back to top
View user's profile Send private message
Deus Ex
Guru
Guru


Joined: 16 Nov 2005
Posts: 489
Location: Patavium

PostPosted: Thu Nov 27, 2008 1:17 pm    Post subject: Reply with quote

Devi solo correggerla, sì :)
_________________
Deus Ex
--
L’inflazione che caccia nelle mani dell’individuo, in un gesto solo, miliardi di marchi, lasciandolo più miserabile di prima, dimostra punto per punto che il denaro è un’allucinazione collettiva.
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Fri Nov 28, 2008 4:47 pm    Post subject: Reply with quote

niente da fare...
Back to top
View user's profile Send private message
Deus Ex
Guru
Guru


Joined: 16 Nov 2005
Posts: 489
Location: Patavium

PostPosted: Fri Nov 28, 2008 8:13 pm    Post subject: Reply with quote

potresti riportare l'output di

Code:
cat /boot/grub/grub.conf


e
Code:
ls -la /boot


?
_________________
Deus Ex
--
L’inflazione che caccia nelle mani dell’individuo, in un gesto solo, miliardi di marchi, lasciandolo più miserabile di prima, dimostra punto per punto che il denaro è un’allucinazione collettiva.
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Dec 11, 2008 11:01 am    Post subject: Reply with quote

ho notato una cosa: se tento di scrivere sul grub.conf ad installazione conclusa mi dice ke nn trova nessun file, se digito nuovamente emerge grub-static, mi scarica il grub e appena vado ad editare il grub.conf mi compaiono tutti i settaggi che ho fatto durante l'installazione....
potrebbe essere questo il problema?
come faccio per ovviare?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Dec 11, 2008 7:07 pm    Post subject: Reply with quote

Bob87 wrote:
ho notato una cosa: se tento di scrivere sul grub.conf ad installazione conclusa mi dice ke nn trova nessun file, se digito nuovamente emerge grub-static

mi pare che stai confondendo l'installazione del programma nel sistema con l'installazione del bootloader sull'hard disk.

    a. emerge installa il programma.
    b. dopo, tu configuri il file /boot/grub/menu.lst (che in gentoo è un link a /boot/grub/grub.conf).
    c. alla fine, esegui il programma grub (quello precedentemente installato da emerge) per caricare le nuove impostazioni nella mbr dell'hd.

seguendo le istruzioni dei manuali, ti accorgerai che le cose stanno proprio così.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Bob87
n00b
n00b


Joined: 15 Nov 2008
Posts: 32

PostPosted: Thu Dec 11, 2008 7:39 pm    Post subject: Reply with quote

si, ma siccome dopo all'avvio mi si presenta sempre il solito problema, riprendo il cd e faccio il boot dal cd....
controllo le impostazioni del grub e mi dice che non trova nessun grub, se lo riemergo quando vado ad editare il grub.conf ha le stesse impostazioni che avevo messo durante l'installazione...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum