Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mips-el-gcc-4.1.2: can someone "quickpkg" it for me ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Nov 11, 2008 2:44 pm    Post subject: mips-el-gcc-4.1.2: can someone "quickpkg" it for m Reply with quote

Hi,
this is the machine i have to support

Quote:

Magic: {7f,45,4c,46,01,01,01}
Class: ELF32
Data: 2's complement, little endian
OS/ABI: UNIX - System V
Type: EXEC (Executable file)
Machine: MIPS R3000
Entry point address: 0x803d6040
Flags: 0x50001001, noreorder, o32, mips32
M.I.P.S.m.a.c.h.i.n.e. (IDT-79RC32434-MIPS32)



Quote:

MIPS ISA 32/64-bit CPUs Covered
==========================================================================================
MIPS 1 32-bit R2000, R3000
MIPS 2 32-bit R6000
MIPS 3 64-bit R4000, R4400, R4600, R4700
MIPS 4 64-bit R5000, RM5000, RM7000 R8000, R9000, R10000, R12000, R14000, R16000
MIPS 5 64-bit None As Yet
MIPS32 32-bit AMD Alchemy series, 4kc, 4km, many others...
MIPS64 64-bit Broadcom SiByte SB1, 5kc ... etc...



as the fact it is a r3000 (32bit) it should be supported as MIPS-1

here I have got gcc-4.1.1, but I can't recompile the gcc.4.1.2: it fails and my machine is too slow to try to fix the issue


Could some one provide me a-quickpkg-gcc.4.1.2.btgz packet ?
I mean one that I could emerge using the special flag "already compiled package"


Quote:

quickpkg can generate special tgz version of an installed ebuild
how do i install and uninstall these packages?
1) put it in the $PKGDIR ( /usr/portage/packages/All by default)
2) call emerge with the -K switch.








I am using binutils 2.17, here it is the gcc I'm using
Quote:
Using built-in specs.
Target: mipsel-unknown-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.1.1-r3/work/gcc-4.1.1/configure --prefix=/usr --bindir=/usr/mipsel-unknown-linux-gnu/gcc-bin/4.1.1 --includedir=/usr/lib/gcc/mipsel-unknown-linux-gnu/4.1.1/include --datadir=/usr/share/gcc-data/mipsel-unknown-linux-gnu/4.1.1 --mandir=/usr/share/gcc-data/mipsel-unknown-linux-gnu/4.1.1/man --infodir=/usr/share/gcc-data/mipsel-unknown-linux-gnu/4.1.1/info --with-gxx-include-dir=/usr/lib/gcc/mipsel-unknown-linux-gnu/4.1.1/include/g++-v4 --host=mipsel-unknown-linux-gnu --build=mipsel-unknown-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --enable-libmudflap --disable-libssp --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 4.1.1 (Gentoo 4.1.1-r3 p1.10)
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 460

PostPosted: Tue Nov 11, 2008 2:58 pm    Post subject: Reply with quote

Do you need FPU support? I have 32bit mipsel softfloat versions of 3.4.6, 4.2.4 and 4.3.2 here.

If you want them, I'll stick 'em on a website for you to download
(i also have binutils-2.19 and glibc-2.7-r2 against linux-headers-2.6.27-r2)

Code:
Using built-in specs.
Target: mipsel-softfloat-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.3.2/work/gcc-4.3.2/configure --prefix=/usr --bindir=/usr/mipsel-softfloat-linux-gnu/gcc-bin/4.3.2 --includedir=/usr/lib/gcc/mipsel-softfloat-linux-gnu/4.3.2/include --datadir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.3.2 --mandir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.3.2/man --infodir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.3.2/info --with-gxx-include-dir=/usr/lib/gcc/mipsel-softfloat-linux-gnu/4.3.2/include/g++-v4 --host=mipsel-softfloat-linux-gnu --build=mipsel-softfloat-linux-gnu --disable-altivec --with-float=soft --disable-nls --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-multilib --disable-libmudflap --disable-libssp --enable-cld --disable-libgcj --enable-languages=c,c++,treelang --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.3.2 p1.0'
Thread model: posix
gcc version 4.3.2 (Gentoo 4.3.2 p1.0)
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Nov 11, 2008 3:30 pm    Post subject: Reply with quote

thank you, they are OK =)
where can i download them ?
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 460

PostPosted: Tue Nov 11, 2008 5:20 pm    Post subject: Reply with quote

Get them here: http://mlau.at/files/mips-toolchain/

Be warned, though: last time I transitioned from mipsel-unknown- to mipsel-softfloat-
I had to rebuild most packages! And don't forget to change CHOST to mipsel-softfloat-linux-gnu.

(but hey, I also have a ~700MB tarball of portage-built packages, including KDE-3.5.10
built with this toolchain if you run into troubles).
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Thu Nov 13, 2008 5:52 pm    Post subject: Reply with quote

well working
thank you a lot

=)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum