Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how do i upgrade portage?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
krlitux
n00b
n00b


Joined: 02 Nov 2008
Posts: 2

PostPosted: Tue Nov 11, 2008 5:19 am    Post subject: how do i upgrade portage? Reply with quote

Hi guys!

after typing...

#emerge --sync

Portage recommeds to upgrade it with...

#emerge portage

In make.conf i edited: ACCEPT_KEYWORDS="~X86" for masked packages and it says that the current version is blocking:

Gateway ~ # emerge portage
Calculating dependencies... done!

[ebuild U ] app-admin/eselect-1.0.11-r1 [1.0.7] USE="-vim-syntax%"
[ebuild U ] sys-apps/sandbox-1.2.18.1-r2 [1.2.17]
[ebuild U ] app-misc/pax-utils-0.1.17 [0.1.15]
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5]
[ebuild N ] app-admin/eselect-news-20080320
[ebuild U ] sys-apps/portage-2.2_rc13 [2.1.2.2] USE="-build*"
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild U ] app-shells/bash-3.2_p33 [3.1_p17] USE="-plugins%"
[blocks B ] <sys-apps/portage-2.1.4_rc1 (is blocking app-shells/bash-3.2_p33)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

Also i have used /etc/portage/package.keywords (~sys-apps/portage-2.2_rc13 and some more) but i have the same result (editing again make.conf: ACCEPT_KEYWORDS="").

Have anybody achieved a succesfull upgrade?
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 782
Location: Massachusetts USA

PostPosted: Tue Nov 11, 2008 5:57 am    Post subject: Reply with quote

Try
Code:
emerge --oneshot =app-shells/bash-3.2_p17
and then update portage.
Back to top
View user's profile Send private message
bombcar
Guru
Guru


Joined: 08 Apr 2003
Posts: 446
Location: Lincoln Acres, CA

PostPosted: Tue Nov 11, 2008 7:11 am    Post subject: Reply with quote

Quote:
In make.conf i edited: ACCEPT_KEYWORDS="~X86" for masked packages and it says that the current version is blocking:


Are you sure you want to do that? It's safer to ~x86 only the packages you want bleeding edge.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7817

PostPosted: Tue Nov 11, 2008 9:09 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Portage update blocked by bash?!".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum