Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Startx
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Fri Nov 07, 2008 1:26 pm    Post subject: [RISOLTO]Startx Reply with quote

ciao a tutto il forum, sono nuovo, e sto cercando di installare gentoo seguendo il manuale per la piattaforma amd64, ho seguito passo passo tutto fino al riavvio del sistema. Adesso è il momento di installare la parte grafica e quindi prima di installare X ho configurato make.conf come dice in una guida trovata nel sito. Dopodicché:
Code:
emerge xorg-x11
emerge gnome


ma arrivando al punto di far partire startx non parte poichè non trova dei file...in linea generale h9o sbagliato/mancato qualcosa? ora ho cancellato l'installazione..la farò di nuovo, ma arrivato a quel punto avrò lo stesso risultato?

P.s quando emergevo x e gnome spesso suonava il bios del pc è normale?
RIngrazio per le risposte


Last edited by newuserx on Sun Dec 28, 2008 4:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Nov 07, 2008 2:15 pm    Post subject: Reply with quote

nota generale sull'uso di emerge: ti consiglio sempre di vedere quali pacchetti stanno per essere installati e con quali opzioni abilitate (USE FLAG) per fare questo aggiungi le opzioni -a (--ask) e -v (--verbose) al comando emerge, quindi abilita/disabilita le opzioni che più ritieni utili:
normalmente puoi vederne la descrizione con
Code:
quse -D <flag>

ma se non erro quse fa parte di app-portage/portage-utils.

qui noterai se una flag è globale o locale (cioè si applica al singolo pacchetto), e riguardo a ciò ti consiglio la lettura di:
http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2&chap=2

per abilitare globalmente le flag trovo comodo
Code:
euse -E <flag>

per disabilitarla
Code:
euse -D <flag>

(oppure classicamente modificando make.conf a mano)
euse fa invece parte del pacchetto app-portage/gentoolkit
mentre per abilitarla/disabilitarla localmente ti consiglio di usare /etc/portage/package.use
nello stesso modo che si usa per installare pacchetti considerati non stabili; a tal proposito ti consiglio vivamente la lettura di:
http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=3&chap=3

Ultima cosa: spesso i pacchetti a fine installazione, di aggiornamento o di rimozione, stampano delle informazioni che sono spesso essenziali (come usare il pacchetto o quale guida, file di configurazione guardare), per evitare di avere problemi prima o poi ti consiglio VIVAMENTE di usare ELOG, feature di portage che consente di rintracciare questi messaggi tutti assieme, specialmente quando il numero è elevato, per questo guarda questa sezione della guida di portage:
http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=3&chap=1#doc_chap4

benvenuto e buon divertimento 8)

PS: in generale ti consiglio nei momenti di pausa mentre aspetti che ti emerga il sistema, di leggerti la guida generica su gentoo
http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2
e portage
http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=3
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Fri Nov 07, 2008 2:44 pm    Post subject: Reply with quote

grazie per le dritte...darò con calma un'occhiata a tutto e poi cercherò di reinstallare, cmq mi avevano consigliato di disabilitare le use prima di installare x e gnome, va bene?
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Nov 07, 2008 3:16 pm    Post subject: Reply with quote

newuserx wrote:
grazie per le dritte...darò con calma un'occhiata a tutto e poi cercherò di reinstallare, cmq mi avevano consigliato di disabilitare le use prima di installare x e gnome, va bene?


"disabilitare le use" è un po' troppo generico
diciamo che per l'installazione del sistema base che viene con lo stage, direi che le USE fornite nel profilo vanno più che bene, quando inizi ad installare la parte "grafica" conviene vedere quali USE ci sono e iniziare a capire quali abilitare e disabilitare, altrimenti dopo ti tocca ricompilare chili di pacchetti due volte.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Sat Nov 08, 2008 10:53 am    Post subject: Reply with quote

e per il rumore del bios quando emergevo?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Nov 08, 2008 1:28 pm    Post subject: Reply with quote

bip al riavvio o durante la compilazione?
Se ci pensi bene ricorda il bip del forno a microonde per avvistarti del "la zuppa l'è cotten" di bonviana memoria, ovvero si lamenta perchè ha troppo caldo.

La prima cosa (assai stupida) che puoi fare è andare nelle impostazioni del bios e disabilitare il warn per il surriscaldamento o il monitor hardware (su alcuni bios è la stessa cosa).
La seconda cosa è pensare di configurare la gestione energetica in modo da evitare la cottura del computer, se è un portatile, se è un desktop potresti pensare che è ora di prendere un dissipatore meno "puffo", ovviamente parlando di computer nuovi.
Se il computer ha più di un annetto mi sa che è il momento di fargli il bagnetto, ovvero ripulire ventole e dissipatori assortiti; se è un portatile dicono un gran bene delle superfici in marmo od in vetro come appoggio, contribuiscono assai meglio alla dissipazione delle superfici in legno, plastica e conglomerati vari.

Sappi che le regole stabiliscono la correlazione stretta un problema->un thread. Se non funziona o ti accodi ad uno dei vecchi thread sull'argomento o ne apri uno nuovo, stà roba va in discussioni in genere. (per la ricerca c'è un thread evidenziato, leggilo o perderai tempo e non troverai niente)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Sat Nov 08, 2008 1:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sat Nov 08, 2008 1:30 pm    Post subject: Reply with quote

djinnZ wrote:
bip al riavvio o durante la compilazione?
Se ci pensi bene ricorda il bip del forno a microonde per avvistarti del "la zuppa l'è cotten" di bonviana memoria, ovvero si lamenta perchè ha troppo caldo.

La prima cosa (assai stupida) che puoi fare è andare nelle impostazioni del bios e disabilitare il warn per il surriscaldamento o il monitor hardware (su alcuni bios è la stessa cosa).
La seconda cosa è pensare di configurare la gestione energetica in modo da evitare la cottura del computer, se è un portatile, se è un desktop potresti pensare che è ora di prendere un dissipatore meno "puffo", ovviamente parlando di computer nuovi.
Se il computer ha più di un annetto mi sa che è il momento di fargli il bagnetto, ovvero ripulire ventole e dissipatori assortiti; se è un portatile dicono un gran bene delle superfici in marmo od in vetro come appoggio, contribuiscono assai meglio alla dissipazione delle superfici in legno, plastica e conglomerati vari.

a dirla tutta, a me, tempo fa capitò una situazione in cui dei warning di post install (tipo il countdown di emerge) venivano segnalati con dei "beep" dello speaker del pc. allora non stetti troppo a perdere tempo, e quindi non mi sento nemmeno di confermare questa cosa... ma ora che ci penso... è possibile???
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Nov 08, 2008 1:34 pm    Post subject: Reply with quote

Si, dipende dal tono, mi pare che quello della temperatura dovrebbe essere intorno nai 3/400 hz mentre quello dei warn di compilazione ridotto alla metà.

Dimenticavo che se ci sono degli avvisi importanti alla fine dell'installazione emerge si lamenta un poco anche lui.

Detta così genericamente ci sono diverse possibili cause e la mia sfera di cristallo non è che funzioni sempre benissimo. :twisted:

In ogni caso è meglio partire dalla verifica dell'ipotesi più funesta (la cottura del pc), se è un altro motivo tanto di guadagnato.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Sat Nov 08, 2008 1:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
Luc484
Veteran
Veteran


Joined: 26 Mar 2005
Posts: 1035
Location: Italy

PostPosted: Sat Nov 08, 2008 1:35 pm    Post subject: Reply with quote

Beh, anche a me suona spesso qualche suono il PC quando esegue qualche merge, mi pare che segnali messaggi importanti, se è questo di cui si sta parlando. Suona anche il mac quando mi collego su Gentoo via ssh per fare compilazioni. Però non sono sicuro che sia l'internal speaker... ma magari vi riferite a qualcosa di diverso...
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Sat Nov 08, 2008 6:53 pm    Post subject: Reply with quote

non credo che sia il surriscaldamento dato che non mi e mai capitato e poi ho controllato le temperature nel bios....inoltre pulisco le ventole 1volta al mese e tengo il coperchio laterale del case sempre aperto...per favorire la "respirazione" del pc.Di solito riscalda molto con i dual core potenti tipo E6850, io ho solo un modesto E2140.. :) cmq sento il bip quando finisce di installare un pacchetto e ne emerge un'altro..
Peach wrote:
a dirla tutta, a me, tempo fa capitò una situazione in cui dei warning di post install (tipo il countdown di emerge) venivano segnalati con dei "beep" dello speaker del pc. allora non stetti troppo a perdere tempo, e quindi non mi sento nemmeno di confermare questa cosa... ma ora che ci penso... è possibile???

a dir la verità ora che ci penso bene mi sono incuriosito poichè non mi e partito X ma poi oltre a qst quando stava compilando X se non sbaglio era a metà lavoro, e c'aveva messo un bel po di tempo..poi ho spento lo schermo e dopo 5 minuti aveva finito e in quei 5 minuti non ho + sentito il beep del pc
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Nov 08, 2008 7:06 pm    Post subject: Reply with quote

newuserx wrote:
non credo che sia il surriscaldamento dato che non mi e mai capitato e poi ho controllato le temperature nel bios....inoltre pulisco le ventole 1volta al mese e tengo il coperchio laterale del case sempre aperto...per favorire la "respirazione" del pc.Di solito riscalda molto con i dual core potenti tipo E6850, io ho solo un modesto E2140.. :) cmq sento il bip quando finisce di installare un pacchetto e ne emerge un'altro..
è nomale, non ti preoccupare.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Sat Nov 08, 2008 7:36 pm    Post subject: Reply with quote

non e' la famosa "system bell" che fa bip ogni volta che succede qualcosa di "importante", come la fine di una compilazione?
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sun Nov 09, 2008 12:43 am    Post subject: Reply with quote

ckx3009 wrote:
non e' la famosa "system bell" che fa bip ogni volta che succede qualcosa di "importante", come la fine di una compilazione?


la stessa che ti fa fare beep quando pigi tab sul terminale?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Sun Nov 09, 2008 1:24 pm    Post subject: Reply with quote

si mi riferivo esattamente a quella :D
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Sun Dec 14, 2008 12:06 pm    Post subject: Reply with quote

eccomi..ho ritentato l'installazione...questa volta ho caricato un .config di un kernel fatto su un'altra distro...cmq prima di emergere il server X ho configurato make.conf dicendogli che ho una scheda nvidia,mouse e tastiera, poi però nell'emergere trovo problemi alla fine poichè non emerge i driver nvidia..posso postare il log di x:
Code:
 
X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN
Current Operating System: Linux tux 2.6.26-gentoo-r4 #1 SMP PREEMPT Sat Dec 13 18:14:24 Local time zone must be set-- x86_64
Build Date: 13 December 2008
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 13 20:12:11 2008
(EE) Unable to locate/open config file
(II) Loader magic: 0x7b07a0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.3
   X.Org Video Driver: 1.2
   X.Org XInput driver : 0.7
   X.Org Server Extension : 0.3
   X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib64/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   ABI class: X.Org Video Driver, version 1.2
(--) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,29c0 card 1043,8276 rev 02 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,29c1 card 0000,0000 rev 02 class 06,04,00 hdr 01
(II) PCI: 00:1a:0: chip 8086,2937 card 1043,8277 rev 02 class 0c,03,00 hdr 80
(II) PCI: 00:1a:1: chip 8086,2938 card 1043,8277 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1a:2: chip 8086,2939 card 1043,8277 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1a:7: chip 8086,293c card 1043,8277 rev 02 class 0c,03,20 hdr 00
(II) PCI: 00:1b:0: chip 8086,293e card 1043,829f rev 02 class 04,03,00 hdr 00
(II) PCI: 00:1c:0: chip 8086,2940 card 0000,0000 rev 02 class 06,04,00 hdr 81
(II) PCI: 00:1c:4: chip 8086,2948 card 0000,0000 rev 02 class 06,04,00 hdr 81
(II) PCI: 00:1c:5: chip 8086,294a card 0000,0000 rev 02 class 06,04,00 hdr 81
(II) PCI: 00:1d:0: chip 8086,2934 card 1043,8277 rev 02 class 0c,03,00 hdr 80
(II) PCI: 00:1d:1: chip 8086,2935 card 1043,8277 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:2: chip 8086,2936 card 1043,8277 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:7: chip 8086,293a card 1043,8277 rev 02 class 0c,03,20 hdr 00
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev 92 class 06,04,01 hdr 01
(II) PCI: 00:1f:0: chip 8086,2918 card 1043,8277 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:1f:2: chip 8086,2921 card 1043,8277 rev 02 class 01,01,8f hdr 00
(II) PCI: 00:1f:3: chip 8086,2930 card 1043,8277 rev 02 class 0c,05,00 hdr 00
(II) PCI: 00:1f:5: chip 8086,2926 card 1043,8277 rev 02 class 01,01,85 hdr 00
(II) PCI: 01:00:0: chip 10de,0393 card 0000,0000 rev a1 class 03,00,00 hdr 00
(II) PCI: 02:00:0: chip 1969,1048 card 1043,8226 rev b0 class 02,00,00 hdr 00
(II) PCI: 03:00:0: chip 197b,2363 card 1043,824f rev 03 class 01,06,01 hdr 80
(II) PCI: 03:00:1: chip 197b,2363 card 1043,824f rev 03 class 01,01,85 hdr 00
(II) PCI: 05:03:0: chip 1106,3044 card 1043,81fe rev c0 class 0c,00,10 hdr 00
(II) PCI: End of PCI scan
(II) Intel Bridge workaround enabled
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,5), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
   [0] -1   0   0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
   [0] -1   0   0x00000000 - 0xffffffff (0x100000000) MX[B]
(II) Bus 0 prefetchable memory range:
   [0] -1   0   0x00000000 - 0xffffffff (0x100000000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 1 I/O range:
   [0] -1   0   0x0000c000 - 0x0000cfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
   [0] -1   0   0xfc000000 - 0xfe8fffff (0x2900000) MX[B]
(II) Bus 1 prefetchable memory range:
   [0] -1   0   0xd0000000 - 0xdfffffff (0x10000000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 4: bridge is at (0:28:0), (0,4,4), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 4 prefetchable memory range:
   [0] -1   0   0xfaf00000 - 0xfaffffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:28:4), (0,3,3), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 3 I/O range:
   [0] -1   0   0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 3 non-prefetchable memory range:
   [0] -1   0   0xfea00000 - 0xfeafffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:28:5), (0,2,2), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 2 non-prefetchable memory range:
   [0] -1   0   0xfe900000 - 0xfe9fffff (0x100000) MX[B]
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 5: bridge is at (0:30:0), (0,5,5), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 5 I/O range:
   [0] -1   0   0x0000e000 - 0x0000efff (0x1000) IX[B]
(II) Bus 5 non-prefetchable memory range:
   [0] -1   0   0xfeb00000 - 0xfebfffff (0x100000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation G70 [GeForce 7300 GT] rev 161, Mem @ 0xfd000000/24, 0xd0000000/28, 0xfc000000/24, I/O @ 0xcc00/7, BIOS @ 0xfe8e0000/17
New driver is "nv"
(==) Using default built-in configuration (55 lines)
(==) --- Start of built-in configuration ---
   Section "Module"
      Load   "extmod"
      Load   "dbe"
      Load   "glx"
      Load   "freetype"
      Load   "type1"
      Load   "record"
      Load   "dri"
   EndSection
   Section "Monitor"
      Identifier   "Builtin Default Monitor"
   EndSection
   Section "Device"
      Identifier   "Builtin Default nv Device 0"
      Driver   "nv"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default nv Screen 0"
      Device   "Builtin Default nv Device 0"
      Monitor   "Builtin Default Monitor"
   EndSection
   Section "Device"
      Identifier   "Builtin Default fbdev Device 0"
      Driver   "fbdev"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default fbdev Screen 0"
      Device   "Builtin Default fbdev Device 0"
      Monitor   "Builtin Default Monitor"
   EndSection
   Section "Device"
      Identifier   "Builtin Default vesa Device 0"
      Driver   "vesa"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default vesa Screen 0"
      Device   "Builtin Default vesa Device 0"
      Monitor   "Builtin Default Monitor"
   EndSection
   Section "Device"
      Identifier   "Builtin Default vga Device 0"
      Driver   "vga"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default vga Screen 0"
      Device   "Builtin Default vga Device 0"
      Monitor   "Builtin Default Monitor"
   EndSection
   Section "ServerLayout"
      Identifier   "Builtin Default Layout"
      Screen   "Builtin Default nv Screen 0"
      Screen   "Builtin Default fbdev Screen 0"
      Screen   "Builtin Default vesa Screen 0"
      Screen   "Builtin Default vga Screen 0"
   EndSection
(==) --- End of built-in configuration ---
(==) ServerLayout "Builtin Default Layout"
(**) |-->Screen "Builtin Default nv Screen 0" (0)
(**) |   |-->Monitor "Builtin Default Monitor"
(**) |   |-->Device "Builtin Default nv Device 0"
(**) |-->Screen "Builtin Default fbdev Screen 0" (1)
(**) |   |-->Monitor "Builtin Default Monitor"
(**) |   |-->Device "Builtin Default fbdev Device 0"
(**) |-->Screen "Builtin Default vesa Screen 0" (2)
(**) |   |-->Monitor "Builtin Default Monitor"
(**) |   |-->Device "Builtin Default vesa Device 0"
(**) |-->Screen "Builtin Default vga Screen 0" (3)
(**) |   |-->Monitor "Builtin Default Monitor"
(**) |   |-->Device "Builtin Default vga Device 0"
(==) |-->Input Device "<default pointer>"
(==) |-->Input Device "<default keyboard>"
(WW) The core pointer device wasn't specified explicitly in the layout.
   Using the default mouse configuration.
(WW) The core keyboard device wasn't specified explicitly in the layout.
   Using the default keyboard configuration.
(WW) No FontPath specified.  Using compiled-in default.
(WW) The directory "/usr/share/fonts/TTF/" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib64/xorg/modules"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Addressable bus resource ranges are
   [0] -1   0   0x00000000 - 0xffffffff (0x100000000) MX[B]
   [1] -1   0   0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
   [0] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
   [0] -1   0   0xfebff800 - 0xfebfffff (0x800) MX[B]
   [1] -1   0   0xfeafe000 - 0xfeafffff (0x2000) MX[B]
   [2] -1   0   0xfe9c0000 - 0xfe9fffff (0x40000) MX[B]
   [3] -1   0   0xfbfff400 - 0xfbfff4ff (0x100) MX[B]
   [4] -1   0   0xfbfff800 - 0xfbfffbff (0x400) MX[B]
   [5] -1   0   0xfbff8000 - 0xfbffbfff (0x4000) MX[B]
   [6] -1   0   0xfbfffc00 - 0xfbffffff (0x400) MX[B]
   [7] -1   0   0xfe8e0000 - 0xfe8fffff (0x20000) MX[B](B)
   [8] -1   0   0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
   [9] -1   0   0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
   [10] -1   0   0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
   [11] -1   0   0x0000ec00 - 0x0000ec7f (0x80) IX[B]
   [12] -1   0   0x0000d400 - 0x0000d40f (0x10) IX[B]
   [13] -1   0   0x0000d480 - 0x0000d483 (0x4) IX[B]
   [14] -1   0   0x0000d800 - 0x0000d807 (0x8) IX[B]
   [15] -1   0   0x0000d880 - 0x0000d883 (0x4) IX[B]
   [16] -1   0   0x0000dc00 - 0x0000dc07 (0x8) IX[B]
   [17] -1   0   0x0000a400 - 0x0000a40f (0x10) IX[B]
   [18] -1   0   0x0000a480 - 0x0000a48f (0x10) IX[B]
   [19] -1   0   0x0000a800 - 0x0000a803 (0x4) IX[B]
   [20] -1   0   0x0000a880 - 0x0000a887 (0x8) IX[B]
   [21] -1   0   0x0000ac00 - 0x0000ac03 (0x4) IX[B]
   [22] -1   0   0x0000b000 - 0x0000b007 (0x8) IX[B]
   [23] -1   0   0x00000400 - 0x0000041f (0x20) IX[B]
   [24] -1   0   0x00009400 - 0x0000940f (0x10) IX[B]
   [25] -1   0   0x00009480 - 0x0000948f (0x10) IX[B]
   [26] -1   0   0x00009800 - 0x00009803 (0x4) IX[B]
   [27] -1   0   0x00009880 - 0x00009887 (0x8) IX[B]
   [28] -1   0   0x00009c00 - 0x00009c03 (0x4) IX[B]
   [29] -1   0   0x0000a000 - 0x0000a007 (0x8) IX[B]
   [30] -1   0   0x0000b480 - 0x0000b49f (0x20) IX[B]
   [31] -1   0   0x0000b400 - 0x0000b41f (0x20) IX[B]
   [32] -1   0   0x0000b080 - 0x0000b09f (0x20) IX[B]
   [33] -1   0   0x0000bc00 - 0x0000bc1f (0x20) IX[B]
   [34] -1   0   0x0000b880 - 0x0000b89f (0x20) IX[B]
   [35] -1   0   0x0000b800 - 0x0000b81f (0x20) IX[B]
   [36] -1   0   0x0000cc00 - 0x0000cc7f (0x80) IX[B](B)
(II) Active PCI resource ranges after removing overlaps:
   [0] -1   0   0xfebff800 - 0xfebfffff (0x800) MX[B]
   [1] -1   0   0xfeafe000 - 0xfeafffff (0x2000) MX[B]
   [2] -1   0   0xfe9c0000 - 0xfe9fffff (0x40000) MX[B]
   [3] -1   0   0xfbfff400 - 0xfbfff4ff (0x100) MX[B]
   [4] -1   0   0xfbfff800 - 0xfbfffbff (0x400) MX[B]
   [5] -1   0   0xfbff8000 - 0xfbffbfff (0x4000) MX[B]
   [6] -1   0   0xfbfffc00 - 0xfbffffff (0x400) MX[B]
   [7] -1   0   0xfe8e0000 - 0xfe8fffff (0x20000) MX[B](B)
   [8] -1   0   0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
   [9] -1   0   0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
   [10] -1   0   0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
   [11] -1   0   0x0000ec00 - 0x0000ec7f (0x80) IX[B]
   [12] -1   0   0x0000d400 - 0x0000d40f (0x10) IX[B]
   [13] -1   0   0x0000d480 - 0x0000d483 (0x4) IX[B]
   [14] -1   0   0x0000d800 - 0x0000d807 (0x8) IX[B]
   [15] -1   0   0x0000d880 - 0x0000d883 (0x4) IX[B]
   [16] -1   0   0x0000dc00 - 0x0000dc07 (0x8) IX[B]
   [17] -1   0   0x0000a400 - 0x0000a40f (0x10) IX[B]
   [18] -1   0   0x0000a480 - 0x0000a48f (0x10) IX[B]
   [19] -1   0   0x0000a800 - 0x0000a803 (0x4) IX[B]
   [20] -1   0   0x0000a880 - 0x0000a887 (0x8) IX[B]
   [21] -1   0   0x0000ac00 - 0x0000ac03 (0x4) IX[B]
   [22] -1   0   0x0000b000 - 0x0000b007 (0x8) IX[B]
   [23] -1   0   0x00000400 - 0x0000041f (0x20) IX[B]
   [24] -1   0   0x00009400 - 0x0000940f (0x10) IX[B]
   [25] -1   0   0x00009480 - 0x0000948f (0x10) IX[B]
   [26] -1   0   0x00009800 - 0x00009803 (0x4) IX[B]
   [27] -1   0   0x00009880 - 0x00009887 (0x8) IX[B]
   [28] -1   0   0x00009c00 - 0x00009c03 (0x4) IX[B]
   [29] -1   0   0x0000a000 - 0x0000a007 (0x8) IX[B]
   [30] -1   0   0x0000b480 - 0x0000b49f (0x20) IX[B]
   [31] -1   0   0x0000b400 - 0x0000b41f (0x20) IX[B]
   [32] -1   0   0x0000b080 - 0x0000b09f (0x20) IX[B]
   [33] -1   0   0x0000bc00 - 0x0000bc1f (0x20) IX[B]
   [34] -1   0   0x0000b880 - 0x0000b89f (0x20) IX[B]
   [35] -1   0   0x0000b800 - 0x0000b81f (0x20) IX[B]
   [36] -1   0   0x0000cc00 - 0x0000cc7f (0x80) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
   [0] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
   [0] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0xfebff800 - 0xfebfffff (0x800) MX[B]
   [5] -1   0   0xfeafe000 - 0xfeafffff (0x2000) MX[B]
   [6] -1   0   0xfe9c0000 - 0xfe9fffff (0x40000) MX[B]
   [7] -1   0   0xfbfff400 - 0xfbfff4ff (0x100) MX[B]
   [8] -1   0   0xfbfff800 - 0xfbfffbff (0x400) MX[B]
   [9] -1   0   0xfbff8000 - 0xfbffbfff (0x4000) MX[B]
   [10] -1   0   0xfbfffc00 - 0xfbffffff (0x400) MX[B]
   [11] -1   0   0xfe8e0000 - 0xfe8fffff (0x20000) MX[B](B)
   [12] -1   0   0xfc000000 - 0xfcffffff (0x1000000) MX[B](B)
   [13] -1   0   0xd0000000 - 0xdfffffff (0x10000000) MX[B](B)
   [14] -1   0   0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
   [15] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [16] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
   [17] -1   0   0x0000ec00 - 0x0000ec7f (0x80) IX[B]
   [18] -1   0   0x0000d400 - 0x0000d40f (0x10) IX[B]
   [19] -1   0   0x0000d480 - 0x0000d483 (0x4) IX[B]
   [20] -1   0   0x0000d800 - 0x0000d807 (0x8) IX[B]
   [21] -1   0   0x0000d880 - 0x0000d883 (0x4) IX[B]
   [22] -1   0   0x0000dc00 - 0x0000dc07 (0x8) IX[B]
   [23] -1   0   0x0000a400 - 0x0000a40f (0x10) IX[B]
   [24] -1   0   0x0000a480 - 0x0000a48f (0x10) IX[B]
   [25] -1   0   0x0000a800 - 0x0000a803 (0x4) IX[B]
   [26] -1   0   0x0000a880 - 0x0000a887 (0x8) IX[B]
   [27] -1   0   0x0000ac00 - 0x0000ac03 (0x4) IX[B]
   [28] -1   0   0x0000b000 - 0x0000b007 (0x8) IX[B]
   [29] -1   0   0x00000400 - 0x0000041f (0x20) IX[B]
   [30] -1   0   0x00009400 - 0x0000940f (0x10) IX[B]
   [31] -1   0   0x00009480 - 0x0000948f (0x10) IX[B]
   [32] -1   0   0x00009800 - 0x00009803 (0x4) IX[B]
   [33] -1   0   0x00009880 - 0x00009887 (0x8) IX[B]
   [34] -1   0   0x00009c00 - 0x00009c03 (0x4) IX[B]
   [35] -1   0   0x0000a000 - 0x0000a007 (0x8) IX[B]
   [36] -1   0   0x0000b480 - 0x0000b49f (0x20) IX[B]
   [37] -1   0   0x0000b400 - 0x0000b41f (0x20) IX[B]
   [38] -1   0   0x0000b080 - 0x0000b09f (0x20) IX[B]
   [39] -1   0   0x0000bc00 - 0x0000bc1f (0x20) IX[B]
   [40] -1   0   0x0000b880 - 0x0000b89f (0x20) IX[B]
   [41] -1   0   0x0000b800 - 0x0000b81f (0x20) IX[B]
   [42] -1   0   0x0000cc00 - 0x0000cc7f (0x80) IX[B](B)
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 0.3
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/lib64/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
   compiled for 1.3.0, module version = 2.1.0
   Module class: X.Org Font Renderer
   ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/lib64/xorg/modules/fonts//libtype1.so
(II) Module type1: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.2
   Module class: X.Org Font Renderer
   ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI
(II) LoadModule: "nv"
(WW) Warning, couldn't open module nv
(II) UnloadModule: "nv"
(EE) Failed to load module "nv" (module does not exist, 0)
(II) LoadModule: "fbdev"
(WW) Warning, couldn't open module fbdev
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) LoadModule: "vesa"
(WW) Warning, couldn't open module vesa
(II) UnloadModule: "vesa"
(EE) Failed to load module "vesa" (module does not exist, 0)
(II) LoadModule: "vga"
(WW) Warning, couldn't open module vga
(II) UnloadModule: "vga"
(EE) Failed to load module "vga" (module does not exist, 0)
(II) LoadModule: "mouse"
(WW) Warning, couldn't open module mouse
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (module does not exist, 0)
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sun Dec 14, 2008 12:32 pm    Post subject: Reply with quote

hai provato a seguire questa guida: http://www.gentoo.org/doc/it/nvidia-guide.xml?
_________________
LP
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Sun Dec 14, 2008 1:53 pm    Post subject: Reply with quote

beh in effetti mi manca l'MTRR..per i driver interni che potevano andare in conflitto li ho tolti..ora come procedo?devo fare un unmerge di x o dopo che applico le modifiche riemergo senza togliere i precedenti?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Dec 14, 2008 3:24 pm    Post subject: Reply with quote

Consiglio: se devi ricompilare il driver nvidia/ati è meglio che lanci preventivamente un eselect opengl set xorg-x11, e poi riabiliti; c'è un problemino con eselect ed i link simbolici.
In make.conf hai
VIDEO_CARDS="nv nvidia" (verificare, sono uno dei dannATI, per mia disgrazia) e INPUT_DEVICES="evdev keyboard mouse" almeno? Fatto questo ti basta lanciare un emerge -NDu @world per mettere a posto, credo. Ovviamente mi auguro che xorg-x11 sia in world o sia richiesto come dipendenza da qualche pacchetto in world, se lanci un emerge --depclean -p quali pacchetti ti vuole disinstallare?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
newuserx
n00b
n00b


Joined: 07 Nov 2008
Posts: 8

PostPosted: Sun Dec 14, 2008 5:03 pm    Post subject: Reply with quote

ti ringrazio dell'aiuto ma pur cavandomela con linux..su gentoo non ho esperienza e non ho capito un granché, potresti spiegarmi meglio quali input devo dare e quali output vorresti sapere?grazie

EDIT:ho risolto..ho installato il sitema e la parte grafica..grazie cmq.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum