Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[LaTeX] File `floatflt.sty' not found [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Wed Nov 05, 2008 6:33 pm    Post subject: [LaTeX] File `floatflt.sty' not found [Résolu] Reply with quote

Bonjour,

Sur mon pc de bureau, qui est en gentoo ~amd64, j'ai installé texlive 2008 pour compiler mon rapport de stage. Lorsque je le compile, pdflatex se plaint de pas trouver floatflt.sty. Je pense que j'ai oublier d'installer un package texlive, mais je ne vois pas lequel, mon ami google ne m'a donné des réponses que pour Miktex (machin windows). Aussi je viens demander l'aide de « spécialistes », pour trouver quel ebuild texlive j'aurai oublié (quel étourdi je fais).

Voici le log de compilation :

Code:

pdflatex stage.tex
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.
entering extended mode
(./stage.tex
LaTeX2e <2005/12/01>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, basque, french, loaded.
(/usr/share/texmf-dist/tex/latex/base/report.cls
Document Class: report 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size12.clo))
(/usr/share/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texmf-dist/tex/latex/base/t1enc.def))
(/usr/share/texmf-dist/tex/latex/base/inputenc.sty
(/usr/share/texmf-dist/tex/latex/base/utf8.def
(/usr/share/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/share/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/share/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/share/texmf-dist/tex/generic/babel/babel.sty
(/usr/share/texmf-dist/tex/generic/babel/frenchb.ldf
(/usr/share/texmf-dist/tex/generic/babel/babel.def)
*************************************
* Local config file frenchb.cfg used
*
(/usr/share/texmf-dist/tex/generic/babel/frenchb.cfg)))
(/usr/share/texmf-dist/tex/latex/carlisle/scalefnt.sty)
(/usr/share/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/share/texmf-dist/tex/latex/fancyhdr/fancyhdr.sty)
(/usr/share/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/share/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/share/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/share/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf-dist/tex/latex/pdftex-def/pdftex.def)))
(/usr/share/texmf-dist/tex/latex/ltxmisc/a4wide.sty
(/usr/share/texmf-dist/tex/latex/ntgclass/a4.sty))
(/usr/share/texmf-dist/tex/latex/float/float.sty)
(/usr/share/texmf-dist/tex/latex/psnfss/palatino.sty)
(/usr/share/texmf-dist/tex/latex/moreverb/moreverb.sty
(/usr/share/texmf-dist/tex/latex/tools/verbatim.sty))
(/usr/share/texmf-dist/tex/latex/base/alltt.sty)

! LaTeX Error: File `floatflt.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)


Voici la liste des packages que j'utilise dans mon fichier .tex :

Code:

\documentclass[a4paper, 12pt, twoside]{report}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[frenchb]{babel}
\usepackage{fancyhdr}
\usepackage[final]{graphicx}%draft pour les essais
\usepackage{a4wide}
\usepackage{float}
\usepackage{palatino}
\usepackage{moreverb}
\usepackage{alltt}
\usepackage{floatflt}
\usepackage{hyperref}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{subfigure}
\usepackage{array}
\usepackage{tabularx}
\usepackage{subfigure}

%Balise pour mettre en forme le code source
%\begin{lstlisting}[firstnumber=1]
%\end{lstlisting}
\usepackage{listings}
\usepackage{color}



J'ai créé un set portage pour installer texlive le voici :

Code:
dev-texlive/texlive-latex
dev-texlive/texlive-documentation-base
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-latexextra
dev-texlive/texlive-langfrench
dev-texlive/texlive-science
dev-texlive/texlive-pictures
dev-texlive/texlive-pstricks
dev-texlive/texlive-mathextra
dev-texlive/texlive-publishers
dev-texlive/texlive-genericextra
dev-texlive/texlive-bibtexextra


Merci de votre aide.

PS : j'aimerai éviter d'installer tous les ebuilds texlive pour avoir mon fichier sty manquant, de même je préférerai l'instant depuis portage que d'aller le chercher sur le site du CTAN.
PS2 : en commentant \usepackage{floatflt} je n'ai plus d'erreur, mais je préferrai savoir quel ebuild installer, d'autant plus que j'aurais peut être besoin de ce package dans le futur.


Last edited by ppg on Wed Nov 05, 2008 7:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Nov 05, 2008 6:56 pm    Post subject: Reply with quote

Utilise dev-tex/texmfind ;)

Code:
[pierre@Korriban ~] % texmfind floatflt
dev-texlive/texlive-latexrecommended [1 file]
floatflt

Found 1 texmf file in 1 ebuild.


Donc à priori tu devrais déjà l'avoir.
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Wed Nov 05, 2008 7:28 pm    Post subject: Reply with quote

Effectivement, j'obtiens le même résultat chez moi, pourtant pdflatex se plaint toujours de ne pas trouver floatflt :!:
Je devrais peut être changer pour revenir en texlive 2007 ? (Mais mon rapport est à rendre bientôt je ne vais pas pendre ce risque maintenant)

EDIT : je viens de voir qu'un autre ebuild contient floatftl mais celui est Hard masked (enfin [M] c'est bien pour les ebuilds hard-masked non :oops: ?)
Code:
furet@woodstock ~/stage/rapport $ eix floatflt
* dev-tex/floatflt
     Available versions:  [M]1.31a
     Homepage:            http://www.ctan.org/tex-archive/help/Catalogue/entries/floatflt.html?action=/tex-archive/macros/latex/contrib/other/floatflt/
     Description:         LaTeX package used to warp text around figures

l'installer résoudra-t-il mon problème ?


Last edited by ppg on Wed Nov 05, 2008 7:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Wed Nov 05, 2008 7:45 pm    Post subject: Reply with quote

Bonjour,

Il semblerait que floatflt ait été retiré de texlive 2008 à cause d'un problème de licence...

3 solutions:
- copier manuellement le fichier depuis le serveur CTAN
- repasser à texlive 2007
- demasquer le paquet dev-tex/floatflt puis l'installer (j'ai pas testé)

Perso, j'ai choisi la 1ère...
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Wed Nov 05, 2008 7:49 pm    Post subject: Reply with quote

Merci YétiBarBar.

Je crois que quand j'aurais finit mon rapport je vais repasser sur texlive 2007 car les autres machines que j'utilise sont restées sur la version 2007 ; de plus j'ai à mon niveau pas eu un réel besoin de passer en 2008 (conséquence indirecte du ACCEPT_KEYWORD=~adm64).

Merci à toi aussi geekounet.
Back to top
View user's profile Send private message
Alexis
Developer
Developer


Joined: 25 Jun 2004
Posts: 241

PostPosted: Thu Nov 06, 2008 8:04 am    Post subject: Reply with quote

oué floatflt a été viré de tl 2008 pour des raisons de license...
cf https://bugs.gentoo.org/show_bug.cgi?id=240321; n'étant pas spécialiste des questions de licenses, je ne me mouille pas trop en général donc j'ai pas encore bougé a propos de ça. Si quelqu'un veut me filer un coup de main à ce propos, l'aide est vraiment bienvenue :)
Ça veut dire regarder attentivement les fichiers dans http://tug.ctan.org/tex-archive/macros/latex/contrib/floatflt/ et me dire où est la partie non libre et quelle license serait la plus appropriée
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum