Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Localizzazione italiano di krita e gimp su kde
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Fri Oct 10, 2008 7:25 pm    Post subject: [RISOLTO]Localizzazione italiano di krita e gimp su kde Reply with quote

Salve a tutti,
lo so che è un problema stupidissimo, però ho cercato in lungo e in largo e non ho trovato una risposta a questo mio "strano" problemino. Uso kde già completamente localizzata in italiano, ho però alcuni programmi, nella fattispecie gimp e krita, in inglese.
Riguardo a gimp credo che dipenda qualcosa da gnome, perdonate se dico una ca****a, mentre krita, dovrebbe far parte di koffice, e quindi non capisco perchè, anche dopo riemersione del pacchetto kde-i18n, non si sia messo in italiano. Non ho trovato inoltre nelle impostazioni dei due programmi qualcosa a riguardo.

p.s.: in make.conf è impostato LINUGUAS così:
Code:
LINGUAS="it"


Potete darmi una mano, non so dove sbattere la testa, insomma la soluzione credo sia sotto il mio naso, ma non riesco a venirne a capo.


Last edited by dynamite on Mon Oct 13, 2008 8:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Oct 10, 2008 7:41 pm    Post subject: Reply with quote

LINGUAS="it en" è meglio IMHO :wink:
Avvia un xterm, lancia locale, verifica che sia a posto e prova a lanciare da li gimp, verifica che locales.gen e compagnia siano a posto nel frattempo e semmai prova a cambiare LC_ALL in 02locale in it_IT.UTF-8 o cosa ti potrebbe servire. Sempre che la localizzazione sia prevista (per gimp si per gli altri non so), in tal caso ti becchi posix ovvero en.

Non ti invito a rileggere l'apposita guida (che in virtù dello sfruttamento schiavistico dei traduttori non è disponibile nel solo odioso idioma britannico) e non ti posto il link pechè se non lo hai fatto è tempo che ti arrangi a cercare. [OT]sempre per i "furbi" voglio chiarire che scherzo...[/OT]
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Sun Oct 12, 2008 6:23 pm    Post subject: Reply with quote

Scusa il ritardo nella risposta, proprio seguendo la guida (prima di scrivere il post 8) ) avevo modificato LC_ALL nel file 02locale in /etc/env.d/, ma non da risultati neanche avviando da terminale, ho aggiornato prima le variabili d'ambiente come scritto nella guida.
Ho pensato che servisse un particolare pacchetot (almeno) per quanto riguarda krita, perchè, credo nei vecchi ricordi su slackware, esisteva un pacchetto di localizzazione separato per koffice.

Modificando LINGUAS, aggiungendo "en", mi costringe a ricompilare alcuni pacchetti e al momento non ho tempo (nè batteria), rimando quest'operazione a domani e edito il post per segnalare eventuali cambiamenti della situazione. Pensi che sia questa la ragione della mancata localizzazione di questi due prog?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Oct 12, 2008 7:19 pm    Post subject: Reply with quote

assolutamente no, avere "it en" è una ridondanza per evitare problemi nel caso gli ebuild siano pasticciati, più che altro, è un consiglio generico (come usare userlocales e configurare meno "localizzazioni" possibili, configurare utf8, usare localepurge etc.).

da terminale X
Code:
locale
riporta correttamente it_IT o POSIX?
Tra le varie use per caso hai attivato userlocales (nls deve esserci)?
Hai configurato /etc/locales.gen?
app-i18n/koffice-i18n è installato? Anche kde-i18n?
In kde il supporto lingua e la localizzazione sono configurate?
emerge -pv gtk+ riporta linguas_it attiva?
Per caso hai usato localepurge ma non lo hai configurato per risparmiare il supporto alla lingua italiana prima?

Altre idee non me ne vengono posta un emerge info.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Sun Oct 12, 2008 7:43 pm    Post subject: Reply with quote

Quote:
riporta correttamente it_IT o POSIX?

Sì, avendo impostato LC_ALL si è tutto impostato a it_IT.UTF-8 UTF-8.
Comunque, ci hai beccato, non trovavo quel pacchetto, koffice-i18n, assurdo lo avevo cercato, ma evidentemente mi deve essere sfuggito!Krita ora è in italiano.
Per quanto riguarda gtk+, non riporta alcuna dicitura LINGUAS:
Code:
emerge -vp gtk+

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/gtk+-2.12.11  USE="X cups jpeg tiff xinerama -debug -doc -vim-syntax" 15,852 kB


Non ho la use flag userlocales attiva (di cui non ero a conoscenza e che attiverò subito) ed ecco:
Code:
emerge --info
Portage 2.1.4.5 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.26-gentoo-r1 x86_64 Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz
Timestamp of tree: Sun, 12 Oct 2008 18:30:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8 UTF-8"
LC_ALL="it_IT.UTF-8 UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amazon amd64 audiofile automount berkdb bluetooth bzip2 cairo cli cracklib crypt cups dbus dri dvdr encode fbsplash ffmpeg firefox flac gdbm gimp glitz gphoto2 gpm gstreamer gtk hal hdaps howl iconv imagemagick imlib ipw4965 isdnlog jpeg jpeg2k kde lame lm_sensors md5sum midi mjpeg mmx mng mp3 msse3 mudflap multilib musepack ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 readline reflection samba scanner session smp sndfile spl sse sse2 ssl svg sysfs tcl tcpd theora tiff tk unicode usb vcd vorbis wavpak xine xinerama xorg xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="synaptics evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Oct 13, 2008 6:45 pm    Post subject: Reply with quote

vedi che LANG ed LC_ALL devono essere impostate su "it_IT.UTF-8" non "it_IT.UTF-8 UTF-8", correggi e fai sapere. Ti ripeto che prima di attivare userlocales DEVI configurare bene i vali locale in etc, TUTTI.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Mon Oct 13, 2008 8:41 pm    Post subject: Reply with quote

Perdonami, ho dato per scontato che fosse così, perchè era così la riga da decomentare in locale.gen. Grazie per la pazienza! Tutto risolto (edito il primo post)
Back to top
View user's profile Send private message
fabiolino
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2006
Posts: 103
Location: bologna

PostPosted: Thu Mar 26, 2009 7:28 pm    Post subject: Reply with quote

Non riesco a visualizzare gimp in italiano
Ma non riesco a capire come mai non ho 02locale in /etc/env.d. :?
posto emerge --info
Code:

Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-AMD_Sempron-tm-_SI-42-with-glibc2.2.5
Timestamp of tree: Tue, 17 Mar 2009 21:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="it_IT UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/distfiles/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cdr cli cracklib crypt cups dri dvd fortran gdbm gpm gtk hal iconv isdnlog kde midi mmx motif mudflap multilib ncurses nls nptl nptlonly nvidia opengl openmp pam pcre perl pic pppd python qt qt3 readline reflection session spl sse sse2 ssl sysfs tcpd unicode wifi xorg xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
http://www.fabiospadaro.com
Back to top
View user's profile Send private message
dynamite
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jun 2007
Posts: 114
Location: Rovereto (TN)

PostPosted: Thu Mar 26, 2009 9:59 pm    Post subject: Reply with quote

Neanche io avevo quel file, e infatti ho provveduto manualmente con le istruzioni di djinnz e quelle trovate nella documentazione ufficiale
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Mar 27, 2009 11:48 am    Post subject: Reply with quote

Il problema è che nella documentazione ufficiale non è specificato,
Quote:
These are typically set in the /etc/env.d/02locale
probabilmente dovena essere
Quote:
These are typically to set in the /etc/env.d/02locale
o meglio doveva essere inserito nello stage 3 un file di esempio, ma il file va creato a manina.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
fabiolino
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2006
Posts: 103
Location: bologna

PostPosted: Fri Mar 27, 2009 9:58 pm    Post subject: Reply with quote

Ho impostato a manina in /etc/env.d/02locale:
Code:

LANG="it_IT.utf8@euro"
LC_ALL="it_IT.UTF-8"

Adesso va' 8)
_________________
http://www.fabiospadaro.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum