Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KVM] FATAL: Module kvm_intel not found.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Mon Oct 06, 2008 2:59 pm    Post subject: [KVM] FATAL: Module kvm_intel not found. Reply with quote

Bsr,


J'ai un pti souci apres un modprobe kvm ou kvm-intel, il n'arrive pas a trouver le module pourtant je l'ai:

Quote:
/lib/modules/2.6.26.5/kvm
jerem-laptop kvm # ls -la
total 276
drwxr-xr-x 2 root root 55 Oct 6 17:37 .
drwxr-xr-x 6 root root 4096 Oct 6 17:37 ..
-rwxr-xr-x 1 root root 36664 Oct 6 17:37 kvm-amd.ko
-rwxr-xr-x 1 root root 56224 Oct 6 17:37 kvm-intel.ko
-rwxr-xr-x 1 root root 182656 Oct 6 17:37 kvm.ko





j'ai fais un emerge:

Quote:
[ebuild R ] app-emulation/kvm-75 USE="alsa modules ncurses sdl -esd -gnutls -havekernel -pulseaudio -test -vde" 0 kB



Quote:
erem-laptop jerem # modprobe "kvm-intel"
FATAL: Module kvm_intel not found.
jerem-laptop jerem # modprobe kvm
FATAL: Module kvm not found.


jerem-laptop jerem # uname -r
2.6.26.5



je soupsonne un mauvais alias mais je ne sais pas quoi changer


voila le strace:
Quote:

jerem-laptop kvm # strace modprobe "kvm-intel"
execve("/sbin/modprobe", ["modprobe", "kvm-intel"], [/* 53 vars */]) = 0
brk(0) = 0x1d18000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80e3000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80e2000
access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=116806, ...}) = 0
mmap(NULL, 116806, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7fe8e80c5000
close(3) = 0
open("/lib/libz.so.1", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\20 \0\0\0\0\0\0@"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=88368, ...}) = 0
mmap(NULL, 2183664, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7fe8e7cb2000
mprotect(0x7fe8e7cc7000, 2093056, PROT_NONE) = 0
mmap(0x7fe8e7ec6000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x14000) = 0x7fe8e7ec6000
close(3) = 0
open("/lib/libc.so.6", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\240\345\1\0\0\0\0\0@"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1383600, ...}) = 0
mmap(NULL, 3490456, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7fe8e795d000
mprotect(0x7fe8e7aa8000, 2097152, PROT_NONE) = 0
mmap(0x7fe8e7ca8000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x14b000) = 0x7fe8e7ca8000
mmap(0x7fe8e7cad000, 17048, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7fe8e7cad000
close(3) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80c4000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80c3000
arch_prctl(ARCH_SET_FS, 0x7fe8e80c36f0) = 0
mprotect(0x7fe8e7ca8000, 16384, PROT_READ) = 0
mprotect(0x7fe8e7ec6000, 4096, PROT_READ) = 0
mprotect(0x606000, 4096, PROT_READ) = 0
mprotect(0x7fe8e80e4000, 4096, PROT_READ) = 0
munmap(0x7fe8e80c5000, 116806) = 0
create_module(NULL, 0) = -1 ENOSYS (Function not implemented)
uname({sys="Linux", node="jerem-laptop", ...}) = 0
fstat(2, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 1), ...}) = 0
brk(0) = 0x1d18000
brk(0x1d39000) = 0x1d39000
open("/etc/modprobe.conf", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = -1 ENOTDIR (Not a directory)
open("/etc/modprobe.conf", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=6405, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80e1000
read(3, "### This file is automatically ge"..., 4096) = 4096
read(3, "5\n\n\n# Configurable module paramet"..., 4096) = 2309
read(3, ""..., 4096) = 0
close(3) = 0
munmap(0x7fe8e80e1000, 4096) = 0
open("/lib/modules/2.6.26.5/modules.dep", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=3710, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80e1000
read(3, "/lib/modules/2.6.26.5/video/nvidi"..., 4096) = 3710
read(3, ""..., 4096) = 0
close(3) = 0
munmap(0x7fe8e80e1000, 4096) = 0
open("/lib/modules/2.6.26.5/modules.alias", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = -1 ENOTDIR (Not a directory)
open("/lib/modules/2.6.26.5/modules.alias", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=3306, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe8e80e1000
read(3, "# Aliases extracted from modules "..., 4096) = 3306
read(3, ""..., 4096) = 0
close(3) = 0
munmap(0x7fe8e80e1000, 4096) = 0
write(2, "FATAL: Module kvm_intel not found"..., 35FATAL: Module kvm_intel not found.
) = 35
exit_group(1) = ?



merci
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Mon Oct 06, 2008 8:54 pm    Post subject: Reply with quote

Salut,

Quote:
je soupsonne un mauvais alias mais je ne sais pas quoi changer

Regarde si tu as quelque chose à propos de kvm dans /etc/modprobe.d
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Tue Oct 07, 2008 10:32 am    Post subject: Reply with quote

qu'est ce que donne la commande :

Code:
find /lib/modules/[b]`uname -r `[/b] -iname "*.ko" |grep kvm
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Oct 07, 2008 11:31 am    Post subject: Reply with quote

J'ai eu le même problème avec le smodules du paquet, il fallait que je les charge avec insmod kvm.ko et insmod kvm_intel.ko (une fois ans le repertoire /lib/modules/versiondukernel/kvm/)

Bon, au final, ça marche pas mais c'est un autre problème vu que ça fait pareil avec les modules du noyau. Qemu se lançait quand même, sans aucune erreur, avec cette méthode.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum