Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VM e Border Manager [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ginsoak
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2005
Posts: 139
Location: Pisa - Italy

PostPosted: Mon Sep 29, 2008 4:55 am    Post subject: VM e Border Manager [risolto] Reply with quote

Ciao,
sto cercando di installare una macchina virtuale gentoo (su un sistema Suse) in una rete gestita con Novell Border Manager.
La rete risponde, riesco a pingare google, ma non riesco a impostare il proxy.
Un problema è che nella password del proxy c'è un carattere "@" che disturba, ma ho letto in giro che posso bypassare il problema usando la codifica URL %40.
export http_proxy="user:passwd@addr:port" è il comando che uso.
Qualcuno sa darmi un consiglio?


Last edited by ginsoak on Thu Oct 02, 2008 2:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Tue Sep 30, 2008 3:46 pm    Post subject: Re: VM e Border Manager Reply with quote

ginsoak wrote:
Un problema è che nella password del proxy c'è un carattere "@" che disturba, ma ho letto in giro che posso bypassare il problema usando la codifica URL %40.
export http_proxy="user:passwd@addr:port" è il comando che uso.


Non ho capito: oltre ad aver letto del workaround per '@', lo hai anche provato e ancora non va?
_________________
Ciao da me!
Back to top
View user's profile Send private message
ginsoak
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2005
Posts: 139
Location: Pisa - Italy

PostPosted: Wed Oct 01, 2008 12:09 pm    Post subject: Reply with quote

esatto, non va e penso che il problema sia che border manager invia un certificato: con un browser come firefox non ci sono problemi, ma wget o links non riescono a visualizzare tale richiesta. wget con l'opzione --no-check-certificate non funziona ugualmente. la soluzione che ho trovato è quella di scaricare manualmente i pacchetti del kernel (al di fuori dell'installazione di gentoo, per intenderci), buttarli in /usr/portage/distfiles, compilare il kernel col supporto a ncpfs e quindi effettuare la connessione al border manager con cl4others. a questo punto border manager verrà escluso e potrò usare la rete. in questo momento sto compilando il kernel, se ti interessa ti faccio sapere come va a finire!
Back to top
View user's profile Send private message
ginsoak
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2005
Posts: 139
Location: Pisa - Italy

PostPosted: Wed Oct 01, 2008 6:55 pm    Post subject: Reply with quote

ok funziona, ma il problema col proxy rimane...
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Oct 02, 2008 10:53 am    Post subject: Reply with quote

ginsoak wrote:
ok funziona, ma il problema col proxy rimane...


Ricapitoliamo.

Con firefox funziona, con wget e links no. E' il caso di circoscrivere l'errore per vedere a cosa é dovuto.

Prova manualmente a usare wget e controlla cosa restituisce ("penso che il problema sia che border manager invia un certificato" non é sufficiente, se é il certificato di una connessione https wget dovrebbe gestirlo).
Prova anche passando manualmente anche user e passwd del proxy.
_________________
Ciao da me!
Back to top
View user's profile Send private message
ginsoak
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2005
Posts: 139
Location: Pisa - Italy

PostPosted: Thu Oct 02, 2008 1:59 pm    Post subject: Reply with quote

Firefox lo uso sotto un altro ambiente. Ora ho una macchina virtuale con gentoo installato correttamente, il kernel compilato col modulo ncpfs e il client cl4others per il login al border manager. Monto i volumi di novell correttamente ed eseguo il login al border manager con cl4others (passandogli username e password). a questo punto dovrebbe essere sufficiente impostare le variabili per il proxy (senza username e password, perchè border manager dovrebbe gia riconoscermi) e tutto dovrebbe funzionare (così come funziona sulle altre macchine linux che ho configurato), invece appena lancio wget google.it il client cl4oterhs risponde "Could not send NCPX Packet" e wget sta li aspettando una risposta dal proxy.
Back to top
View user's profile Send private message
ginsoak
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2005
Posts: 139
Location: Pisa - Italy

PostPosted: Thu Oct 02, 2008 2:28 pm    Post subject: Reply with quote

effettuando il login ad un secondo volume novell ho risolto. resta da capire il motivo, visto che in altri ambienti è indifferente il volume a cui ci si connette...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum