Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] impossible de faire une mise a jour
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
donald7
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 136

PostPosted: Sun Sep 21, 2008 9:47 am    Post subject: [emerge] impossible de faire une mise a jour Reply with quote

bonjour

emerge ne veut pas faire les mises a jour, mais je ne comprends ce qui bloque. J'ai désinstallé qca mais cela ne change rien

Code:
gentoo donald # emerge -aDNtuv world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[ebuild     U ] app-emulation/wine-1.1.2 [1.1.0] USE="X alsa cups gecko hal jpeg ncurses opengl scanner -dbus -esd -jack -lcms -ldap -nas -oss -samba -xml" 13,748 kB
[ebuild     U ] kde-misc/kdirstat-2.5.3-r1 [2.4.4] USE="-debug -xinerama (-arts%)" 662 kB
[nomerge      ] kde-base/kopete-3.5.9  USE="crypt ssl -addbookmarks -alias -arts -autoreplace -connectionstatus -contactnotes -debug -gadu -groupwise -highlight -history -irc -jingle -kdeenablefinal -kdehiddenvisibility -latex -netmeeting -nowlistening -sametime -slp -sms -statistics -texteffect -translator -webpresence -winpopup -xinerama -xscreensaver -yahoo"
[nomerge      ]  app-crypt/qca-tls-1.0-r3  [?]
[ebuild  N    ]   app-crypt/qca-2.0.0-r2  USE="-debug -doc -examples" 0 kB
[ebuild  N    ]  app-crypt/qca-1.0-r2  0 kB
[nomerge      ] sys-devel/autoconf-2.61-r2  USE="-emacs"
[ebuild     U ]  sys-devel/autoconf-wrapper-5 [4-r3] 0 kB
[blocks B     ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Total: 5 packages (3 upgrades, 2 new, 1 block), Size of downloads: 14,409 kB
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



Quote:



gentoo donald # emerge --unmerge app-crypt/qca

--- Couldn't find 'app-crypt/qca' to unmerge.

>>> No packages selected for removal by unmerge
gentoo etienne #


une idée ? :(
_________________
Linux Counter #433775

Visitez et contribuez au site gnulinux.fr


Last edited by donald7 on Mon Sep 22, 2008 11:39 am; edited 1 time in total
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Sun Sep 21, 2008 10:37 am    Post subject: Reply with quote

salut,

dans la proposition d'emerge, tu peux voir que les deux paquets qca veulent s'installer.
il suffit de msquer celui que tu ne veux pas ;) ( /etc/portage/package.mask)
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Sep 21, 2008 8:41 pm    Post subject: Reply with quote

Si tu pouvais utilisais la balise [code] pour qu'on puisse lire l'arbre des dépendances correctement ce serait pas mal. Tu précises pas, mais je suppose que tu esen ~arch vu que qca-2 est en ~arch. Et c'est quoi cet overlay qui contient qca-tls ?
Back to top
View user's profile Send private message
donald7
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 136

PostPosted: Mon Sep 22, 2008 11:41 am    Post subject: Reply with quote

bon j'ai vu qu'il y a ici un rapport de bug

j'ai changé la balise quote en code de mon post initial

j'ai mis >app-crypt/qca-1.0-r3 dans /etc/portage/package.mask, ce qui m'a permis de faire mes mises a jour

et je vais attendre que le bug soit corrigé :?
_________________
Linux Counter #433775

Visitez et contribuez au site gnulinux.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum