Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[?RISOLTO?] Errore dhcpcd
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Fri Sep 19, 2008 8:10 am    Post subject: [?RISOLTO?] Errore dhcpcd Reply with quote

Questa mattina ho avuto una bella sorpresa; ho acceso il PC e... non finiva la sequenza di boot.
Per essere più precisi dhcpcd non riesce ad acquisire correttamente l'indirizzo di rete e rimane bloccato emettendo continuamente il seguente messaggio:
Code:

err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)
err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)
err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)


Impostando i parametri di rete a mano tutto funziona, qualcuno ha un'idea?

Versione di dhcpcd:
net-misc/dhcpcd-3.2.3
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500


Last edited by falko on Sat Sep 27, 2008 8:15 am; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Sep 19, 2008 9:17 am    Post subject: Reply with quote

puoi postare la tua configurazione di net?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Fri Sep 19, 2008 10:03 am    Post subject: Reply with quote

Code:

modules=("udhcpc")
config_eth0=("dhcp")
dhcpcd_eth0="-t 5"

# Configurazione scheda wireless con wpa supplicant
modules=( "wpa_supplicant" )
#wpa_supplicant_eth1="-Dmadwifi"
#wpa_supplicant_eth1="-Dwext"
wpa_supplicant_eth1="-Dwext -ieth1 -c/etc/wpa_supplicant/wpa_supplicant.conf"
config_eth1=( "dhcp" )
dhcp_eth1="nontp nonis"
depend_eth1(){
        need ipw3945d
}
associate_timeout_eth1=60

# Configurazione connessione ADSL (over Ethernet)
#config_eth0=( "null" )
config_ppp0=( "ppp" )
link_ppp0="eth0"
plugins_ppp0=( "pppoe" )

username_ppp0='aliceadsl'
password_ppp0='aliceadsl'

pppd_ppp0=(
    "noauth"
    "defaultroute"
    "usepeerdns"
    "default-asyncmap"
    "ipcp-accept-remote"
    "ipcp-accept-local"
    "lcp-echo-interval 15"
    "lcp-echo-failure 3"
    "mru 1492"
    "mtu 1492"
    "debug"
)

_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Sep 19, 2008 10:20 am    Post subject: Re: Errore dhcpcd Reply with quote

falko wrote:
Impostando i parametri di rete a mano tutto funziona, qualcuno ha un'idea?

intendi dire dando ifconfig eth0 etc etc?
hai provato a startare dhcpcd eth0 a mano?

facendo una veloce ricerca, il problema potrebbe essere multiplo
c'è anche un bug aperto riguardante dhcpcd 3.1.3 dove compare questo errore
https://bugs.gentoo.org/show_bug.cgi?id=188028

provato a spegnere e riaccendere la scheda?
oppure riavviare sotto windows (se ce l'hai) e poi riavviare sotto linux? a volte certi driver bastardi resettano qualche parametro... è solo un'idea, niente di certo.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Fri Sep 19, 2008 12:05 pm    Post subject: Reply with quote

Code:

dhcpcd eth0
err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)
err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)
err, eth0: ARPOP_REPLY received from 10.10.26.230 (00:06:b1:29:a3:58)
....


L'avevo visto anche io quel bug ma è relativo alla versione 3.1.3 ed è segnato come risolto.
Comunque la cosa strana è che io non l'avevo aggiornato e aveva sempre funzionato
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Fri Sep 19, 2008 12:50 pm    Post subject: Reply with quote

Magari non centra nulla, ma non mi convince quel module(udhcp) perchè teoricamente quella direttiva sta a segnalare a gentoo di usare udhcp anzichè dhcpcd. Puoi provare a commentare tale direttiva e riprovare ?
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Fri Sep 19, 2008 1:27 pm    Post subject: Reply with quote

No, il risultato è lo stesso
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Sat Sep 27, 2008 8:14 am    Post subject: Reply with quote

Non so cosa possa aver avuto di strano, ma adesso dhcpcd ha ripreso a funzionare 8O, non ho ne ricompilato ne aggiornato il pacchetto (non avendo usato gentoo per tutta la settimana) e adesso non da alcun problema
bha! 8O 8O 8O
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum