Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con neon e revdep-rebuild
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Sep 17, 2008 7:04 pm    Post subject: Problema con neon e revdep-rebuild Reply with quote

Salve a tutti,

ho un problema che ho scoperto facendo un revdep-rebuild.
Alla fine del calcolo delle dipendenze da riemergere mi vuole riemergere rpm2targz e rpm, e per finire neon.
Il problema è che una volta finito, quando rilancio revdep-rebuild per vedere se tutto è a posto, viene fuori che manca la libreria libneon.so.27.
Dunque riparte con l'emerge ma una volta che ha finito mi dice che l'aggiornamento di neon può portare problemi causati dal fatto che altri programmi ancora non usano le librerie di neon aggiornate, quindi consigliano di fare un
Code:
emerge --oneshot '<net-misc/neon-0.28'
.

Quote:
* Neon has a policy of breaking API across minor versions, this means
* that any package that links against neon may be broken after
* updating. They will remain broken until they are ported to the
* new API. You can downgrade neon to the previous version by doing:
*
* emerge --oneshot '<net-misc/neon-0.28'
*


Dunque se non lo faccio mi emerge neon-0.28.3, rpm e rpm2targz. Rifaccio revdep-rebuild e quando finisce lo faccio di nuovo.
Ed ecco cosa esce:
Code:
 broken /usr/bin/svn (requires  libneon.so.26)
  broken /usr/bin/svnsync (requires  libneon.so.26)
  broken /usr/bin/svnversion (requires  libneon.so.26)
  broken /usr/lib/libsvn_ra_dav-1.so.0.0.0 (requires  libneon.so.26)

E vuole riemergere: =dev-util/subversion-1.4.6 =dev-util/xxdiff-3.2-r1.
Ok, glielo faccio fare... ed ecco cosa esce:
Code:
 broken /usr/bin/rpm (requires  libneon.so.27)
  broken /usr/bin/rpm2cpio (requires  libneon.so.27)
  broken /usr/bin/rpmgraph (requires  libneon.so.27)
  broken /usr/lib/librpmio-4.4.so (requires  libneon.so.27)
  broken /usr/lib/rpm/javadeps (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmb (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmcache (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmd (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_archive (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_checkpoint (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_deadlock (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_dump (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_load (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_printlog (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_recover (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_stat (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_svc (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_upgrade (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdb_verify (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmdeps (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmfile (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmi (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmk (requires  libneon.so.27)
  broken /usr/lib/rpm/rpmq (requires  libneon.so.27)

Vado avanti con il rebuild... e mi emerge =app-arch/rpm2targz-9.0-r6 =app-arch/rpm-4.4.6-r6.
Faccio di nuovo revdep-rebuild e ...
Code:
broken /usr/bin/svn (requires  libneon.so.26)
  broken /usr/bin/svnsync (requires  libneon.so.26)
  broken /usr/bin/svnversion (requires  libneon.so.26)
  broken /usr/lib/libsvn_ra_dav-1.so.0.0.0 (requires  libneon.so.26)
e vuole di nuovo emergere =dev-util/subversion-1.4.6 =dev-util/xxdiff-3.2-r1 ...

e si ricomincia..

C'è un modo per risolvere?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum