Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemino con samba: nessun client scrive!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Mon Sep 15, 2008 12:57 pm    Post subject: problemino con samba: nessun client scrive! Reply with quote

ciao a tutti ragazzi! come ben sapete ho messo da poco sul mio portatile Gentoo 2008.0 e devo dire che mi trovo benissimo! è un sistema stupendo personalizzabile al 100% quasi e con il quale si può imparare veramente cos'è il sistema linux e piu in generale i sistemi based unix.
da poco ho anche installato il famoso demone samba per instaurare una condivisione tra il mio portatile con Gentoo (che è il server della rete) e i miei altri pc windows. grazie al vostro aiuto sono riuscito a creare la rete e anche a far vedere sia la stampante condivisa che le cartelle nei diversi client. ora sorge il problema: volevo prendere i relativi driver windows per la stampante da mettere sul cups in modo da scaricarli automaticamente alla connessione di ogni client..ma mentre provo a copiare nella cartella condivisa tutti i driver mi da un'errore che dice che in pratica il disco sul quale vorrei scrivere è pieno o protetto da scrittura, il che fondamentalmente era vero finchè i permessi erano settati male, ma questo accade anche se chmoddo con permessi a 777 la directory e tutte le sottodirectory..mi sembra una cosa molto strana..cosa potete consigliarmi? il mio smb.conf l'ho gia postato qui quindi senza che ve lo riposto potete leggerlo nella prima risposta. per il resto se serve qualcosaltro non esitate a chiedere sono a disposizione grazie a tutti anticipatamente :wink:
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Mon Sep 15, 2008 3:27 pm    Post subject: Reply with quote

se è questa la sezione che ti riferisci
Code:

[public]
comment = Public Files
browseable = yes
public = yes
create mode = 0766
guest ok = yes
path = /home/samba/public


io la cambierei in
Code:

[public]
comment = Public Files
public = yes
writable = yes
path = /home/samba/public

così avresti che tutti possono accedere in lettura e scrittura senza bisogno di inserire password

oppure...
Code:

[public]
comment = Public Files
public = no
writable = yes
valid users = <utente>
path = /home/samba/public

In questo caso solo <utente> potrebbe accedervi (mediante password impostata con il tool di samba) e logicamente i file avrebbero come owner
l'utente <utente>
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Mon Sep 15, 2008 8:30 pm    Post subject: Reply with quote

ho provato come dici tu ma dando un testparm mi da questo output
Code:
Goran gion # testparm
Load smb config files from /etc/samba/smb.conf
Unknown parameter encountered: "valid user"
Ignoring unknown parameter "valid user"
Processing section "[print$]"
Unknown parameter encountered: "valid user"
Ignoring unknown parameter "valid user"
Processing section "[HP_LaserJet_1020]"
Unknown parameter encountered: "valid user"
Ignoring unknown parameter "valid user"
Processing section "[printers]"
Unknown parameter encountered: "valid user"
Ignoring unknown parameter "valid user"
Processing section "[public]"
Unknown parameter encountered: "valid user"
Ignoring unknown parameter "valid user"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
mentre se metto le opzioni public = yes writable = yes senza pass e user va tutto ok..c'è qualcosa che posso fare per renderla accedibile solo tramite user? grazie comunque dell'aiuto


EDIT: errore mio la variabile giusta era valid users..ora provo e vi fccio sapere
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Tue Sep 16, 2008 1:14 pm    Post subject: Reply with quote

ecco ho provato con la variabile valid users e me l'accetta tutto ok. il client che ho settato scrive e tutto senza problemi e accede solo tramite password. sorge un problema però: sul pc windows se provo a cliccare sull'opzione "visualizza computer del gruppo di lavoro" mi da accesso negato dicendo che nn dispongo delle autorizzazioni necessarie e neppure facendo il login con l'user settato mi ci fa andare..quale potrebbe essere il problema? ho provato a vede se era una storia di permessi che l'user non aveva..ma anche accedendo da root mi da lo stesso errore nononstante nell'smb.conf abbia aggiunto nei valid user l'utente root scrivendo
Code:
valid users = gion , root
ma niente..correggetemi se ho sbagliato..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum