Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GNOME] Messages d'erreurs en allumant l'ordi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Sun Sep 07, 2008 10:13 am    Post subject: [GNOME] Messages d'erreurs en allumant l'ordi Reply with quote

Bonjour,

Lorsque que j'ai allumé l'ordi, des messages d'erreurs sont apparues disant que GNOME ne gère pas certains trucs (pourtant GNOME est installé depuis beacoup de temps). J'ai essayé de faire un 'emerge -av gnome' mais une erreur dit que libxml2 n'a pas été trouvé (en gros). Je l'ai donc installé mais rien n'y fait. J'ai ensuite fait un 'python-updater -v' pour l'allumer mais le paquet d'épiphany est masqué par rien du tout. J'ai donc fait un 'emerge --sync' mais la même erreur survient.

Que puis-je faire ?

Merci d'avance,
Damiatux

PS : voici un screen de la première fois que j'ai eu les messages : http://img60.imageshack.us/img60/4859/captureou1.png et de maintenant : http://img5.xooimage.com/files/4/9/e/capture-5-637885.png

PS 2 : ce sont les tableaux de bords qui bugent...
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Sep 07, 2008 5:52 pm    Post subject: Reply with quote

Tu as essayé revdep-rebuild ?
Essayes de recompiler gnome-settings-daemon vu que c'est lui qui plante.
Tu peux aussi essayé de voir si ça vient de ta config en lançant gnome un autre utilisateur.

Enfin, XMMS, ça craint !
Back to top
View user's profile Send private message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Sun Sep 07, 2008 6:05 pm    Post subject: Reply with quote

Non je n'ai pas essayé. J'ai déjà essayé avec un autre utilisateur mais toujours le même problème.

Pourquoi ça craint XMMS ?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Sep 07, 2008 6:14 pm    Post subject: Reply with quote

Parce que c'est vieux, déprécié, plus maintenu, et que ça utilise gtk 1 qui est vieux, déprécié et plus maintenu.
Back to top
View user's profile Send private message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Sun Sep 07, 2008 6:19 pm    Post subject: Reply with quote

Tu me conseil quoi ?

Le 'revdep-rebuild' trouve un paquet masqué par rien... Même si je mets mon système à jour, ça ne marche pas...


Last edited by Damiatux on Sun Sep 07, 2008 7:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Sun Sep 07, 2008 6:57 pm    Post subject: Reply with quote

Utilise audacious (dans Portage) à la place de XMMS. Tu as tout à y gagner (notamment une inteface graphique en GTK2 et le support de l'UTF-8).
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Mon Sep 08, 2008 5:28 pm    Post subject: Reply with quote

Oui audacious qui ressemble beaucoup.

Sinon, tu as essayé de réinstallé gnome-settings-daemon ?

Et le paquet que revdep-rebuild donne c'est quoi ? comment ça il est masqué ?
Back to top
View user's profile Send private message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Mon Sep 08, 2008 6:00 pm    Post subject: Reply with quote

Voici tout le truc de revdep-rebuild :
Code:
# revdep-rebuild
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... using existing /root/.revdep-rebuild.1_files.

Collecting complete LD_LIBRARY_PATH... using existing /root/.revdep-rebuild.2_ldpath.

Checking dynamic linking consistency... using existing /root/.revdep-rebuild.3_rebuild.

Assigning files to ebuilds... using existing /root/.revdep-rebuild.4_ebuilds.

Evaluating package order... using existing /root/.revdep-rebuild.5_order.

All prepared. Starting rebuild...
emerge --oneshot  =app-cdr/cdrdao-1.2.1-r1 =app-text/evince-0.8.3 =dev-cpp/libglademm-2.6.1 =dev-cpp/libgnomecanvasmm-2.12.0 =dev-cpp/libgnomemm-2.12.0 =dev-cpp/libgnomeuimm-2.12.0 =dev-python/gnome-python-desktop-2.18.0 =gnome-base/gnome-panel-2.18.3 =gnome-extra/bug-buddy-2.18.1 =gnome-extra/gnome-power-manager-2.18.3 =gnome-extra/gnome-screensaver-2.18.2-r1 =gnome-extra/gnome-system-monitor-2.18.2 =mail-client/evolution-2.10.2 =media-video/vlc-0.8.6-r1 =net-libs/libsoup-2.2.100 =net-libs/xulrunner-1.9.0.1 =sys-apps/apmd-3.2.1_p4 =sys-power/cpufreqd-2.1.1 =x11-misc/notification-daemon-0.3.6-r1
..........
Calculating dependencies |
!!! All ebuilds that could satisfy "=app-text/evince-0.8.3" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/evince-0.8.3 (masked by: )

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*
L'installation de gnome-settings-daemon marche très bien.
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Tue Sep 09, 2008 1:38 pm    Post subject: Reply with quote

Salut, fait voir ton emerge --info stp. IL y a dans le résultat de revdep-rebuild (qui n'est pas un truc:p)) des versions de libraires très anciennes.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Wed Sep 10, 2008 10:35 am    Post subject: Reply with quote

Code:
revdep-rebuild -X -i

Me semble que c'est -X pour virer les numéros de versions dans les vieilles versions de revdep-rebuild.
Tu as mis ton système à jour ? emerge --update --deep --newuse --ask --verbose world ?
Back to top
View user's profile Send private message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Thu Sep 11, 2008 4:50 pm    Post subject: Reply with quote

Voilà mon emerge --info :
Code:
Portage 2.1.4.4 (hardened/linux/x86, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4-sata i686)
=================================================================
System uname: 2.6.21-gentoo-r4-sata i686 Intel(R) Pentium(R) M processor 1.73GHz
Timestamp of tree: Sun, 07 Sep 2008 12:36:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa avi berkdb cdda cddb cdparanoia cdr cli cracklib crypt cups dri dts dvd dvdr dvdread emacs ffmpeg firefox foomaticdb freetype gif gimpprint gnome gpm gtk gtk2 hardened iconv isdnlog jabber java jpeg live midi mmx mp3 mpeg msnbzip2 mtrr mudflap ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl openmp pam pcre perl pic png ppds pppd python readline reflection screen sdl session skins spl sqlite sse ssl stream svg tcpd theora truetype unicode urandom vorbis win32codecs wxwindows x86 xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse speedo xtt" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="radeon vesa vga fbdev fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


Si je mets mon système à jour, j'ai encore droit à des erreurs...
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Fri Sep 12, 2008 11:43 am    Post subject: Reply with quote

tu as mis ton système à jour ?
refait
Code:
revdep-rebuild -i -X


Ton système d'avant n'était probablement pas à jour vu la présence de evince 0.8.3 qui date d'il y a très longtemps. (chez moi ça fait un que j'ai une version plus récente)

Tu mets ton système à jour comment ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum