Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE freeze] Ati-Drivers 8.40.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nelsooon
n00b
n00b


Joined: 08 Aug 2004
Posts: 68

PostPosted: Sun Dec 09, 2007 9:09 am    Post subject: [KDE freeze] Ati-Drivers 8.40.4 Reply with quote

Salut,
J'ai voulu passer avec les drivers ati-drivers-8.40.4 sous ma gentoo-2.6.23-r3.
quand je les emerge, tout est ok.
Je fais eselect opengl set ati
puis si je fais:
Code:

Gentoo adel # modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.23.9/video/fglrx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Gentoo adel #     


Voici le contenu de dmesg:
Code:

Dec  8 23:54:12 Gentoo fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
Dec  8 23:54:12 Gentoo fglrx: Unknown symbol refrigerator
Dec  8 23:54:12 Gentoo fglrx: Unknown symbol kmap
Dec  8 23:54:12 Gentoo fglrx: Unknown symbol kunmap
Dec  8 23:54:12 Gentoo fglrx: Unknown symbol page_address

Puis quand je mets les drivers fglrx dans xorg.conf, KDE demarre, mais dès que je vois la souris, ça freeze.
mon noyau 2.6.23-r3 est compilé avec les mêmes parametres que le 2.6.22-r9, pourtant le vieux fonctionne tres bien avec ces drivers.
J'ai un IBM Thinkpad T43, Ati Radeon X300. Gentoo Updated at all latest stable versions.
Config noyau:
Code:

Device Drivers --> Graphic Supports >
<M>   ATI Radeon display support                                                                               
        [*]     DDC/I2C for ATI Radeon support                                                                         
        [*]     Support for backlight control                                                                           
        [ ]     Lots of debug output from Radeon driver   

et
 Device Drivers --> Character Devices >
<M> /dev/agpgart (AGP Support)                                                                                 
       < >   ALI chipset support                                                                                       
       <M>   ATI chipset support                                                                                     
       < >   AMD Irongate, 761, and 762 chipset support                                                               
      ....
      < > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)                 



Des idées ?
merci
Back to top
View user's profile Send private message
BitPit
n00b
n00b


Joined: 10 Jun 2003
Posts: 10
Location: Austin, TX

PostPosted: Mon Sep 08, 2008 4:54 pm    Post subject: Reply with quote

Sorry, I don't know French :-(

The key seems to be "Unknown symbol refrigerator".

It occurred when I recompiled my kernel after modifying ".config".

It is fixed by "emerge ati-drivers" with /usr/src/linux linked to that kernel.

Good Luck
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum