Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Apache] URL rewriting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Thu Aug 28, 2008 9:40 pm    Post subject: [Apache] URL rewriting Reply with quote

Bonsoir,

J'aimerais utiliser l'URL rewriting sous Apache. Dans mon httpd.conf, j'ai :
Code:
LoadModule rewrite_module modules/mod_rewrite.so

Dans les autres fichiers de configuration (00_default_settings.conf et 00_error_documents.conf), j'ai remplacé AllowOverride None par AllowOverride All.

Or pour les pages présentes dans mon répertoire public_html local, j'obtiens une errer 404. Je ne sais pas ce qui manque. Qui peut m'aider ?
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Fri Aug 29, 2008 9:01 am    Post subject: Reply with quote

ça manque d'information là, le contenu de tes fichiers .htaccess par exemple ?
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Sep 03, 2008 6:13 pm    Post subject: Reply with quote

NEOxAKIRA wrote:
ça manque d'information là, le contenu de tes fichiers .htaccess par exemple ?

Le problème ne vient pas du .htaccess qui fonctionne très bien chez mon hébergeur mais de la configuration d'Apache.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
adjaxio
n00b
n00b


Joined: 06 Mar 2006
Posts: 54

PostPosted: Thu Sep 04, 2008 10:13 am    Post subject: Reply with quote

Neuromancien wrote:
NEOxAKIRA wrote:
ça manque d'information là, le contenu de tes fichiers .htaccess par exemple ?

Le problème ne vient pas du .htaccess qui fonctionne très bien chez mon hébergeur mais de la configuration d'Apache.


Bonjour,

a tu compiler apache avec le support de l'URL Rewriting ?

Bye
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Sep 10, 2008 7:03 pm    Post subject: Reply with quote

adjaxio wrote:
Neuromancien wrote:
NEOxAKIRA wrote:
ça manque d'information là, le contenu de tes fichiers .htaccess par exemple ?

Le problème ne vient pas du .htaccess qui fonctionne très bien chez mon hébergeur mais de la configuration d'Apache.


Bonjour,

a tu compiler apache avec le support de l'URL Rewriting ?

Bye

Oui.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Oct 08, 2008 7:40 pm    Post subject: Reply with quote

Personne n'a une idée ? Il s'agit d'un problème de configuration de Apache chez moi, mais je ne trouve pas ce qui cloche...
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Jamesbch
Apprentice
Apprentice


Joined: 30 Sep 2007
Posts: 185

PostPosted: Fri Oct 10, 2008 10:00 pm    Post subject: Reply with quote

Salut,

peut-être que tu devrais poster ton fichier de configuration (00_default_*). En tout cas chez moi je n'ai pas modifié 00_error_documents.conf (restaure-le si tu peux).
Dans mon 00_default_settings.conf j'ai ceci d'intéressant :

Code:
<Directory />
        Options FollowSymLinks
        AllowOverride All
</Directory>


Il s'applique donc à tout le site en question. T'as bien le module apache "rewrite" d'activé dans portage ? T'as regardé les logs pour savoir si ça cloche (/var/log/apache2/error_log) ? Sinon le reste à l'air bon.

Bonne chance.
_________________
Desktop: Gigabyte EX38-DS4, Intel Q9450 2.6 GHz, 4 GiB DDR2, Nnvidia GTX 285.
Home-Server: Gigabyte 945GCM-S2L, Intel E2180 2.2 GHz, 2 GiB DDR2, Intel 82945G.
Laptop: Asus 1215N, Atom D525 1.4 Ghz, 2 GiB, Intel + Ion2
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Wed Oct 15, 2008 10:10 pm    Post subject: Reply with quote

Je confirme il faut que tu mette au moins ce que dit Jamesbch

Pour ma part j'ai ça et ça fonctionne
/etc/apache2/modules.d/00_default_settings.conf wrote:

...
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>
...


bon courage
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat Aug 22, 2009 8:07 am    Post subject: Reply with quote

Bonjour,

Je pose une nouvelle fois la question car je ne parviens toujours pas à faire fonctionner l'URL rewriting avec Apache sous Gentoo.

  • Mon fichier .htaccess est correct, il fonctionne chez mon hébergeur.
  • Apache est compilé avec rewrite.
  • Dans httpd.conf, j'ai :
    Code:
    RewriteRule ^(.*)$ index.php [L]


_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Sat Aug 22, 2009 9:01 am    Post subject: Reply with quote

T'as pensé aux mods-enable et mods-available ?
J'ai jamais utilisé apache sous gentoo, mais si ça se comporte comme sous debian (je pense qu'à 99% c'est le cas) il faut renseigner /etc/apache2/mods-available/rewrite.load et faire pointer (avec un ln -s) /etc/apache2/mods-enable/rewrite.load sur /etc/apache2/mods-available/rewrite.load.
Je ne sais pas si sur gentoo la conf est exactement la même, mais il devrait y avoir une manip similaire à faire ?

J'espère que ça peut t'aider, excuse-moi d'avance si le problème n'a rien à voir :oops:
Back to top
View user's profile Send private message
Ey
l33t
l33t


Joined: 07 Apr 2005
Posts: 863
Location: Paris

PostPosted: Sat Aug 22, 2009 9:06 am    Post subject: Reply with quote

Si tu as un probleme dans ton public_html tu devrais plutot regarder les options dans 00_mod_userdir.conf
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Aug 23, 2009 1:30 pm    Post subject: Reply with quote

Ey wrote:
Si tu as un probleme dans ton public_html tu devrais plutot regarder les options dans 00_mod_userdir.conf

En effet le problème semble lié au userdir.
Pour les scripts situés dans /var/www/localhost/, l'URL rewriting fonctionne bien avec le .htaccess suivant :
Code:
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?url=$1 [L,QSA]

En revanche dans public_html, ça ne fonctionne pas :
Si le je laisse le .htaccess tel quel, je suis redirigé vers http://localhost/.
J'ai modifié la règle en mettant l'URL complète :
Code:
RewriteRule ^(.*)$ http://localhost/~mon_user/index.php?url=$1 [L,QSA]

Là, ça fonctionne à moitié. Je suis redirigé vers l'URL modifiée et ce n'est plus l'URL réécrite qui apparaît dans la barre d'adresse de mon navigateur.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum