Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[apache] 403 Forbidden (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
legabier
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 231

PostPosted: Fri Aug 22, 2008 4:57 pm    Post subject: [apache] 403 Forbidden (résolu) Reply with quote

Bonjour,

Dernièrement j'ai formaté un ubuntu pour y installer gentoo. J'ai préalablement fait une copie de sauvegarde de mes sites.
Voilà, gentoo est installé. J'ai ensuite installé apache, php, mysql et phpmyadmin.
Quand je me connecte au serveur depuis un autre ordi du LAN (avec son host ou son IP) ça fonctionne (It work!).
Même phpmyadmin, j'ai enfin réussi à le mettre à ma main, donc j'ai commencé à recréer mes utilisateurs, importer les DB...
Et là je me disais que le pire était passé, qu'il me resterait qu'à copier les /etc/apache2/vhosts.d/*.conf, mais non, finalement je bloque à l'endroit dont je n'aurais jamais supposé.

Donc pour chercher mon problème, j'ai créé /var/www/localhost/htdocs/test/, j'y ai mis des fichiers de toute sorte, php, html, jpg... Toutes mes requêtes font un 403. Pour aider, j'ai mis la signature au maximum (ServerTokens Full), tout semble être bien présent comme on peut voir.
Code:
Forbidden

You don't have permission to access / on this server.
Apache/2.2.9 (Gentoo) mod_ssl/2.2.9 OpenSSL/0.9.8g PHP/5.2.6-pl6-gentoo Server at test Port 80

On voit que là ma requête était la racine, mais j'ai essayé en ajoutant index.php et index.html dans l'url (les fichiers existaient sur le serveur évidement) et le résultat est toujours le même.
Voici la conf de mon vhost de test:
Code:
<VirtualHost *:80>
ServerAdmin webmaster@host.example.com
DocumentRoot "/var/www/localhost/htdocs/test"
ServerName test
ServerSignature On
</VirtualHost>


J'ai tenté un chown -R apache:apache /var/www mais ça ne change rien, et de toute façon le site par défaut de apache (It work!), il appartenait à root et pourtant s'affiche sans problème.

Je ne sais plus ou chercher, j'ai besoin de vos idées!

Merci!

Édit: Voici ce que dit le log:
Code:
[Fri Aug 22 14:48:17 2008] [error] [client 192.168.1.100] client denied by server configuration: /var/www/localhost/htdocs/test/
Clairement, ma config est mauvaise, quelque part ailleurs que dans mes anciens .conf je suppose puisqu'ils fonctionnaient tous avant le formatage.
_________________
Néophyte ou novice, telle est la question...


Last edited by legabier on Fri Aug 22, 2008 10:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
legabier
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 231

PostPosted: Fri Aug 22, 2008 7:12 pm    Post subject: Re: [apache] 403 Forbidden (résolu) Reply with quote

Code:
<VirtualHost *:80>
ServerAdmin webmaster@host.example.com
DocumentRoot "/var/www/localhost/htdocs/test"
ServerName test
ServerSignature On
        <Directory "/var/www/localhost/htdocs/test">
                AllowOverride None
                Options None
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>
Voilà, ça fonctionne.
Ubuntu est probablement par défaut plus permissif que Gentoo...
_________________
Néophyte ou novice, telle est la question...
Back to top
View user's profile Send private message
Poch
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2006
Posts: 105
Location: Namur, Belgique

PostPosted: Fri Aug 22, 2008 8:04 pm    Post subject: Reply with quote

Un ptit (résolu) dans le titre alors :D
Ça aidera ceux qui seront confronté au même problème dans le futur...

Merci :)
_________________
Microsoft is not the answer. Microsoft is the question. NO, is the answer.
Back to top
View user's profile Send private message
legabier
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 231

PostPosted: Fri Aug 22, 2008 10:56 pm    Post subject: Reply with quote

Poch wrote:
Un ptit (résolu) dans le titre alors :D
Ça aidera ceux qui seront confronté au même problème dans le futur...

Merci :)


Désolé, j'avais mis le "(résolu)" dans le topic de ma réplique...

Par contre, j'suis pas certain d'avoir tout résolu, j'vais devoir m'attarder longuement aux options de <Directory>.
Ça ne fonctionne pas avec tous mes sites, c'est plus compliqué avec ceux qui ont des .htaccess par exemple.
Mais le fait que ça fonctionne avec mon vhost de test me prouve que je suis dans la bonne direction. Mes sites les plus simples fonctionnent aussi.
_________________
Néophyte ou novice, telle est la question...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum