Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema con genkernel e tastiera portatile [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
marcospino
n00b
n00b


Joined: 05 Aug 2006
Posts: 12

PostPosted: Tue Aug 19, 2008 12:55 pm    Post subject: problema con genkernel e tastiera portatile [risolto] Reply with quote

salve, ho installato gentoo dal livecd 2008 su un vecchio portatile (Geo focus 200) e funziona alla grandissima.Ho quindi provato a compilarmi il kernell con genkernell (senza fare modifiche con l'opzione --menuconfig) e mi succede una cosa stranissima: ogni tanto quando avvio non funziona la tastiera (nessun tasto), mentre col kernel del live cd non sbaglia un colpo.....c'è un modo per far creare a genkernel un kernell come quello del live cd? come mai stà differenza? ciao e grazie comunque a tutti.........
_________________
marcospino


Last edited by marcospino on Tue Aug 19, 2008 5:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Aug 19, 2008 1:52 pm    Post subject: Reply with quote

Avviando con il livecd, dal chroot
Code:
zcat /proc/config.gz > /etc/kernels/kernel-config-x86-2.6.25-gentoo
presupponendo che nil percorso del tuo kernel sia /usr/src/linux-2.6.25-gentoo (in pratica sostituisci kernel-config-x86 od x64 se è il caso a linux nel nome della directory del kernel).
A quel punto genkernel con l'opzione --menuconfig (ma non noclean e nomrproper) ti consente di rifinirlo abilitando builtin controller e quanto altro ti serve.

Se le versioni del kernel sono diverse (il touchpad del mio portatile per esempio funziona perfettamente con i kernel fino alla 2.6.14 e con i kernel dalla versione 2.5.25 in poi ma con .16 .18 e .20 non ne ha mai voluto sapere di funzionare e non sono riuscito a capire perchè) però ti consiglio di provare ad usare direttamente la versione più vecchia purchè sia pari (come versione del kernel il -rnumero è di gentoo e non conta) ai linux-headers.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
marcospino
n00b
n00b


Joined: 05 Aug 2006
Posts: 12

PostPosted: Tue Aug 19, 2008 5:33 pm    Post subject: Reply with quote

grazie 1000!!! ora provo subito..
_________________
marcospino
Back to top
View user's profile Send private message
marcospino
n00b
n00b


Joined: 05 Aug 2006
Posts: 12

PostPosted: Wed Aug 20, 2008 5:12 pm    Post subject: Reply with quote

proprio come indicato il kernel 2.6.25 (come quello del live cd) funziona a meraviglia.Per curiosità ho provato il 2.6.26 (da portage, non vanilla) e si ripropone il problema della tastiera...bho.....cercherò di fare altre prove.Comunque per il momento grazie veramente , ho recuperato alla grande un vecchio portatile.
_________________
marcospino
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Aug 21, 2008 3:49 pm    Post subject: Reply with quote

marcospino wrote:
proprio come indicato il kernel 2.6.25 (come quello del live cd) funziona a meraviglia.Per curiosità ho provato il 2.6.26 (da portage, non vanilla) e si ripropone il problema della tastiera...bho.....cercherò di fare altre prove.Comunque per il momento grazie veramente , ho recuperato alla grande un vecchio portatile.


Prova a salvare il config del livecd e quello di genkernel e fai un diff dei due files per vedere cosa é abilitato nel primo che non é nel secondo ;-)
_________________
Ciao da me!
Back to top
View user's profile Send private message
marcospino
n00b
n00b


Joined: 05 Aug 2006
Posts: 12

PostPosted: Tue Aug 26, 2008 11:28 am    Post subject: Reply with quote

Grazie per il consiglio! ho quindi provato a confrontare il .config del kernel 2.6.26 creato con genlkernel grazie alle impostazioni del livecd con il .config che genkernel crea "da solo" su 2.6.26 vanilla. Da quali moduli mi consigliate di partire? (la macchina è lentuccia a compilare, anche con l'opzione --no-clean penso ci metterò delle orette...)

Quote:
marco@localhost ~/Config $ diff .config_2.6.26 .config_2.6.26-gentoo-r1
3,4c3,4
< # Linux kernel version: 2.6.26
< # Mon Aug 25 15:08:36 2008
---
> # Linux kernel version: 2.6.26-gentoo-r1
> # Fri Aug 22 15:13:22 2008
88c88,92
< # CONFIG_GROUP_SCHED is not set
---
> CONFIG_GROUP_SCHED=y
> CONFIG_FAIR_GROUP_SCHED=y
> # CONFIG_RT_GROUP_SCHED is not set
> CONFIG_USER_SCHED=y
> # CONFIG_CGROUP_SCHED is not set
204c208
< CONFIG_M686=y
---
> # CONFIG_M686 is not set
206c210
< # CONFIG_MPENTIUMIII is not set
---
> CONFIG_MPENTIUMIII=y
230d233
< CONFIG_X86_PPRO_FENCE=y
249c252
< CONFIG_PREEMPT_NONE=y
---
> # CONFIG_PREEMPT_NONE is not set
251c254,255
< # CONFIG_PREEMPT is not set
---
> CONFIG_PREEMPT=y
> # CONFIG_PREEMPT_RCU is not set
265,266c269,270
< # CONFIG_NOHIGHMEM is not set
< CONFIG_HIGHMEM4G=y
---
> CONFIG_NOHIGHMEM=y
> # CONFIG_HIGHMEM4G is not set
269c273
< CONFIG_HIGHMEM=y
---
> # CONFIG_X86_PAE is not set
287d290
< CONFIG_HIGHPTE=y
294c297
< CONFIG_HZ_100=y
---
> # CONFIG_HZ_100 is not set
297,298c300,301
< # CONFIG_HZ_1000 is not set
< CONFIG_HZ=100
---
> CONFIG_HZ_1000=y
> CONFIG_HZ=1000
301d303
< CONFIG_CRASH_DUMP=y
307d308
< CONFIG_ARCH_ENABLE_MEMORY_HOTPLUG=y
1416a1418
> CONFIG_BLK_DEV_DM_BBR=m
1770c1772
< CONFIG_HDLC_PPP=m
---
> # CONFIG_HDLC_PPP is not set
1778d1779
< CONFIG_PC300_MLPPP=y
2247c2248
< CONFIG_THERMAL=m
---
> CONFIG_THERMAL=y
2743a2745
> CONFIG_FB_CON_DECOR=y
3175a3178
> # CONFIG_MMC_SPI is not set
3384d3386
< CONFIG_PROC_VMCORE=y
3406a3409,3411
> CONFIG_SQUASHFS=y
> CONFIG_SQUASHFS_EMBEDDED=y
> CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE=3
3544a3550
> CONFIG_DEBUG_PREEMPT=y
3556d3561
< # CONFIG_DEBUG_HIGHMEM is not set

_________________
marcospino
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Aug 27, 2008 1:53 pm    Post subject: Reply with quote

se è tutto mi sa che sei nella mia stessa situazione con il 2.6.18 semplicemente questa versione del kernel ha problemi a riconoscere il tuo hardware.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum