Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth Headset
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Mon Aug 18, 2008 7:21 pm    Post subject: Bluetooth Headset Reply with quote

Hi all,

I don't know if this is the right section, but I just bought a bluetooth headset (scala 600) and it's not working on my Gentoo box.
I didn't manage to figure out the main problem, but:

- I'm able to ping the device
- I find it with a scan only if it's in discovery mode
- if I try to use it (with mplayer, for example), I get this error:
Code:
Aug 18 21:10:53 hcid[28844]: HCI dev 0 up
Aug 18 21:10:53 hcid[28844]: Device hci0 has been added
Aug 18 21:10:53 hcid[28844]: Starting security manager 0
Aug 18 21:10:53 hcid[28844]: Device hci0 has been activated
Aug 18 21:11:13 NetworkManager: <debug> [1219086673.620772] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/bluetooth_acl_a9ba11d44').
Aug 18 21:11:13 hcid[28844]: Audio API: received BT_GETCAPABILITIES_REQ
Aug 18 21:11:13 hcid[28844]: Audio API: sending BT_GETCAPABILITIES_RSP
Aug 18 21:11:13 hcid[28844]: Audio API: received BT_SETCONFIGURATION_REQ
Aug 18 21:11:13 hcid[28844]: config sco - device = 00:0A:9B:A1:1D:44 access_mode = 2
Aug 18 21:11:14 hcid[28844]: link_key_request (sba=00:1E:4C:DD:C0:0C, dba=00:0A:9B:A1:1D:44)
Aug 18 21:11:16 hcid[28844]: connect: Operation not permitted (1)
Aug 18 21:11:16 hcid[28844]: Badly formated or unrecognized command: AT+BTRH?


Code:
in other cases hcid crashes with the following message:
Aug 18 21:07:18 hcid[28754]: link_key_request (sba=00:1E:4C:DD:C0:0C, dba=00:0A:9B:A1:1D:44)                                                       
Aug 18 21:07:20 hcid[28754]: link_key_notify (sba=00:1E:4C:DD:C0:0C, dba=00:0A:9B:A1:1D:44)                                                         
Aug 18 21:07:32 hcid[28754]: Badly formated or unrecognized command: AT+BTRH?                                                                       
Aug 18 21:07:45 hcid[28754]: Audio API: received BT_GETCAPABILITIES_REQ                                                                             
Aug 18 21:07:45 hcid[28754]: Audio API: sending BT_GETCAPABILITIES_RSP                                                                             
Aug 18 21:07:45 hcid[28754]: Audio API: received BT_SETCONFIGURATION_REQ                                                                           
Aug 18 21:07:45 hcid[28754]: config sco - device = 00:0A:9B:A1:1D:44 access_mode = 2                                                               
Aug 18 21:07:45 hcid[28754]: segfault at 10 ip b7ef370e sp bf960f40 error 6 in audio.so[b7eec000+18000]                                             
Aug 18 21:07:45 hcid[28754]: connect: Operation not permitted (1)     


I'm no bluetooth expert and I can't figure out thte problem: this device is supposed to work on Linux.

By the way: I have a bluetooth mouse from Apple and it works.

This is my controller
Code:
hci0:   Type: USB
        BD Address: 00:1E:4C:DD:C0:0C ACL MTU: 1017:8 SCO MTU: 64:8
        UP RUNNING PSCAN
        RX bytes:437149 acl:26255 sco:0 events:661 errors:0
        TX bytes:13172 acl:340 sco:0 commands:300 errors:0
        Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH HOLD SNIFF PARK
        Link mode: SLAVE ACCEPT
        Name: 'BlueZ (0)'
        Class: 0x080100
        Service Classes: Capturing
        Device Class: Computer, Uncategorized
        HCI Ver: 2.0 (0x3) HCI Rev: 0x216f LMP Ver: 2.0 (0x3) LMP Subver: 0x41d8
        Manufacturer: Broadcom Corporation (15)
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Thu Aug 21, 2008 7:26 pm    Post subject: Reply with quote

Ok, I finally managed to have it working, but with bad sound quality: is there a way to improve it?

My device is a cardo scala 600
Back to top
View user's profile Send private message
Seelenfeuer
n00b
n00b


Joined: 09 Nov 2005
Posts: 73

PostPosted: Fri Oct 31, 2008 5:52 pm    Post subject: Reply with quote

How did you get it working? (currently struggling with mine...)

For improved soundquality you have to use another transport protocol like a2dp. You >could< try to edit your ~/.asoundrc to look like this:

Code:
pcm.bt_headset {
     type bluetooth
     device AA:BB:CC:DD:EE:FF
     profile hifi
}


though I don't know whether it works. Try looking into a2dp, maybe you find something.

Regards
~
_________________
Is this your only grace -
The art of conversation?

~Paradise Lost~
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum