Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fixing Japanese character entry in konsole [TIP]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 454
Location: Hokkaido Japan

PostPosted: Sat Aug 16, 2008 1:34 am    Post subject: Fixing Japanese character entry in konsole [TIP] Reply with quote

Hi -

It seems like everytime I setup a new Japanese environment in gentoo I come across this issue with Japanese input and konsole. When you enter in Japanese text into the konsole app what should display is :

Code:
日本語

After you hit the enter key, what actually displays is:
Code:
日本語日本語日本語日本語日本語日本語日本語日本語日本語日本語日本語日本語



To fix the issue do this:

  • start konsole ie. /usr/kde/3.5/bin/konsole
  • set encoding to utf8 via the konsole settings menu (settings --> encoding --> utf8)
  • save as default (settings --> save as default)
  • make sure your LANG var is set to a UTF8 variant, you can check by doing this: echo $LANG from the konsole prompt. You should get something like this: en_US.UTF-8
  • if you don't get anything you can set your LANG variable in ~/.bashrc
  • Code:
    echo LANG=\'en_US.UTF-8\' >> ~/.bashrc

  • logout and log back in and you should be able to input Japanese in konsole without the repetition issue mention above.


Cheers,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum