Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SQUIDGUARD] https ne passe pas ! (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Wed Aug 13, 2008 11:03 am    Post subject: [SQUIDGUARD] https ne passe pas ! (résolu) Reply with quote

Bonjour,


J'ai configuré squid + squidGuard simplement, tout fonctionne pour le port 80 mais pas moyen pour le 443 et c'est squidGuard qui pose problème car quand je désactive squidGuard , squid me donne accès au https.

Ma conf squid
Code:

#/etc/squid/squid.conf
#
#
#

acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl to_localhost dst 127.0.0.0/8
acl localnet src 192.168.1.0/24
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl Safe_ports port 901         # SWAT
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localnet
http_access allow localhost
http_access deny all


icp_access allow localnet
icp_access deny all

htcp_access allow localnet
htcp_access deny all

http_port 8080

redirect_program /usr/bin/squidGuard

hierarchy_stoplist cgi-bin ?

access_log /var/log/squid/access.log squid

refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern (cgi-bin|\?)    0       0%      0
refresh_pattern .               0       20%     4320

icp_port 3130

forwarded_for off
coredump_dir /var/cache/squid

check_hostnames on

error_directory /usr/share/squid/errors/French


Mon /etc/squidGuard/squidGuard.conf
Code:

# Configuration de SquidGuard

logdir /var/log/squidGuard
dbhome /etc/squidGuard/db


src salle-de-ventes {
                ip 192.168.1.20  192.168.1.21  192.168.1.22  192.168.1.23   192.168.1.24
                }


dest  clean {
        urllist         whitelist/clean
        }


acl    {
            default   {
                pass good  none
                redirect  http://127.0.0.1/cgi-bin/squidGuard.cgi?
                }
        }



J'ai cherché et rien trouvé pour l'instant .
Merci
_________________
Get Up and Go !


Last edited by man in the hill on Fri Aug 15, 2008 1:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Fri Aug 15, 2008 1:23 pm    Post subject: Reply with quote

Bonjour,

Le problème venait du fait que les requêtes https étaient redirigées vers une autre machine avec un autre nom internet donc il faut faire attention et suivre tout le chemin de connexion pour placer les bonnes adresses dans la base de donnée de squidGuard.
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum