Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wicd 1.5.1 e wpa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
rafs
n00b
n00b


Joined: 04 Aug 2008
Posts: 7

PostPosted: Tue Aug 12, 2008 10:32 pm    Post subject: wicd 1.5.1 e wpa Reply with quote

Salve a tutti,
ho notato che da qualche giorno, da quando ho aggiornato wicd alla versione 1.5.1 in portage (prima usavo quella di sunrise) ho problemi con la connessione alla mia rete wpa. Premetto che in precedenza ha sempre funzionato, ora invece per farlo funzionare devo fare questa strana procedura:
-vado nelle preferenze di wicd e metto come driver wpa supplicant madwifi
-provo la connessione e fallisce
-ritorno nelle preferenze mettendo wext
-provo la connessione e riesce!

e la cosa strana è che va solo se faccio il primo test con madwifi. con le versioni precedenti di wicd ho sempre usato wext.
se può servire la mia scheda wireless è Intel PRO/Wireless 4965AGN

grazie in anticipo per qualsiasi dritta
Back to top
View user's profile Send private message
rafs
n00b
n00b


Joined: 04 Aug 2008
Posts: 7

PostPosted: Thu Aug 14, 2008 10:05 am    Post subject: Reply with quote

una cosa importante che mi son dimenticato di dire è che wicd si blocca durante la fase di "validating authentication" e resta impallato li!
oggi ho provato a reinstallarlo ma niente da fare...
Back to top
View user's profile Send private message
rafs
n00b
n00b


Joined: 04 Aug 2008
Posts: 7

PostPosted: Sat Aug 16, 2008 4:34 pm    Post subject: Reply with quote

mah! sto continuando a fare prove e ricerche ma non ne vengo fuori!
mi sa che più che wicd sia un problema di wpa_supplicant.
ho fatto girare wicd in modalità debug e questo è l'output...se può essere utile

questo è l'output di quando fallisce:
Quote:

2008/08/14 12:44:04 :: iwconfig wlan0 essid "XXX" channel 11 ap XXX
2008/08/14 12:44:04 :: WPA_CLI RESULT IS DISCONNECTED
2008/08/14 12:44:05 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:06 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:07 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:08 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:09 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:10 :: WPA_CLI RESULT IS DISCONNECTED
2008/08/14 12:44:10 :: wpa_supplicant rescan forced...
2008/08/14 12:44:11 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:12 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:13 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:14 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:15 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:16 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:18 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:19 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:20 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:21 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:22 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:23 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:24 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:25 :: WPA_CLI RESULT IS DISCONNECTED
2008/08/14 12:44:25 :: wpa_supplicant rescan forced...
2008/08/14 12:44:26 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:27 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:28 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:29 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:30 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:31 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:32 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:33 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:34 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:35 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:36 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:37 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:38 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:39 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:40 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:44:41 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:42 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:43 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:44 :: WPA_CLI RESULT IS ASSOCIATED
2008/08/14 12:44:45 :: wpa_supplicant authentication may have failed.
2008/08/14 12:44:45 :: exiting connection thread


questo invece è l'output di quando la connessione riesce:
Quote:

2008/08/14 12:53:39 :: Stopping wpa_supplicant and any DHCP clients
2008/08/14 12:53:39 :: killall wpa_supplicant
2008/08/14 12:53:39 :: Flushing the routing table...
2008/08/14 12:53:39 :: route del dev wlan0
2008/08/14 12:53:39 :: route del dev eth0
2008/08/14 12:53:39 :: Generating psk...
2008/08/14 12:53:39 :: Attempting to authenticate...
2008/08/14 12:53:39 :: wpa_supplicant -B -i wlan0 -c "/var/lib/wicd/configurations/00184d13474c" -D wext
2008/08/14 12:53:39 :: Putting interface up...
2008/08/14 12:53:39 :: ifconfig wlan0 up
2008/08/14 12:53:39 :: iwconfig wlan0 mode managed
2008/08/14 12:53:39 :: iwconfig wlan0 essid "XXX" channel 11 ap XXX
2008/08/14 12:53:39 :: WPA_CLI RESULT IS DISCONNECTED
2008/08/14 12:53:40 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:53:41 :: WPA_CLI RESULT IS SCANNING
2008/08/14 12:53:42 :: WPA_CLI RESULT IS 4WAY_HANDSHAKE
2008/08/14 12:53:43 :: WPA_CLI RESULT IS COMPLETED
2008/08/14 12:53:43 :: Setting static IP : 192.168.0.3
2008/08/14 12:53:43 :: ifconfig wlan0 192.168.0.3 netmask 255.255.255.0
2008/08/14 12:53:43 :: Setting default gateway : 192.168.0.1
2008/08/14 12:53:43 :: route add default gw 192.168.0.1
2008/08/14 12:53:43 :: Setting DNS : 192.168.0.1
2008/08/14 12:53:43 :: Connecting thread exiting.
2008/08/14 12:53:43 :: ifconfig wlan0
2008/08/14 12:53:43 :: IP Address is: 192.168.0.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum