Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[MAJ]:J'ai cassé mon système !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Tue Aug 12, 2008 12:59 pm    Post subject: [MAJ]:J'ai cassé mon système ! Reply with quote

Bonjour,

Je n'ai pas fait de MAJ régulières de ma gentoo depuis environ 6 mois (je sais, c'est pas bien :( )
J'ai donc fait hier un emerge -uavdN world suivi d'un etc-update. Comme il y avait 196 fichiers de config à mettre à jour, j'ai fait un auto-merge (-5), histoire de gagner du temps (de toute façon quand je les fais un à un, je ne comprend pas trop ce que je fais ni les incidences que cela peut avoir - ou plutôt je comprend ce que je fais, mais je ne sais pas selon quels critères je dois mettre à jour ou non le fichier de config...)
Ensuite, pour éviter d'éventuels problèmes de librairies vcassées et autres réjouissances du genre, j'ai fait un petit revdep-rebuild qui me renvoie une erreur en me disant que le paquet engage est maské et que, de ce fait, il ne peut le ré-emerger pour satisfaire les dépendances.
Je lance donc un "layman -d enlightnment" histoire de supprimer l'overlay pour calmer mon revdep-rebuild mais là :
Code:
 Traceback (most recent call last):
 File "/usr/bin/layman", line 23, in <module>
    from   layman.config            import Config
ImportError: No module named layman.config

Entre-deux, coupure de courant, je redémarre et là, surprise, plus de kdm, un vieil xdm tout vilain...
j'essaie de lancer à la main "startkde" apres un "export DISPLAY=:0" suivi de "X&" mais c'est un échec.
Je m'aperçois alors que kde est toujours là, mais que je dois à présent l'exécuter depuis /usr/kde/3.5/bin/ sinon, rien!
kdm lui refuse de se lancer. J'arrive tant bien que mal sur mon bureau perso et la, pas de décoration des fenetres, pas de compiz-fusion. Qu'a cela ne tienne, je fais ma popote à la main, mais c'est un échec car beaucoup de librairies sont cassées.
L'éxécution de la plupart des programmes se solde par un :
Code:
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Quant au applications qui utilisent python, elles ont toutes le bec dans l'eau : la MAJ a passé la version en 2.5 et toutes mes applications. cherchent python2.4...

Bref, c'est la panique à bord commandant !

Précision : j'adore gentoo et j'ai du faire une connerie pour en arriver là.

Je vous ai écrit mon petit roman en essayant d'être le plus proche possible de la réalité et de l'ordre dans lequel j'ai effectué les opérations pour vous donner un maximum de billes pour m'aider.

Voici les caractéristiques de mon ordi :
Code:
Linux localhost 2.6.23-gentoo-r6 #11 SMP Tue Apr 8 17:29:03 CEST 2008 x86_64 Intel(R) Core(TM)2 CPU 4400 @ 2.00GHz GenuineIntel GNU/Linux


Voila, c'est à peu près tout.

J'espère évoluer et avancer dans mes connaissances sur gentoo grâce à votre aide et, cerise sur le gâteau, pourquoi pas me dépatouiller de ce pétrain.

Merci à vous ! 8)
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Aug 12, 2008 1:17 pm    Post subject: Reply with quote

Salut !
Alors, anti-conformiste tu portes bien ton nom. Peuxtu mettre ton titre en adéquation avec les règles du forum ?

Ensuite, peut-être pourrais tu commencer par un python-updater comme recommandé lors de la mise à jour de python...
Ensuite peut-être que revdep-rebuild passera mieux.

tu peux aussi ensuite essayé revdep-rebuild -L libGL.so.1


edit : tu peux aussi démasquer le paquet qui est masqué. Cf la documentation gentoo.
Ou simplement désinstallé engage
un emerge --ask --depclean pour virer des dépendances qui font chier aussi, si tu l'as pas déjà fait.
(attention à vérifier la liste des paquets)

Aussi, emerge --info serait plus utile que uname -a

Commence par python-updater et tiens nous au courant
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Wed Aug 13, 2008 7:58 am    Post subject: Re: [MAJ]:J'ai cassé mon système ! Reply with quote

anti-conformiste wrote:
Comme il y avait 196 fichiers de config à mettre à jour, j'ai fait un auto-merge (-5), histoire de gagner du temps
[snip]
Précision : j'adore gentoo et j'ai du faire une connerie pour en arriver là.

Affirmatif mon capitaine!
Cherche pas plus loin, on l'a tous faite celle-là :D

Maintenant, tu vas devenir "un homme" et réparer tout comme un grand...

+1 pour python-updater.

--
edit: 1999e message, diantre :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Aug 13, 2008 10:10 am    Post subject: Reply with quote

Ah non pas moi :twisted:
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Wed Aug 13, 2008 12:43 pm    Post subject: Reply with quote

Ouais, mais lire les docs (avant de faire une connerie) c'est tricher :lol:
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Aug 13, 2008 1:43 pm    Post subject: Reply with quote

C'est vrai que c'est pas très français de lire la doc :lol:
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Wed Aug 13, 2008 2:16 pm    Post subject: Reply with quote

t'as déja trouvé une doc avec le minitel toi ? :p
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Wed Aug 13, 2008 3:03 pm    Post subject: Reply with quote

Ouais fallait faire le 3611 MAN
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Wed Aug 13, 2008 3:26 pm    Post subject: Reply with quote

kopp wrote:
Ouais fallait faire le 3611 MAN


à ne pas confondre avec 3615 men ... ok elle est limite celle la 8)
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Aug 13, 2008 11:37 pm    Post subject: Reply with quote

El_Goretto wrote:
Ouais, mais lire les docs (avant de faire une connerie) c'est tricher :lol:


Surtout quand ca fini sur un "fait un rm -rf /" ca ira mieux"... :lol:

>> A NE PAS FAIRE !! <<
(On ne sait jamais XD)
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
ercete
Guru
Guru


Joined: 11 Dec 2003
Posts: 426
Location: France, Avignon

PostPosted: Thu Aug 14, 2008 12:02 pm    Post subject: Reply with quote

kopp wrote:
Salut !
Ensuite, peut-être pourrais tu commencer par un python-updater comme recommandé lors de la mise à jour de python...


J'en profite pour faire de la pub pour le programme "elogv" dispo dans portage qui permet de relire toutes les logs avec une interface user friendly qui fonctionne sous console (pratique quand on a cassé X 8) ).
Ainsi tu ne pourras plus rater un message t'indiquant de lancer telle ou telle commande après l'install et je ne serai plus obligé de lire les affligantes blagues désespérantes de dapsaille.
@dapsaille : tu as dépassé les bornes, la police de l'humour te condamne à une amende de 123456789 euros pour utilisation de contre-blague de catégorie 5 sans le permis adapté, tu as le droit de garder le silence, tous les paquets que tu emergeras pourront se retourner contre toi, si tu ne dispose pas d'un avocat un pingouin te seras commis d'office
_________________
Oh look... is it a stockbroker? Is it a quantity Surveyor? Is it a church warden?
NO! It's Bicycle Repair Man!

jadis raoulchatigré
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Thu Aug 14, 2008 12:19 pm    Post subject: Reply with quote

ercete wrote:

@dapsaille : tu as dépassé les bornes, la police de l'humour te condamne à une amende de 123456789 euros pour utilisation de contre-blague de catégorie 5 sans le permis adapté, tu as le droit de garder le silence, tous les paquets que tu emergeras pourront se retourner contre toi, si tu ne dispose pas d'un avocat un pingouin te seras commis d'office



:wink:
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Mon Aug 18, 2008 2:08 pm    Post subject: Reply with quote

Désolé de ne répondre que maintenant, mais sans decorateur de fenetre, c'est pas facile.

J'ai refait un emerge --sync suivi d'un emerge -uavdN world

Apres avoir réparé des dizaine de probleme, il me reste encore celui là, sur lequel je calle :

Code:
localhost ~ # python-updater
 * Starting Python Updater from 2.4 to 2.5 :
 *   Adding to list: =dev-java/java-config-1.3.7 => la ça ira
 *   Adding to list: =dev-libs/boost-1.34.1-r2     => je me debrouillerai aussi
*   Adding to list: =dev-util/subversion-1.3.2-r4 => c'est la que ça coince

These are the packages that would be merged, in order:

Calculating dependencies /
!!! All ebuilds that could satisfy "=dev-util/subversion-1.3.2-r4" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/subversion-1.3.2-r4 (masked by: )

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

localhost ~ #


Je precise que subversion est damasqué.
Pour comprendre le probleme, je l'emerge manuellement :

Code:
emerge -av subversion
[...]

configure: Apache Portable Runtime Utility (APRUTIL) library configuration
checking for APR-util... yes
checking APR-UTIL version... 1.2.10
configure: checking neon library
checking neon library version... 0.26.3
You have neon version 0.26.3,
but Subversion needs neon 0.25.5.

An appropriate version of neon could not be found, so libsvn_ra_dav
will not be built.  If you want to build libsvn_ra_dav, please either
install neon 0.25.5 on this system

or

get neon 0.25.5 from: *******************************************probleme ici*********************
    http://www.webdav.org/neon/neon-0.25.5.tar.gz
unpack the archive using tar/gunzip and rename the resulting
directory from ./neon-0.25.5/ to ./neon/

configure: error: no suitable neon found
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/subversion-1.4.6/work/subversion-1.4.6/config.log
 *
 * ERROR: dev-util/subversion-1.4.6 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 5314:  Called econf 'src_compile' 'src_compile' '--disable-javahl' '--with-swig' '--with-neon=/usr' '--with-apr=/usr/bin/apr-1-config' '--with-apr-util=/usr/bin/apu-1-config' '--without-apxs' '--with-berkeley-db' '--disable-maintainer-mode' '--enable-nls'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-util/subversion-1.4.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/subversion-1.4.6/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="." JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info


Je ne comprend pas pourquoi il veut me faire downgrader néon qui est installé en v026.4 vers la 0.25.5....
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Aug 18, 2008 2:40 pm    Post subject: Reply with quote

anti-conformiste wrote:
You have neon version 0.26.3,
but Subversion needs neon 0.25.5.

Je ne sais pas ce que tu as trifouillé avec ton arbre portage mais ce que je peux te dire c'est qu'aucune version de subversion actuellement dans portage, ni en stable ni en instable, ne réclame une version de neon inférieure à 0.26 ! :?

De plus, subversion-1.4.6 est stable, donc en principe pas besoin de démasquer quoi que ce soit !
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Mon Aug 18, 2008 2:48 pm    Post subject: Reply with quote

ghoti wrote:
anti-conformiste wrote:
You have neon version 0.26.3,
but Subversion needs neon 0.25.5.

Je ne sais pas ce que tu as trifouillé avec ton arbre portage mais ce que je peux te dire c'est qu'aucune version de subversion actuellement dans portage, ni en stable ni en instable, ne réclame une version de neon inférieure à 0.26 ! :?

De plus, subversion-1.4.6 est stable, donc en principe pas besoin de démasquer quoi que ce soit !


:?

Bin j'ai bien du mal a me dépatouiller de tout ça, il veut downgrader pas mal de paquets...
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Mon Aug 18, 2008 2:52 pm    Post subject: Reply with quote

Bon, j'ai zappé pas mal de paquets qui posaient probleme grace a un skip-first, je réemerge kde...
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Mon Aug 18, 2008 3:09 pm    Post subject: Reply with quote

Je crois que je ne vais pas m'en sortir ... :
Code:

[...]
libtool: link: cannot find the library `/usr/lib64/libavahi-qt3.la' => je réinstalle avahi (avec quels flags) ou qt ?????
[...]
* Messages for package kde-base/kdebase-3.5.9-r3:

 *
 * ERROR: kde-base/kdebase-3.5.9-r3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4177:  Called kde_src_compile
 *             environment, line 2951:  Called kde_src_compile 'src_compile'
 *             environment, line 3071:  Called kde_src_compile 'src_compile' 'all' 'myconf'
 *             environment, line 3067:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *  The die message:
 *   died running emake, kde_src_compile:make
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdebase-3.5.9-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdebase-3.5.9-r3/temp/environment'.
 *
localhost ~ #


Une idée ?
Back to top
View user's profile Send private message
anti-conformiste
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 162
Location: Saint-Omer (Pas-de-Calais)

PostPosted: Mon Aug 18, 2008 3:18 pm    Post subject: Reply with quote

je me répond.
J'ai réemergé avahi qui passe maintenant :?

Code:
>>> /usr/lib64/libavahi-common.la
>>> /usr/lib64/libavahi-qt3.la => ça doit etre ça...
>>> /usr/lib64/libavahi-qt3.so -> libavahi-qt3.so.1.0.2
>>> /usr/lib64/libavahi-common.so.3.5.0


Il m'a réinstallé la librairie qui semblait faire défaut à kdebase....
C'est reparti pour la compil de kde.....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum