Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CUPS, invio dei job di stampa molto lento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Wed Aug 06, 2008 10:29 pm    Post subject: CUPS, invio dei job di stampa molto lento Reply with quote

Ciao a tutti,

sto incontrando qualche problema con CUPS nel senso che quando provo a stampare qualcosa, il processo di invio del job di stampa al server e' di una lentezza che non mi e' mai capitato di sperimentare.

Mi spiego meglio: ho un desktop configurato come server di stampa e un notebook in cui ho configurato CUPS (attraverso il file /etc/cups/client.conf) per inviare i job di stampa al server. La stampa va a buon fine ma l'invio del job e' estremamente lento, per capirci siamo sull'ordine dei minuti. Ad esempio, quando provo a stampare un pdf, kpdf si pianta fino a che il job non e' stato inviato :-(

La mia configurazione attuale e':

- [ebuild R ] net-print/cups-1.3.7-r1 USE="X acl dbus java jpeg kerberos ldap nls pam perl png ppds python ssl tiff -avahi -php -samba -slp -static -zeroconf" LINGUAS="it -de -en -es -et -fr -he -ja -pl -sv -zh_TW" 3,805 kB

- [ebuild R ] sys-kernel/gentoo-sources-2.6.25-r7 USE="-build -symlink" 47,586 kB

Qualcuno ha avuto lo stesso problema o ha qualche idea?
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Thu Aug 07, 2008 7:48 am    Post subject: Reply with quote

Quali sono le dimensioni del file che vuoi stampare?
Se quest'ultime sono di diversi mega, i tempi lunghi sono abbastanza giustificati.
_________________
LP
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Thu Aug 07, 2008 8:06 am    Post subject: Reply with quote

macche'... sto usando come file di test un txt di 1,2 KB... :-(

Siccome avevo avuto la sensazione che questo rallentamento si fosse verificato in corrispondenza del cambio di profilo al 2008.0/desktop ho provato a ricompilare CUPS con le use flags del profilo vecchio ma niente da fare... l'invio del job e' sempre nell'ordine dei minuti (1-2 min)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Aug 07, 2008 4:24 pm    Post subject: Reply with quote

Non ho capito se stampi su una virtual printer del cups locale che poi fa il forward sul desktop o kpd cerca direttamente il cups remoto? Ti spiacerebbe essere un tantino più preciso su come hai configurato cups.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dema
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2006
Posts: 88
Location: Padova - Italy

PostPosted: Thu Aug 07, 2008 5:17 pm    Post subject: Reply with quote

djinnZ wrote:
Non ho capito se stampi su una virtual printer del cups locale che poi fa il forward sul desktop o kpd cerca direttamente il cups remoto? Ti spiacerebbe essere un tantino più preciso su come hai configurato cups.

Chiedo scusa se non sono stato sufficientemente chiaro, cercherò di spiegarmi meglio: il notebook e' configurato per inviare i job alla stampante remota che e' connessa e configurata sul desktop. Quindi per rispondere alla tua domanda: no, sul notebook non c'e' nessuna stampante virtuale; kpdf va in cerca della stampante remota ubicata sul desktop.

Questa configurazione e' stata ottenuta impostando nel file "/etc/cups/client.conf" locale (quindi sul notebook) la direttiva:
Code:
ServerName SERVER_IP_ADDR

Ovviamente questa configurazione non me la sono inventata io; ho seguito le instruzioni riportate nella sezione "Setting Up a Remote Printer" della Gentoo Printing Guide. Questa configurazione ha sempre funzionato egregiamente fino a che, non ho capito bene in corrispondenza di che evento, non si e' verificato questo problema.

Ho provato anche a verificare se questo problema e' limitato alle applicazioni di kde e il risultato e' che le applicazioni gnome (e.g. GIMP) si comportano nella stessa maniera. Lo stesso comportamento lo ottengo sia che il notebook sia connesso via wireless sia che sia connesso via ethernet.

La cosa che mi lascia perplesso e' che ho effettuato l'installazione di gentoo sul notebook di un amico giusto un paio di giorni fa, ho configurato CUPS nello stesso modo ed ottengo lo stesso comportamento :-(.

Sinceramente non ho idea di dove andare a sbattere la testa...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum