Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eclipse + PDT
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
GHopper
n00b
n00b


Joined: 28 Feb 2008
Posts: 17

PostPosted: Wed Aug 06, 2008 4:23 am    Post subject: Eclipse + PDT Reply with quote

Здравствуйте!
Установил
Eclipse SDK
Version: 3.4.0
Build id: I20080617-2000
теперь хочу прикрутить eclipsePDT. Доков - куча, и каждый по своему описывает этот процесс. И ведь не по одному не получилось...
Help->Software Update выдает:
"Cannot launch the Update UI. This installation has not been configured property for Software Updates"
Включил Windows->Preferance->General->Capabitities->Classic Update - появился классический Software Update. В нем прописывал разные адреса обновлений для eclipsePDT - но все они ругаются на нехватку какх-либо компонентов.
Кто смог это сделать, поделитесь опытом.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Fri Aug 15, 2008 2:59 pm    Post subject: Re: Eclipse + PDT Reply with quote

GHopper wrote:
Кто смог это сделать, поделитесь опытом.

У меня успешно и неоднократно получилось добавить PDT используя эту доку:
http://wiki.eclipse.org/PDT/Installation
Back to top
View user's profile Send private message
KiberGus
Tux's lil' helper
Tux's lil' helper


Joined: 16 Apr 2005
Posts: 81
Location: Moskow, Russia

PostPosted: Mon Aug 25, 2008 9:30 pm    Post subject: Re: Eclipse + PDT Reply with quote

Laitr Keiows wrote:
GHopper wrote:
Кто смог это сделать, поделитесь опытом.

У меня успешно и неоднократно получилось добавить PDT используя эту доку:
http://wiki.eclipse.org/PDT/Installation

Ух ты, прямо не верится. У меня оно работает вот так:
Quote:

Expand the Europa Discovery site to resolve dependencies. Collapsed sites will not be searched.
Select the PDT feature(s) you want to install.
Click the Select Required button to resolve missing dependencies.

И в этот момент eclipse говорит, а вот фиг вам, мне нужен такой-то feature, где его брать хрен знает. Ну из названия ясно следует пакет, в котором он находится, да и в документации к PDT он в зависимостях указывается. Дописываем еще один источник для обновлений, повторяем процедуру, ищем вторую зависимость... ищем 5ую зависимость, снова select required - "хрен вам, мне нужен очередной feature", причем на этот раз поиск молчит, а название указывает на то, что этоа штука входит в основную поставку, она там и правда есть, только версия не подходит. Видите ли, их система не отслеживает контроль версий. Ну ладно, раз Europe слишком старая, размаскируем новую версию eclipse и повторяем всю эту байду, заодно переписываем идиотский скрипт запуска, который запрещает запуск от рута. Мне лучше знать, от какого пользователя запускаться, когда надо поставить что-то для всех пользовтелей. Все повторяется, только теперь конфликтуют другие компоненты.
Вот такие вот дела. Дома мне один раз удалось поставить pdt. А итог таков: eclipse suxx, дети в школе, для которых ставился eclipse будут пользоваться моим любимым gvim'ом или kate'ом или любым другим редактором, но не eclipse.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Mon Aug 25, 2008 11:15 pm    Post subject: Re: Eclipse + PDT Reply with quote

KiberGus wrote:
Quote:

Expand the Europa Discovery site to resolve dependencies. Collapsed sites will not be searched.

Вот такие вот дела. Дома мне один раз удалось поставить pdt. А итог таков: eclipse suxx, дети в школе, для которых ставился eclipse будут пользоваться моим любимым gvim'ом или kate'ом или любым другим редактором, но не eclipse.

Правильно пишет. Надо раскрыть дерево Europa Discovery и тогда все зависимости сами подберутся. Учите английский :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum