Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200807-16 ] Python: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1703

PostPosted: Fri Aug 01, 2008 12:26 am    Post subject: [ GLSA 200807-16 ] Python: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Python: Multiple vulnerabilities (GLSA 200807-16)
Severity: normal
Exploitable: remote
Date: July 31, 2008
Updated: July 19, 2009
Bug(s): #230640, #232137
ID: 200807-16

Synopsis


Multiple vulnerabilities in Python may allow for the execution of arbitrary
code.


Background


Python is an interpreted, interactive, object-oriented programming
language.


Affected Packages

Package: dev-lang/python
Vulnerable: < 2.5.2-r6
Unaffected: >= 2.4.4-r14 < 2.4.5
Unaffected: >= 2.5.2-r6
Unaffected: >= 2.4.6 < 2.4.7
Architectures: All supported architectures


Description


Multiple vulnerabilities were discovered in Python:

  • David Remahl of Apple Product Security reported several integer
    overflows in core modules such as stringobject, unicodeobject,
    bufferobject, longobject, tupleobject, stropmodule, gcmodule,
    mmapmodule (CVE-2008-2315).

  • David Remahl of Apple Product Security also reported an integer
    overflow in the hashlib module, leading to unreliable cryptographic
    digest results (CVE-2008-2316).

  • Justin Ferguson reported multiple buffer overflows in unicode string
    processing that only affect 32bit systems (CVE-2008-3142).

  • The Google Security Team reported multiple integer overflows
    (CVE-2008-3143).

  • Justin Ferguson reported multiple integer underflows and overflows in
    the PyOS_vsnprintf() function, and an off-by-one error when passing
    zero-length strings, leading to memory corruption (CVE-2008-3144).


Impact


A remote attacker could exploit these vulnerabilities in Python
applications or daemons that pass user-controlled input to vulnerable
functions. Exploitation might lead to the execution of arbitrary code
or a Denial of Service. Vulnerabilities within the hashlib might lead
to weakened cryptographic protection of data integrity or authenticity.


Workaround


There is no known workaround at this time.


Resolution


All Python 2.4 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r14"

All Python 2.5 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/python-2.5.2-r6"

Please note that Python 2.3 is masked since June 24, and we will not be
releasing updates to it. It will be removed from the tree in the near
future.


References

CVE-2008-2315
CVE-2008-2316
CVE-2008-3142
CVE-2008-3143
CVE-2008-3144


Last edited by GLSA on Sun Oct 26, 2014 4:27 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum