Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python updater keeps wanting to update vte and boost
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
phsdv
Guru
Guru


Joined: 13 Mar 2005
Posts: 372
Location: Europe

PostPosted: Tue Aug 05, 2008 7:19 pm    Post subject: python updater keeps wanting to update vte and boost Reply with quote

I ran python-updater to update python from 2.4 to 2.5. Many application were re-emerged, including vte and boost. When I run python-updater again it wants to re-emerge vte and boost again. So I did that, but python-updater still wants to update both packages again if I run python-updater another time:
Code:
 /usr/sbin/python-updater -p
 * Starting Python Updater from 2.4 to 2.5 :
 *   Adding to list: =x11-libs/vte-0.16.14
 *   Adding to list: =dev-libs/boost-1.34.1-r2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/boost-1.34.1-r2  USE="-debug -doc -icu -pyste -tools" 0 kB
[ebuild   R   ] x11-libs/vte-0.16.14  USE="opengl python -debug -doc" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
Is this normal behavior? (I do not think so). Or is there something wrong on my system? Or a bug? Can I safely unmerge python-2.4, or better wait until this is solved?
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Tue Aug 05, 2008 7:29 pm    Post subject: Re: python updater keeps wanting to update vte and boost Reply with quote

phsdv wrote:
Code:
 /usr/sbin/python-updater -p
 * Starting Python Updater from 2.4 to 2.5 :
 *   Adding to list: =x11-libs/vte-0.16.14
 *   Adding to list: =dev-libs/boost-1.34.1-r2

If you run with the --verbose switch, it'll add "check: manual [Added to list manually]" to each of those list items. The man page tells us
man python-updater wrote:

manual
python-updater has a list of packages that are known to break
by python upgrades but can’t be determined by methods specified
above. This check can be disabled if you’re sure you’ve rebuilt
the package once and it’s OK now.
Enabled by default.


So yes, this is normal, but highly non-obvious and there's no shame in not figuring it out for yourself. At the very least, it should add the "manual" annotation without any special switches, preferably with a reference to the man page for more information.
Back to top
View user's profile Send private message
phsdv
Guru
Guru


Joined: 13 Mar 2005
Posts: 372
Location: Europe

PostPosted: Wed Aug 06, 2008 4:29 pm    Post subject: Reply with quote

dleverton, thank you for the explanation. Next team I will also 'read the fine man' (rtfm) pages ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum