Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Instalação de impressora.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Mon Aug 04, 2008 3:37 pm    Post subject: Instalação de impressora. Reply with quote

Oi, pessoal:

Estou tentando fazer funcionar uma impressora HP Deskjet-930C.
Segui todos os passos do manual mas não imprime a página de teste.
Usei os drives hpijs e gutenprint sem resultados.

Aparece na pagina localhost:631 o seguinte: /usr/libexec/cups/filter/foomatic-rip failed

# tail /var/log/cups/error_log

I [04/Aug/2008:12:15:18 -0300] [Job 13] Started filter /usr/libexec/cups/filter/pstops (PID 30639)
I [04/Aug/2008:12:15:18 -0300] [Job 13] Started filter /usr/libexec/cups/filter/foomatic-rip (PID 30640)
I [04/Aug/2008:12:15:18 -0300] [Job 13] Started backend /usr/libexec/cups/backend/usb (PID 30641)
E [04/Aug/2008:12:15:18 -0300] PID 30640 (/usr/libexec/cups/filter/foomatic-rip) stopped with status 1!
I [04/Aug/2008:12:15:18 -0300] Hint: Try setting the LogLevel to "debug" to find out more.
E [04/Aug/2008:12:15:18 -0300] [Job 13] Job stopped due to filter errors.
I [04/Aug/2008:12:15:20 -0300] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=30649)
I [04/Aug/2008:12:15:40 -0300] Started "/usr/libexec/cups/cgi-bin/jobs.cgi" (pid=30651)
I [04/Aug/2008:12:15:40 -0300] [Job 13] Canceled by "root".
I [04/Aug/2008:12:15:46 -0300] Started "/usr/libexec/cups/cgi-bin/printers.cgi" (pid=30652)

Agradeço qualquer ajuda.

[ ]'s.
Back to top
View user's profile Send private message
herkusPT
n00b
n00b


Joined: 15 Feb 2008
Posts: 11

PostPosted: Mon Aug 04, 2008 6:18 pm    Post subject: Reply with quote

tenta reinstalar o

cups
gutenprint

eu no make.conf tenho

cups ppds slp foomaticdb gimpprint xprint

não sei se isto serve de alguma coisa mas se ajudar diz :D


A minha impressora é uma epson stylus DX5000 e funciona bem

HerkusPT
_________________
HerkusPT
Back to top
View user's profile Send private message
cassiol
Guru
Guru


Joined: 16 Oct 2006
Posts: 304
Location: /BR/SC/FLORIPA

PostPosted: Tue Aug 05, 2008 5:20 pm    Post subject: Reply with quote

ola....
eu recomendo vc usar o hplip. com ele não tenho problemas...
qualquer duvidade posta ai denovo....
para utilizar o hplip e soh dar emerge no cups e hplip, iniciaor cups e adicionar a impressora com o backend do hplip..
qualquer duvida posta ai denovo...
_________________
before post......... try that search in google: site:forums.gentoo.org your question
please add [SOLVED] when your question is solved
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Thu Aug 07, 2008 3:25 am    Post subject: Reply with quote

cassiol:

Fiz o que mandou e nada de impressão.
Continua aparecendo a msg /usr/libexec/cups/filter/foomatic-rip failed"
Esse /usr/libexec/cups/filter/foomatic-rip é um ln para /usr/bin/foomatic-rip
O foomatic-rip é um arquivo em perl que no início dá algumas instruções que segui direitinho.
Já procurei nos docs do cups, foomatic e não consegui sair da origem...

Vou dar uma olhada nos foruns em espanhol e inglês para ver se acho alguma coisa.

[ ]'s.
Back to top
View user's profile Send private message
souadriano
n00b
n00b


Joined: 06 Jun 2008
Posts: 32
Location: João Pessoa - PB

PostPosted: Thu Aug 07, 2008 5:16 pm    Post subject: Reply with quote

da uma olhadinha neste site:

http://br-linux.org/tutoriais/002046.html

pode ser que ajude
Back to top
View user's profile Send private message
cassiol
Guru
Guru


Joined: 16 Oct 2006
Posts: 304
Location: /BR/SC/FLORIPA

PostPosted: Thu Aug 07, 2008 8:29 pm    Post subject: Reply with quote

ola...

o que acontence quando vc tente executar /usr/libexec/cups/filter/foomatic-rip ?
provavelmente deve dar um erro, que deve ser uma dependencia faltando..
execute revdep-rebuild.
qualquer coisa posta ai denovo...
_________________
before post......... try that search in google: site:forums.gentoo.org your question
please add [SOLVED] when your question is solved
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Thu Aug 07, 2008 10:17 pm    Post subject: Reply with quote

Prezados cassiol e souadriano:

Agradeço a colaboração e vou tentar o que foi aconselhado por vcs.

Depois reporto o resultado.

[ ]'s.
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Mon Aug 11, 2008 4:31 pm    Post subject: Reply with quote

Prezados cassiol e souadriano:

Depois de instalar o hplip e configurar a impressora, foi impressa uma página de teste.

Porém, quando tentei imprimir um texto a partir do mousepad não consegui.

Na janela do Xfprint só aparece imprimir para arquivo.

O que está havendo?

[ ]'s.
Back to top
View user's profile Send private message
cassiol
Guru
Guru


Joined: 16 Oct 2006
Posts: 304
Location: /BR/SC/FLORIPA

PostPosted: Tue Aug 12, 2008 1:14 pm    Post subject: Reply with quote

olaaaa


vc compilou o X com suporte ao cups???
_________________
before post......... try that search in google: site:forums.gentoo.org your question
please add [SOLVED] when your question is solved
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Tue Aug 12, 2008 3:34 pm    Post subject: Reply with quote

Oi, cassiol:

Desculpe a ignorância mas não entendi isso de compilar o X.
Por favor me diga o que é e como fazer.

O que não estou compreendendo é o seguinte:

A configuração da impressora pelo cups (localhost:631) parece que está ok,
tanto que imprime a página de teste perfeitamente.

A configuração pelo hplip (hp-setup) tb imprime uma página de teste sem problemas.

A saída do lsusb:

Bus 001 Device 001: ID 0000:0000
Bus 005 Device 004: ID 03f0:1204 Hewlett-Packard DeskJet 930c
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
ERROR:
Bus 002 Device 001: ID 0000:0000

Pelo visto a impressora está reconhecida e conectada.

Mas se entrar no aplicativo HP Device Manager aparece o ícone de impressora desconectada e a msg de erro:

ERROR:Device not found.Please check connection and power-on device.

Por outro lado o /var/log/messages informa:

tail -f /var/log/messages
Aug 12 12:16:16 localhost python: hp-toolbox[5286]: error: Invalid locale: C.utf8
Aug 12 12:16:16 localhost python: io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Aug 12 12:16:16 localhost python: io/hpmud/musb.c 1003: unable to open hp:/usb/DeskJet_930C?serial=BR14J1T1TXJJ
Aug 12 12:16:16 localhost python: hp-toolbox[5286]: error: Unable to communicate with device (code=12): hp:/usb/DeskJet_930C?serial=BR14J1T1TXJJ
Aug 12 12:16:16 localhost python: hp-toolbox[5286]: warning: Device not found
Aug 12 12:16:16 localhost python: io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Aug 12 12:16:16 localhost python: io/hpmud/musb.c 1003: unable to open hp:/usb/DeskJet_930C?serial=BR14J1T1TXJJ
Aug 12 12:16:16 localhost python: hp-toolbox[5286]: error: Unable to communicate with device (code=12): hp:/usb/DeskJet_930C?serial=BR14J1T1TXJJ
Aug 12 12:16:16 localhost python: hp-toolbox[5286]: warning: Device not found
Aug 12 12:20:01 localhost cron[5307]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )

Não encontrei nada na página do howto do hplip.

E agora?
[ ]'s.
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Sat Aug 16, 2008 11:36 am    Post subject: Reply with quote

Boas,

Há algum tempo tive problemas com uma impressora usb que também só imprimia as vezes e muitas vezes só a folha de teste, dava os seguintes erros e resolvi como descrevo a seguir .. ...

Erro na impressão “permission denied em /dev/null“

Solução como root executar o comando :

chmod 666 /dev/null

Erro na impressão “unable to open usb device”

Solução como root executar o comando :

chmod 666 /dev/usb/lp0

Possivelmente tens de verificar qual o dispositivo correcto tipo /dev/usb/lp0 ou lp1 etc ...
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum