Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage] pb avec coreutils-6.9-r1 et aclocal
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
maufab
n00b
n00b


Joined: 08 Feb 2006
Posts: 34
Location: Ariège

PostPosted: Fri Aug 01, 2008 5:55 pm    Post subject: [portage] pb avec coreutils-6.9-r1 et aclocal Reply with quote

Bonjour, lors de l'installation de coreutils suite à une màj de world, j'ai une erreur sur coreutils:
Code:
 Building (1 of 1) sys-apps/coreutils-6.9-r1
 * coreutils-6.9.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                       [ ok ]
 * coreutils-6.9-patches-1.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                           [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                           [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                          [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking coreutils-6.9.tar.bz2 to /var/tmp/portage/sys-apps/coreutils-6.9-r1/work
>>> Unpacking coreutils-6.9-patches-1.3.tar.bz2 to /var/tmp/portage/sys-apps/coreutils-6.9-r1/work
 * Applying gnulib-futimens-rename.patch ...                                                                                                                                    [ ok ]
 * Applying ACL patches ...
 *   004_all_coreutils-acl-xattr.patch ...                                                                                                                                      [ ok ]
 *   006_all_coreutils-acl-control.patch ...                                                                                                                                    [ ok ]
 * Done with patching
 * Applying various patches (bugfixes/updates) ...
 *   000_all_coreutils-i18n.patch ...                                                                                                                                           [ ok ]
 *   003_all_coreutils-gentoo-uname.patch ...                                                                                                                                   [ ok ]
 *   009_all_coreutils-tests.patch ...                                                                                                                                          [ ok ]
 *   030_all_coreutils-more-dir-colors.patch ...                                                                                                                                [ ok ]
 *   150_all_coreutils-l10n-updates.patch ...                                                                                                                                   [ ok ]
 *   200_all_coreutils-ls-x.patch ...                                                                                                                                           [ ok ]
 * Done with patching
 * Running eautoreconf in '/var/tmp/portage/sys-apps/coreutils-6.9-r1/work/coreutils-6.9' ...
 * Running aclocal -I m4 -I m4 ...                                                                                                                                              [ !! ]

 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/sys-apps/coreutils-6.9-r1/temp/aclocal-24713.out

 * ERROR: sys-apps/coreutils-6.9-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2969:  Called eautoreconf
 *             environment, line  988:  Called eaclocal
 *             environment, line  927:  Called autotools_run_tool 'aclocal' '-I' 'm4' '-I' 'm4'
 *             environment, line  459:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/coreutils-6.9-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/coreutils-6.9-r1/temp/environment'.



Code:
***** aclocal *****
***** aclocal -I m4 -I m4

configure.ac:38: error: AC_REQUIRE: circular dependency of AC_GNU_SOURCE
m4/extensions.m4:19: AC_USE_SYSTEM_EXTENSIONS is expanded from...
../../lib/autoconf/specific.m4:331: AC_GNU_SOURCE is expanded from...
m4/gnulib-comp.m4:23: gl_EARLY is expanded from...
configure.ac:38: the top level
autom4te-2.62: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1


Last edited by maufab on Mon Aug 04, 2008 4:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Sat Aug 02, 2008 9:33 am    Post subject: Reply with quote

Bonjour,

Pourrais tu faire mettre ton titre en conformité et nous poster ton emerge --info?
Back to top
View user's profile Send private message
maufab
n00b
n00b


Joined: 08 Feb 2006
Posts: 34
Location: Ariège

PostPosted: Mon Aug 04, 2008 4:32 pm    Post subject: Reply with quote

Pas de souci; voilà, c'est fait :

Code:
emerge --info
Portage 2.2_rc4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r6-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-glibc2.2.5
Timestamp of tree: Tue, 29 Jul 2008 16:00:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 acl alsa amd64 apache2 berkdb bzip2 cdparanoia cli cracklib crypt cups dri dssi dvd dvdread ffmpeg fortran gdbm gpm gtk hal iconv isdnlog midi mmx mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg openmp oss pam pcre perl php pppd python readline reflection session spl sse sse2 ssl symlink sysfs tcpd unicode userlocales videos vorbis xml xml2 xorg zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="fglrx vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
maufab
n00b
n00b


Joined: 08 Feb 2006
Posts: 34
Location: Ariège

PostPosted: Fri Aug 08, 2008 5:37 pm    Post subject: Reply with quote

Bon, visiblement, ça n'inspire personne...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum